summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-21 19:39:34 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-21 19:39:34 +0000
commit75f7d4c6df2b0d50a83f6976ca3bf1e878a24abd (patch)
treeb840759f913f4edf70fdafdc7f87a5d3c764b4a5 /games-engines
parentversion bump of to 1.4.0_rc1 of the 1.4.x series (security update) (diff)
downloadgentoo-2-75f7d4c6df2b0d50a83f6976ca3bf1e878a24abd.tar.gz
gentoo-2-75f7d4c6df2b0d50a83f6976ca3bf1e878a24abd.tar.bz2
gentoo-2-75f7d4c6df2b0d50a83f6976ca3bf1e878a24abd.zip
fix tail call; fix gcc version detection (bug #82836)
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog6
-rw-r--r--games-engines/scummvm/files/0.7.0-configure.patch19
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.6.1b1
-rw-r--r--games-engines/scummvm/scummvm-0.6.1b.ebuild66
-rw-r--r--games-engines/scummvm/scummvm-0.7.0.ebuild8
5 files changed, 31 insertions, 69 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index b0f7240f2715..77f6dcf9ac70 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/scummvm
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.20 2005/01/24 04:29:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.21 2005/02/21 19:39:34 mr_bones_ Exp $
+
+ 21 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.7.0-configure.patch, -scummvm-0.6.1b.ebuild, scummvm-0.7.0.ebuild:
+ fix tail call; fix gcc version detection (bug #82836)
23 Jan 2005; Michael Sterrett <mr_bones_@gentoo.org> scummvm-0.7.0.ebuild:
fix non-working option (bug #79279)
diff --git a/games-engines/scummvm/files/0.7.0-configure.patch b/games-engines/scummvm/files/0.7.0-configure.patch
new file mode 100644
index 000000000000..8fbddcff2491
--- /dev/null
+++ b/games-engines/scummvm/files/0.7.0-configure.patch
@@ -0,0 +1,19 @@
+--- configure.orig 2005-02-21 14:32:17.000000000 -0500
++++ configure 2005-02-21 14:33:46.000000000 -0500
+@@ -462,14 +462,14 @@
+
+ echocheck "compiler version"
+
+-cxx_name=`( $cc -v ) 2>&1 | tail -1 | cut -d ' ' -f 1`
++cxx_name=`( $cc -v ) 2>&1 | tail -n 1 | cut -d ' ' -f 1`
+ cxx_version=`( $CXX -dumpversion ) 2>&1`
+ if test "$?" -gt 0; then
+ cxx_version="not found"
+ fi
+
+ case $cxx_version in
+- 2.95.[2-9]|2.95.[2-9][-.]*|3.[0-9]|3.[0-9].[0-9])
++ 2.95.[2-9]|2.95.[2-9][-.]*|3.[0-9]|3.[0-9].[0-9]|3.[0-9].[0-9]-*)
+ _cxx_major=`echo $cxx_version | cut -d '.' -f 1`
+ _cxx_minor=`echo $cxx_version | cut -d '.' -f 2`
+ cxx_version="$cxx_version, ok"
diff --git a/games-engines/scummvm/files/digest-scummvm-0.6.1b b/games-engines/scummvm/files/digest-scummvm-0.6.1b
deleted file mode 100644
index bf91203d2931..000000000000
--- a/games-engines/scummvm/files/digest-scummvm-0.6.1b
+++ /dev/null
@@ -1 +0,0 @@
-MD5 143dd7cfe0995922c49e1f8a6cdf2055 scummvm-0.6.1b.tar.bz2 1626950
diff --git a/games-engines/scummvm/scummvm-0.6.1b.ebuild b/games-engines/scummvm/scummvm-0.6.1b.ebuild
deleted file mode 100644
index aa77b5698d10..000000000000
--- a/games-engines/scummvm/scummvm-0.6.1b.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.6.1b.ebuild,v 1.4 2005/01/20 06:57:34 mr_bones_ Exp $
-
-inherit fixheadtails eutils games
-
-DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
-HOMEPAGE="http://scummvm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc amd64 sparc"
-IUSE="alsa debug mad oggvorbis sdl zlib"
-
-DEPEND="virtual/libc
- virtual/x11
- >media-libs/libmpeg2-0.3.1
- sdl? ( >=media-libs/libsdl-1.2.2 )
- oggvorbis? (
- media-libs/libogg
- media-libs/libvorbis
- )
- alsa? ( >=media-libs/alsa-lib-0.9 )
- mad? ( media-libs/libmad )
- zlib? ( sys-libs/zlib )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # configure luvin from bug #64550
- ht_fix_file configure
- sed -i \
- -e "s:/tmp/:./:" configure \
- || die "sed configure failed"
-}
-
-src_compile() {
- local myconf=
-
- use sdl \
- && myconf="${myconf} --backend=sdl" \
- || myconf="${myconf} --backend=x11"
- use debug \
- || myconf="${myconf} --disable-debug"
-
- # not an autoconf script so dont call econf
- ./configure \
- $(use_enable alsa) \
- $(use_enable mad) \
- $(use_enable oggvorbis vorbis) \
- $(use_enable zlib) \
- ${myconf} \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dogamesbin scummvm || die "dobin failed"
- doman scummvm.6
- dodoc NEWS README TODO
- insinto /usr/share/pixmaps
- doins scummvm.xpm || die "doins failed"
- make_desktop_entry scummvm ScummVM
- prepgamesdirs
-}
diff --git a/games-engines/scummvm/scummvm-0.7.0.ebuild b/games-engines/scummvm/scummvm-0.7.0.ebuild
index ea0b129eb373..fa0ca09c4feb 100644
--- a/games-engines/scummvm/scummvm-0.7.0.ebuild
+++ b/games-engines/scummvm/scummvm-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.7.0.ebuild,v 1.6 2005/01/24 04:29:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.7.0.ebuild,v 1.7 2005/02/21 19:39:34 mr_bones_ Exp $
inherit eutils games
@@ -29,6 +29,12 @@ RDEPEND="virtual/libc
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-configure.patch"
+}
+
src_compile() {
local myconf=