summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-30 01:44:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-30 01:44:11 +0000
commit65bdd5f53bf54e69b8e0178baf23760322e11639 (patch)
tree3dba07299a2abb0ed65168aa033aa0ab53aac254 /games-engines
parentOnly unpack cjk patch if cjk flag is set for bug 120888. (diff)
downloadgentoo-2-65bdd5f53bf54e69b8e0178baf23760322e11639.tar.gz
gentoo-2-65bdd5f53bf54e69b8e0178baf23760322e11639.tar.bz2
gentoo-2-65bdd5f53bf54e69b8e0178baf23760322e11639.zip
old
(Portage version: 2.0.54)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/files/0.7.1-configure.patch19
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.7.11
-rw-r--r--games-engines/scummvm/files/scummvm-0.7.1-64bit.patch35
-rw-r--r--games-engines/scummvm/scummvm-0.7.1.ebuild64
4 files changed, 0 insertions, 119 deletions
diff --git a/games-engines/scummvm/files/0.7.1-configure.patch b/games-engines/scummvm/files/0.7.1-configure.patch
deleted file mode 100644
index e174994aa2ff..000000000000
--- a/games-engines/scummvm/files/0.7.1-configure.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.orig 2005-03-28 18:50:50.000000000 -0500
-+++ configure 2005-03-28 18:56:08.000000000 -0500
-@@ -462,14 +462,14 @@
-
- echocheck "compiler version"
-
--cxx_name=`( $cc -v ) 2>&1 | tail -1 | cut -d ' ' -f 1`
-+cxx_name=`( $cc -v ) 2>&1 | tail -n 1 | cut -d ' ' -f 1`
- cxx_version=`( $CXX -dumpversion ) 2>&1`
- if test "$?" -gt 0; then
- cxx_version="not found"
- fi
-
- case $cxx_version in
-- 2.95.[2-9]|2.95.[2-9][-.]*|3.[0-9]|3.[0-9].[0-9]|4.[0-9].[0-9])
-+ 2.95.[2-9]|2.95.[2-9][-.]*|3.[0-9]|3.[0-9].[0-9]|3.[0-9].[0-9]-*|4.[0-9].[0-9]|4.[0-9].[0-9]-*)
- _cxx_major=`echo $cxx_version | cut -d '.' -f 1`
- _cxx_minor=`echo $cxx_version | cut -d '.' -f 2`
- cxx_version="$cxx_version, ok"
diff --git a/games-engines/scummvm/files/digest-scummvm-0.7.1 b/games-engines/scummvm/files/digest-scummvm-0.7.1
deleted file mode 100644
index 945a8a522727..000000000000
--- a/games-engines/scummvm/files/digest-scummvm-0.7.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a935499011c59441fcce8322ea1c4f1d scummvm-0.7.1.tar.bz2 2051004
diff --git a/games-engines/scummvm/files/scummvm-0.7.1-64bit.patch b/games-engines/scummvm/files/scummvm-0.7.1-64bit.patch
deleted file mode 100644
index 224b7106718d..000000000000
--- a/games-engines/scummvm/files/scummvm-0.7.1-64bit.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Fixes for 64bit issues from upstream.
-
-http://bugs.gentoo.org/103450
-
---- scummvm/scummvm/common/scaler.cpp
-+++ scummvm/scummvm/common/scaler.cpp
-@@ -123,7 +123,7 @@
- int width, int height) {
- uint8 *r;
-
-- assert(((int)dstPtr & 3) == 0);
-+ assert(((long)dstPtr & 3) == 0);
- while (height--) {
- r = dstPtr;
- for (int i = 0; i < width; ++i, r += 4) {
-@@ -148,7 +148,7 @@
- const uint32 dstPitch2 = dstPitch * 2;
- const uint32 dstPitch3 = dstPitch * 3;
-
-- assert(((int)dstPtr & 1) == 0);
-+ assert(((long)dstPtr & 1) == 0);
- while (height--) {
- r = dstPtr;
- for (int i = 0; i < width; ++i, r += 6) {
---- scummvm/scummvm/scumm/instrument.h
-+++ scummvm/scummvm/scumm/instrument.h
-@@ -60,7 +60,7 @@
-
- void clear();
- void copy_to (Instrument *dest) { if (_instrument) _instrument->copy_to (dest); else dest->clear(); }
-- operator int() { return (_instrument ? (int) _instrument : 255); }
-+ operator int() { return (_instrument ? (long) _instrument : 255); }
- void program (byte program, bool mt32);
- void adlib (byte *instrument);
- void roland (byte *instrument);
diff --git a/games-engines/scummvm/scummvm-0.7.1.ebuild b/games-engines/scummvm/scummvm-0.7.1.ebuild
deleted file mode 100644
index bd49fda07aff..000000000000
--- a/games-engines/scummvm/scummvm-0.7.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.7.1.ebuild,v 1.5 2005/09/01 03:18:31 vapier Exp $
-
-inherit eutils games
-
-DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
-HOMEPAGE="http://scummvm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE="alsa debug flac mp3 ogg vorbis sdl zlib"
-RESTRICT="test" # it only looks like there's a test there #77507
-
-RDEPEND=">=media-libs/libsdl-1.2.2
- >media-libs/libmpeg2-0.3.1
- ogg? ( media-libs/libogg media-libs/libvorbis )
- vorbis? ( media-libs/libogg media-libs/libvorbis )
- alsa? ( >=media-libs/alsa-lib-0.9 )
- mp3? ( media-libs/libmad )
- flac? ( media-libs/flac )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-configure.patch
- epatch "${FILESDIR}"/${P}-64bit.patch
-}
-
-src_compile() {
- local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
-
- use debug \
- || myconf="${myconf} --disable-debug"
- (use vorbis || use ogg) \
- && myconf="${myconf} --enable-vorbis" \
- || myconf="${myconf} --disable-vorbis --disable-mpeg2"
-
- # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
- # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
- ./configure \
- $(use_enable alsa) \
- $(use_enable mp3 mad) \
- $(use_enable flac) \
- $(use_enable zlib) \
- $(use_enable x86 nasm) \
- ${myconf} \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dogamesbin scummvm || die "dobin failed"
- doman scummvm.6
- dodoc NEWS README TODO
- doicon scummvm.xpm
- make_desktop_entry scummvm ScummVM
- prepgamesdirs
-}