summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-06-17 06:36:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-06-17 06:36:03 +0000
commit39f5d11e6befa2bc730ec45ff030e12419aca393 (patch)
treee886c1af13446ca39d7cb9f6f977be4c35a5509e /games-engines
parentBump (diff)
downloadgentoo-2-39f5d11e6befa2bc730ec45ff030e12419aca393.tar.gz
gentoo-2-39f5d11e6befa2bc730ec45ff030e12419aca393.tar.bz2
gentoo-2-39f5d11e6befa2bc730ec45ff030e12419aca393.zip
add missing theora USE flag (bug #513366)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog5
-rw-r--r--games-engines/scummvm/scummvm-1.6.0.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index ddd724aa16cc..11c0d1f4ec90 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.129 2014/05/15 16:43:34 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.130 2014/06/17 06:36:03 mr_bones_ Exp $
+
+ 17 Jun 2014; Michael Sterrett <mr_bones_@gentoo.org> scummvm-1.6.0.ebuild:
+ add missing theora USE flag (bug #513366)
15 May 2014; Ulrich Müller <ulm@gentoo.org> scummvm-1.5.0.ebuild,
scummvm-1.6.0.ebuild:
diff --git a/games-engines/scummvm/scummvm-1.6.0.ebuild b/games-engines/scummvm/scummvm-1.6.0.ebuild
index 5230780d2541..d33f9f02d296 100644
--- a/games-engines/scummvm/scummvm-1.6.0.ebuild
+++ b/games-engines/scummvm/scummvm-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.6.0.ebuild,v 1.2 2014/05/15 16:43:34 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.6.0.ebuild,v 1.3 2014/06/17 06:36:03 mr_bones_ Exp $
EAPI=5
inherit eutils flag-o-matic gnome2-utils toolchain-funcs games
@@ -12,12 +12,13 @@ SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="aac alsa debug flac fluidsynth mp3 opengl truetype vorbis"
+IUSE="aac alsa debug flac fluidsynth mp3 opengl theora truetype vorbis"
RESTRICT="test" # it only looks like there's a test there #77507
RDEPEND=">=media-libs/libsdl-1.2.2[sound,joystick,video]
sys-libs/zlib
vorbis? ( media-libs/libogg media-libs/libvorbis )
+ theora? ( media-libs/libtheora )
aac? ( media-libs/faad2 )
alsa? ( media-libs/alsa-lib )
mp3? ( media-libs/libmad )
@@ -67,6 +68,7 @@ src_configure() {
$(use_enable flac) \
$(use_enable opengl) \
$(use_enable vorbis) \
+ $(use_enable theora theoradec) \
$(use_enable truetype freetype2) \
$(use_enable x86 nasm) \
${myconf} || die