summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-02-10 20:48:14 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-02-10 20:48:14 +0000
commitfca14bd74fac8aa362a5004fc4a6ee9d7b55faff (patch)
treef248fa0a5c361c40be2ffc00bbe0aad72a363f4c /games-engines/scummvm
parentAdded RDEPEND to DEPEND so we pull in libsdl for building. (diff)
downloadgentoo-2-fca14bd74fac8aa362a5004fc4a6ee9d7b55faff.tar.gz
gentoo-2-fca14bd74fac8aa362a5004fc4a6ee9d7b55faff.tar.bz2
gentoo-2-fca14bd74fac8aa362a5004fc4a6ee9d7b55faff.zip
Version bumped to 0.8.2 and closing bug #122261.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'games-engines/scummvm')
-rw-r--r--games-engines/scummvm/ChangeLog8
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.8.23
-rw-r--r--games-engines/scummvm/files/scummvm-0.8.2-configure.patch8
-rw-r--r--games-engines/scummvm/scummvm-0.8.2.ebuild73
4 files changed, 91 insertions, 1 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 8360ba8d4385..11537d7d972c 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.28 2006/01/31 05:36:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.29 2006/02/10 20:48:14 wolf31o2 Exp $
+
+*scummvm-0.8.2 (10 Feb 2006)
+
+ 10 Feb 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/scummvm-0.8.2-configure.patch, +scummvm-0.8.2.ebuild:
+ Version bumped to 0.8.2 and closing bug #122261.
*scummvm-0.8.1 (31 Jan 2006)
diff --git a/games-engines/scummvm/files/digest-scummvm-0.8.2 b/games-engines/scummvm/files/digest-scummvm-0.8.2
new file mode 100644
index 000000000000..c817411ef896
--- /dev/null
+++ b/games-engines/scummvm/files/digest-scummvm-0.8.2
@@ -0,0 +1,3 @@
+MD5 60c6977add285175c1133a3017512ce7 scummvm-0.8.2.tar.bz2 2698022
+RMD160 dfc40778bee6156c816435086e5c5d42eef3e5de scummvm-0.8.2.tar.bz2 2698022
+SHA256 3877a7a4f9376c3ce4c014972c58f129bb8285c8241d193b0aec37b52a81d517 scummvm-0.8.2.tar.bz2 2698022
diff --git a/games-engines/scummvm/files/scummvm-0.8.2-configure.patch b/games-engines/scummvm/files/scummvm-0.8.2-configure.patch
new file mode 100644
index 000000000000..0b955c2b6ab2
--- /dev/null
+++ b/games-engines/scummvm/files/scummvm-0.8.2-configure.patch
@@ -0,0 +1,8 @@
+--- configure
++++ configure
+@@ -433,4 +433,5 @@
+ _backend=`echo $ac_option | cut -d '=' -f 2`
+ ;;
++ --enable-debug);;
+ --disable-debug)
+ DEBFLAGS=""
diff --git a/games-engines/scummvm/scummvm-0.8.2.ebuild b/games-engines/scummvm/scummvm-0.8.2.ebuild
new file mode 100644
index 000000000000..b4a16fa43d40
--- /dev/null
+++ b/games-engines/scummvm/scummvm-0.8.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.8.2.ebuild,v 1.1 2006/02/10 20:48:14 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa debug flac mp3 ogg vorbis sdl zlib"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2
+ >media-libs/libmpeg2-0.3.1
+ ogg? ( media-libs/libogg media-libs/libvorbis )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ mp3? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.patch
+ if use x86 ; then
+ local f
+ for f in common/scaler/{hq3x_i386.asm,hq2x_i386.asm}
+ do
+ cat >> $f <<EOF
+ %ifidn __OUTPUT_FORMAT__,elf
+ section .note.GNU-stack noalloc noexec nowrite progbits
+ %endif
+EOF
+ done
+ fi
+}
+
+src_compile() {
+ local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
+
+ (use vorbis || use ogg) \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-mpeg2"
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
+ ./configure \
+ $(use_enable debug) \
+ $(use_enable alsa) \
+ $(use_enable mp3 mad) \
+ $(use_enable flac) \
+ $(use_enable zlib) \
+ $(use_enable x86 nasm) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin scummvm || die "dobin failed"
+ doman scummvm.6
+ dodoc NEWS README TODO
+ doicon scummvm.xpm
+ make_desktop_entry scummvm ScummVM
+ prepgamesdirs
+}