summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-10-30 05:33:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-10-30 05:33:39 +0000
commite18b0c34cba5877a5c906aa978636f2f33b045f4 (patch)
treeddb7d75079a2b6205b8c620b74f7d41e3ba2751a /games-engines/scummvm
parentFix modular deps according to dberkholz's recommendations (diff)
downloadgentoo-2-e18b0c34cba5877a5c906aa978636f2f33b045f4.tar.gz
gentoo-2-e18b0c34cba5877a5c906aa978636f2f33b045f4.tar.bz2
gentoo-2-e18b0c34cba5877a5c906aa978636f2f33b045f4.zip
version bump
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'games-engines/scummvm')
-rw-r--r--games-engines/scummvm/ChangeLog8
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.9.13
-rw-r--r--games-engines/scummvm/scummvm-0.9.1.ebuild87
3 files changed, 97 insertions, 1 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index e4be31a158bc..1e65546e70fb 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.37 2006/10/27 06:04:11 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.38 2006/10/30 05:33:39 mr_bones_ Exp $
+
+*scummvm-0.9.1 (30 Oct 2006)
+
+ 30 Oct 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +scummvm-0.9.1.ebuild:
+ version bump
27 Oct 2006; Steve Dibb <beandog@gentoo.org> scummvm-0.9.0.ebuild:
amd64 stable, bug 144170
diff --git a/games-engines/scummvm/files/digest-scummvm-0.9.1 b/games-engines/scummvm/files/digest-scummvm-0.9.1
new file mode 100644
index 000000000000..76686b5838fa
--- /dev/null
+++ b/games-engines/scummvm/files/digest-scummvm-0.9.1
@@ -0,0 +1,3 @@
+MD5 30a82ad466bae223875e66ee14b94904 scummvm-0.9.1.tar.bz2 4514100
+RMD160 c77a7fa4251b6f6ee303dc35049671547dffed7a scummvm-0.9.1.tar.bz2 4514100
+SHA256 5cd5d9c06281a4f81d85d9a9f9b0410045d4a764a855f06f574183b528c15d1a scummvm-0.9.1.tar.bz2 4514100
diff --git a/games-engines/scummvm/scummvm-0.9.1.ebuild b/games-engines/scummvm/scummvm-0.9.1.ebuild
new file mode 100644
index 000000000000..2b821d5a2d5c
--- /dev/null
+++ b/games-engines/scummvm/scummvm-0.9.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.9.1.ebuild,v 1.1 2006/10/30 05:33:39 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="alsa debug flac fluidsynth mp3 ogg vorbis zlib"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2
+ >media-libs/libmpeg2-0.3.1
+ ogg? ( media-libs/libogg media-libs/libvorbis )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ mp3? ( media-libs/libmad )
+ flac? ( ~media-libs/flac-1.1.2 )
+ fluidsynth? ( media-sound/fluidsynth )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if use x86 ; then
+ local f
+ for f in graphics/scaler/{hq3x_i386.asm,hq2x_i386.asm}
+ do
+ cat >> $f <<EOF
+ %ifidn __OUTPUT_FORMAT__,elf
+ section .note.GNU-stack noalloc noexec nowrite progbits
+ %endif
+EOF
+ done
+ fi
+}
+
+src_compile() {
+ local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
+
+ ( use vorbis || use ogg ) \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-mpeg2"
+
+ # bug #137547
+ use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
+ ./configure \
+ $(use_enable debug) \
+ $(use_enable alsa) \
+ $(use_enable mp3 mad) \
+ $(use_enable flac) \
+ $(use_enable zlib) \
+ $(use_enable x86 nasm) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin scummvm || die "dobin failed"
+ doman dists/scummvm.6
+ dodoc AUTHORS NEWS README TODO
+ insinto "${GAMES_DATADIR}"/${PN}/engines
+ doins gui/themes/modern.*
+ doicon icons/scummvm.xpm
+ make_desktop_entry scummvm ScummVM scummvm.xpm
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "If you want to use the new \"modern\" theme for ${PN},"
+ einfo "add the following line to the [scummvm] section of"
+ einfo "your ~/.scummvmrc file (after running scummvm once):"
+ einfo "themepath=${GAMES_DATADIR}/${PN}/engines/"
+}