summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-05 16:04:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-05 16:04:45 +0000
commit855dc8b2119f04bc6bd0c754c734cea298975cdf (patch)
tree7e36e40e4c5f2d60ed264643e5384713f5fe8292 /games-engines/scummvm
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-855dc8b2119f04bc6bd0c754c734cea298975cdf.tar.gz
gentoo-2-855dc8b2119f04bc6bd0c754c734cea298975cdf.tar.bz2
gentoo-2-855dc8b2119f04bc6bd0c754c734cea298975cdf.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-engines/scummvm')
-rw-r--r--games-engines/scummvm/ChangeLog8
-rw-r--r--games-engines/scummvm/scummvm-1.1.0.ebuild85
2 files changed, 92 insertions, 1 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 20f780a81326..04d9041e431e 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.87 2010/01/30 18:12:53 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.88 2010/04/05 16:04:45 mr_bones_ Exp $
+
+*scummvm-1.1.0 (05 Apr 2010)
+
+ 05 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +scummvm-1.1.0.ebuild:
+ version bump
30 Jan 2010; Raúl Porcel <armin76@gentoo.org> scummvm-1.0.0.ebuild:
sparc stable wrt #297262
diff --git a/games-engines/scummvm/scummvm-1.1.0.ebuild b/games-engines/scummvm/scummvm-1.1.0.ebuild
new file mode 100644
index 000000000000..fec48d6bc9a3
--- /dev/null
+++ b/games-engines/scummvm/scummvm-1.1.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.1.0.ebuild,v 1.1 2010/04/05 16:04:45 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug flac fluidsynth mp3 ogg vorbis"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2[audio,joystick,video]
+ >media-libs/libmpeg2-0.3.1
+ sys-libs/zlib
+ ogg? ( media-libs/libogg media-libs/libvorbis )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( media-libs/alsa-lib )
+ mp3? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ fluidsynth? ( media-sound/fluidsynth )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ # -g isn't needed for nasm here
+ sed -i \
+ -e '/NASMFLAGS/ s/-g//' \
+ Makefile.common \
+ || die "sed failed"
+ sed -i \
+ -e '/INSTALL.*doc\//d' \
+ -e '/INSTALL.*\/pixmaps/d' \
+ -e 's/-s //' \
+ ports.mk \
+ || die "sed failed"
+}
+
+src_configure() {
+ local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
+
+ # let the engine find its data files in the right place (bug #178116)
+ myconf="${myconf} --datadir=${GAMES_DATADIR}"
+
+ if use vorbis || use ogg ; then
+ myconf="${myconf} --enable-vorbis"
+ else
+ myconf="${myconf} --disable-vorbis"
+ fi
+
+ # bug #137547
+ use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
+ ./configure \
+ --enable-verbose-build \
+ --prefix=/usr \
+ --bindir="${GAMES_BINDIR}" \
+ --datadir="${GAMES_DATADIR}" \
+ --libdir="${GAMES_LIBDIR}" \
+ --enable-zlib \
+ $(use_enable debug) \
+ $(use_enable alsa) \
+ $(use_enable mp3 mad) \
+ $(use_enable flac) \
+ $(use_enable x86 nasm) \
+ ${myconf} \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO
+ doicon icons/scummvm.svg
+ make_desktop_entry scummvm ScummVM scummvm "Game;AdventureGame"
+ prepgamesdirs
+}