summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-08-21 19:18:49 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-08-21 19:18:49 +0000
commit71a7c69bbbc4cc05804c77d6850df7d69037d0cb (patch)
tree4781d9f3bc6e2bd67f83a38664b5c41a32385c17 /games-engines/gargoyle
parentStable for x86, wrt bug #428972 (diff)
downloadgentoo-2-71a7c69bbbc4cc05804c77d6850df7d69037d0cb.tar.gz
gentoo-2-71a7c69bbbc4cc05804c77d6850df7d69037d0cb.tar.bz2
gentoo-2-71a7c69bbbc4cc05804c77d6850df7d69037d0cb.zip
make build output verbose, fix build wrt #432178, fix desktop file wrt #432222
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'games-engines/gargoyle')
-rw-r--r--games-engines/gargoyle/ChangeLog7
-rw-r--r--games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch31
-rw-r--r--games-engines/gargoyle/gargoyle-2011.1.ebuild11
3 files changed, 45 insertions, 4 deletions
diff --git a/games-engines/gargoyle/ChangeLog b/games-engines/gargoyle/ChangeLog
index 68d0da3d7999..2311a833f470 100644
--- a/games-engines/gargoyle/ChangeLog
+++ b/games-engines/gargoyle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/gargoyle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.18 2012/06/15 15:40:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.19 2012/08/21 19:18:49 hasufell Exp $
+
+ 21 Aug 2012; Julian Ospald <hasufell@gentoo.org> gargoyle-2011.1.ebuild,
+ +files/gargoyle-2011.1-desktopfile.patch:
+ make build output verbose, fix build wrt #432178, fix desktop file wrt
+ #432222
15 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> gargoyle-2011.1.ebuild:
games goes last on inherit line
diff --git a/games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch b/games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch
new file mode 100644
index 000000000000..6b66328da016
--- /dev/null
+++ b/games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch
@@ -0,0 +1,31 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Aug 21 19:06:54 UTC 2012
+Subject: desktop file
+
+fix QA issues:
+
+# desktop-file-validate /usr/share/applications/gargoyle.desktop
+/usr/share/applications/gargoyle.desktop: error: file contains at least one line ending with a carriage return, while lines should only be separated by a line feed character. First such line is: "[Desktop Entry]"
+/usr/share/applications/gargoyle.desktop: error: (will be fatal in the future): value "gargoyle-house.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path
+
+--- garglk/gargoyle.desktop
++++ garglk/gargoyle.desktop
+@@ -1,9 +1,9 @@
+-[Desktop Entry]
+-Version=1.0
+-Type=Application
+-Name=Gargoyle
+-GenericName=Interactive Fiction interpreter
+-Comment=Interactive Fiction multi-interpreter that supports all major IF formats
+-Icon=gargoyle-house.png
+-Exec=gargoyle
+-Categories=Game;
++[Desktop Entry]
++Version=1.0
++Type=Application
++Name=Gargoyle
++GenericName=Interactive Fiction interpreter
++Comment=Interactive Fiction multi-interpreter that supports all major IF formats
++Icon=gargoyle-house
++Exec=gargoyle
++Categories=Game;
diff --git a/games-engines/gargoyle/gargoyle-2011.1.ebuild b/games-engines/gargoyle/gargoyle-2011.1.ebuild
index 5fa453eaf751..2255b3c62325 100644
--- a/games-engines/gargoyle/gargoyle-2011.1.ebuild
+++ b/games-engines/gargoyle/gargoyle-2011.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-2011.1.ebuild,v 1.3 2012/06/15 15:40:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-2011.1.ebuild,v 1.4 2012/08/21 19:18:49 hasufell Exp $
# Regarding licenses: libgarglk is licensed under the GPLv2. Bundled
# interpreters are licensed under GPLv2, BSD or MIT license, except:
@@ -10,7 +10,7 @@
# don't apply. (Fonts are installed through dependencies instead.)
EAPI=3
-inherit eutils multiprocessing games
+inherit eutils multiprocessing toolchain-funcs games
DESCRIPTION="An Interactive Fiction (IF) player supporting all major formats"
HOMEPAGE="http://ccxvii.net/gargoyle/"
@@ -33,7 +33,8 @@ RDEPEND="media-libs/freetype:2
DEPEND="${RDEPEND}
app-arch/unzip
- dev-util/ftjam"
+ dev-util/ftjam
+ virtual/pkgconfig"
src_prepare() {
# Substitute custom CFLAGS/LDFLAGS.
@@ -52,13 +53,17 @@ src_prepare() {
# The font name of Linux Libertine changed in version 5.
sed -i -e 's/Linux Libertine O/Linux Libertine/g' garglk/garglk.ini
+
+ epatch "${FILESDIR}"/${P}-desktopfile.patch
}
src_compile() {
jam \
+ -sAR="$(tc-getAR) cru" \
-sGARGLKINI="${GAMES_SYSCONFDIR}/garglk.ini" \
-sUSESDL=yes \
-sBUNDLEFONTS=no \
+ -dx \
-j$(makeopts_jobs) || die
}