summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-04-21 00:11:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-04-21 00:11:50 +0000
commitcce705d1763cb572c787d1c3cb5c5d1f08b8be58 (patch)
tree42b8cd52485383d535d7a29cab14dd40e354f34c /games-emulation
parentInitial commit. Bug 229371. Initial ebuild provided by Dmitry Dzhus. (diff)
downloadgentoo-2-cce705d1763cb572c787d1c3cb5c5d1f08b8be58.tar.gz
gentoo-2-cce705d1763cb572c787d1c3cb5c5d1f08b8be58.tar.bz2
gentoo-2-cce705d1763cb572c787d1c3cb5c5d1f08b8be58.zip
version bump (bug #258662)
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/openmsx/ChangeLog10
-rw-r--r--games-emulation/openmsx/openmsx-0.7.0.ebuild52
2 files changed, 60 insertions, 2 deletions
diff --git a/games-emulation/openmsx/ChangeLog b/games-emulation/openmsx/ChangeLog
index 3f9ff48ff8ee..34371b6a73c1 100644
--- a/games-emulation/openmsx/ChangeLog
+++ b/games-emulation/openmsx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/openmsx
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.26 2008/05/20 16:26:08 fmccor Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.27 2009/04/21 00:11:50 mr_bones_ Exp $
+
+*openmsx-0.7.0 (21 Apr 2009)
+
+ 21 Apr 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +openmsx-0.7.0.ebuild:
+ version bump (bug #258662)
20 May 2008; Ferris McCormick <fmccor@gentoo.org> openmsx-0.6.3.ebuild:
Sparc stable, Bug #222133.
diff --git a/games-emulation/openmsx/openmsx-0.7.0.ebuild b/games-emulation/openmsx/openmsx-0.7.0.ebuild
new file mode 100644
index 000000000000..e3dfcf809a5a
--- /dev/null
+++ b/games-emulation/openmsx/openmsx-0.7.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.7.0.ebuild,v 1.1 2009/04/21 00:11:50 mr_bones_ Exp $
+
+EAPI=2
+inherit toolchain-funcs games
+
+DESCRIPTION="MSX emulator that aims for perfection"
+HOMEPAGE="http://openmsx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="jack"
+
+DEPEND="dev-lang/tcl
+ dev-libs/libxml2
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/glew
+ media-libs/sdl-image
+ virtual/opengl
+ jack? ( media-sound/jack-audio-connection-kit )"
+
+src_prepare() {
+ sed -i '/LINK_FLAGS+=/s/-s//' build/main.mk || die "sed failed"
+ sed -i \
+ -e "/DISABLED/s:$:$(use jack || echo JACK):" \
+ -e '/SYMLINK/s:true:false:' \
+ build/custom.mk \
+ || die "sed custom.mk failed"
+ find share/extensions -type f -exec chmod -x '{}' +
+}
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ INSTALL_SHARE_DIR="${GAMES_DATADIR}"/${PN} \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ INSTALL_BINARY_DIR="${D}${GAMES_BINDIR}" \
+ INSTALL_SHARE_DIR="${D}${GAMES_DATADIR}"/${PN} \
+ INSTALL_DOC_DIR="${D}"/usr/share/doc/${PF} \
+ install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+ prepgamesdirs
+}