summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-10-23 12:22:51 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-10-23 12:22:51 +0000
commitb6a97d2e66672032c3c1950ff31971a8e45a2424 (patch)
tree5a30e4f665a55cde0c6d4436c45c0d0d75258ad6 /games-emulation
parentVersion bump. (diff)
downloadgentoo-2-b6a97d2e66672032c3c1950ff31971a8e45a2424.tar.gz
gentoo-2-b6a97d2e66672032c3c1950ff31971a8e45a2424.tar.bz2
gentoo-2-b6a97d2e66672032c3c1950ff31971a8e45a2424.zip
Build with gcc-4.7 Bug #421901
(Portage version: 2.1.11.30/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gcube/ChangeLog8
-rw-r--r--games-emulation/gcube/files/gcube-0.4-gcc47.patch10
-rw-r--r--games-emulation/gcube/gcube-0.4-r1.ebuild14
3 files changed, 24 insertions, 8 deletions
diff --git a/games-emulation/gcube/ChangeLog b/games-emulation/gcube/ChangeLog
index 33107cb7c242..a92897f75c61 100644
--- a/games-emulation/gcube/ChangeLog
+++ b/games-emulation/gcube/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/gcube
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gcube/ChangeLog,v 1.11 2011/06/10 12:27:14 tupone Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gcube/ChangeLog,v 1.12 2012/10/23 12:22:50 tupone Exp $
+
+ 23 Oct 2012; Tupone Alfredo <tupone@gentoo.org> gcube-0.4-r1.ebuild,
+ +files/gcube-0.4-gcc47.patch:
+ Build with gcc-4.7 Bug #421901 by Diego
10 Jun 2011; Tupone Alfredo <tupone@gentoo.org> gcube-0.4-r1.ebuild,
+files/gcube-0.4-underlink.patch:
diff --git a/games-emulation/gcube/files/gcube-0.4-gcc47.patch b/games-emulation/gcube/files/gcube-0.4-gcc47.patch
new file mode 100644
index 000000000000..b459a4e24034
--- /dev/null
+++ b/games-emulation/gcube/files/gcube-0.4-gcc47.patch
@@ -0,0 +1,10 @@
+--- Makefile.rules.old 2012-10-23 14:06:54.417782365 +0200
++++ Makefile.rules 2012-10-23 14:07:11.516377033 +0200
+@@ -1,6 +1,6 @@
+
+ SDL_CONFIG=sdl-config
+-LIBS=`$(SDL_CONFIG) --libs` -mno-windows -mcygwin -lz -l$(OPENGL) -lm
++LIBS=`$(SDL_CONFIG) --libs` -lz -l$(OPENGL) -lm
+
+ PROFLAGS=-g -Wall -pg -fprofile-arcs -ftest-coverage
+ OPTFLAGS=-O3 -fno-strict-aliasing -fomit-frame-pointer -ffast-math -march=$(CPU) $(OPTIMIZE)
diff --git a/games-emulation/gcube/gcube-0.4-r1.ebuild b/games-emulation/gcube/gcube-0.4-r1.ebuild
index 6f0e61b86874..649be9a17b51 100644
--- a/games-emulation/gcube/gcube-0.4-r1.ebuild
+++ b/games-emulation/gcube/gcube-0.4-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gcube/gcube-0.4-r1.ebuild,v 1.7 2011/06/10 12:27:14 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gcube/gcube-0.4-r1.ebuild,v 1.8 2012/10/23 12:22:50 tupone Exp $
-EAPI=2
+EAPI=4
inherit eutils games
DESCRIPTION="Gamecube emulator"
@@ -19,6 +19,7 @@ DEPEND="virtual/opengl
virtual/jpeg
sys-libs/ncurses
sys-libs/zlib"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${PV}
@@ -27,15 +28,16 @@ src_prepare() {
-e '/^CFLAGS=-g/d' Makefile.rules \
|| die "sed failed"
epatch "${FILESDIR}"/${P}-ldflags.patch \
- "${FILESDIR}"/${P}-underlink.patch
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
}
src_install() {
local x
- dogamesbin gcmap gcube || die "dogamesbin failed"
+ dogamesbin gcmap gcube
for x in bin2dol isopack thpview tplx ; do
- newgamesbin ${x} ${PN}-${x} || die "newgamesbin ${x} failed"
+ newgamesbin ${x} ${PN}-${x}
done
dodoc ChangeLog README
prepgamesdirs