summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-04-18 18:39:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-04-18 18:39:08 +0000
commita04ba91c1b3da796843f7fb2a9c29c3d739f763e (patch)
tree12b5bdce758d2320322e4a6b66b08903289f1b4c /games-emulation
parentSparc stable, Bug #217075. (diff)
downloadgentoo-2-a04ba91c1b3da796843f7fb2a9c29c3d739f763e.tar.gz
gentoo-2-a04ba91c1b3da796843f7fb2a9c29c3d739f763e.tar.bz2
gentoo-2-a04ba91c1b3da796843f7fb2a9c29c3d739f763e.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/stella-2.5.1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index 326dc3e34f01..bcf2498c188c 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.26 2008/02/29 19:05:53 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.27 2008/04/18 18:39:08 mr_bones_ Exp $
+
+*stella-2.5.1 (18 Apr 2008)
+
+ 18 Apr 2008; Michael Sterrett <mr_bones_@gentoo.org> +stella-2.5.1.ebuild:
+ version bump
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> stella-2.2.ebuild,
stella-2.4.2.ebuild:
diff --git a/games-emulation/stella/stella-2.5.1.ebuild b/games-emulation/stella/stella-2.5.1.ebuild
new file mode 100644
index 000000000000..6a2c66ea6c0b
--- /dev/null
+++ b/games-emulation/stella/stella-2.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.5.1.ebuild,v 1.1 2008/04/18 18:39:08 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/libpng
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/strip/d' \
+ -e "/icons/d" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.xpm
+ make_desktop_entry stella Stella stella
+ prepgamesdirs
+}