summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-07-30 20:22:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-07-30 20:22:11 +0000
commit9ce0a320673d1a07d190489aa830d41d38e2310f (patch)
tree6f656a7b5104b0bfb68c2033b9ae72acbfb2fdb1 /games-emulation
parentVersion bump. Now with >4GB-support. (diff)
downloadgentoo-2-9ce0a320673d1a07d190489aa830d41d38e2310f.tar.gz
gentoo-2-9ce0a320673d1a07d190489aa830d41d38e2310f.tar.bz2
gentoo-2-9ce0a320673d1a07d190489aa830d41d38e2310f.zip
old
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fakenes/fakenes-0.3.1.ebuild67
-rw-r--r--games-emulation/fakenes/files/0.3.1-allegro.patch55
-rw-r--r--games-emulation/fakenes/files/digest-fakenes-0.3.13
3 files changed, 0 insertions, 125 deletions
diff --git a/games-emulation/fakenes/fakenes-0.3.1.ebuild b/games-emulation/fakenes/fakenes-0.3.1.ebuild
deleted file mode 100644
index bbfbd85b0a63..000000000000
--- a/games-emulation/fakenes/fakenes-0.3.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/fakenes-0.3.1.ebuild,v 1.3 2006/12/06 17:12:19 wolf31o2 Exp $
-
-inherit eutils games
-
-DESCRIPTION="portable, Open Source NES emulator which is written mostly in C"
-HOMEPAGE="http://fakenes.sourceforge.net/"
-SRC_URI="mirror://sourceforge/fakenes/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="zlib fbcon svga"
-
-RDEPEND=">=media-libs/allegro-4.1
- zlib? ( sys-libs/zlib )
- dev-games/hawknl"
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # this is a hack simply because upstream seems kind
- # of dead atm ... if they ever revive, we can do this
- # properly by making an autoconf patch ...
- epatch "${FILESDIR}/${PV}-allegro.patch"
- if ! use fbcon ; then
- sed -i \
- -e '/sedfbme/s:.*::' \
- src/gui.c src/include/gui/menus.h \
- || die "sed fb failed"
- fi
- if ! use svga ; then
- sed -i \
- -e '/sedsvgalibme/s:.*::' \
- src/gui.c src/include/gui/menus.h \
- || die "sed svga failed"
- fi
-
- # fix bad AC_ARG_WITH() configure invocation
- sed -i \
- -e '/USE_/s:$enableval:$withval:' \
- configure || die
-
- # fix bad distribution
- chmod a+x configure
- edos2unix $(find -type f)
-}
-
-src_compile() {
- egamesconf \
- --with-hawknl \
- $(use_with zlib) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- dogamesbin src/fakenes || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins src/support/fakenes.{dat,ico,rc} || die "doins failed"
- dodoc CHANGES README SOURCE SUPPORT
- prepgamesdirs
-}
diff --git a/games-emulation/fakenes/files/0.3.1-allegro.patch b/games-emulation/fakenes/files/0.3.1-allegro.patch
deleted file mode 100644
index 646fe5a6f43c..000000000000
--- a/games-emulation/fakenes/files/0.3.1-allegro.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- src/gui.c.orig 2003-09-25 22:29:25.830731224 -0400
-+++ src/gui.c 2003-09-25 22:30:29.575040616 -0400
-@@ -716,9 +716,9 @@
-
- TOGGLE_MENU (options_video_driver_linux_menu, 4, (gfx_driver -> id == GFX_VBEAF));
-
-- TOGGLE_MENU (options_video_driver_linux_menu, 6, (gfx_driver -> id == GFX_FBCON));
-+ TOGGLE_MENU (options_video_driver_linux_menu, 6, (gfx_driver -> id == GFX_FBCON)); //sedfbme
-
-- TOGGLE_MENU (options_video_driver_linux_menu, 8, (gfx_driver -> id == GFX_SVGALIB));
-+ TOGGLE_MENU (options_video_driver_linux_menu, 8, (gfx_driver -> id == GFX_SVGALIB)); //sedsvgalibme
-
- #endif
-
-@@ -3238,9 +3238,9 @@
-
- DRIVER_MENU_HANDLER (linux, vesa_vbe_af, GFX_VBEAF)
-
--DRIVER_MENU_HANDLER (linux, framebuffer, GFX_FBCON)
-+DRIVER_MENU_HANDLER (linux, framebuffer, GFX_FBCON) //sedfbme
-
--DRIVER_MENU_HANDLER (linux, svgalib, GFX_SVGALIB)
-+DRIVER_MENU_HANDLER (linux, svgalib, GFX_SVGALIB) //sedsvgalibme
-
- #endif
-
---- src/include/gui/menus.h.orig 2003-09-25 22:29:33.099626184 -0400
-+++ src/include/gui/menus.h 2003-09-25 22:31:12.231555840 -0400
-@@ -593,9 +593,9 @@
-
- static int options_video_driver_linux_menu_vesa_vbe_af (void);
-
--static int options_video_driver_linux_menu_framebuffer (void);
-+static int options_video_driver_linux_menu_framebuffer (void); //sedfbme
-
--static int options_video_driver_linux_menu_svgalib (void);
-+static int options_video_driver_linux_menu_svgalib (void); //sedsvgalibme
-
-
- static MENU options_video_driver_linux_menu [] =
-@@ -606,10 +606,10 @@
- { "", NIL, NIL, 0, NIL },
- { "VESA VBE/&AF", options_video_driver_linux_menu_vesa_vbe_af, NIL, 0, NIL },
- { "", NIL, NIL, 0, NIL },
-- { "&Framebuffer", options_video_driver_linux_menu_framebuffer, NIL, 0, NIL },
-- { "", NIL, NIL, 0, NIL },
-- { "&SVGAlib", options_video_driver_linux_menu_svgalib, NIL, 0, NIL },
-- { NIL, NIL, NIL, 0, NIL }
-+ { "&Framebuffer", options_video_driver_linux_menu_framebuffer, NIL, 0, NIL }, //sedfbme
-+ { "", NIL, NIL, 0, NIL }, //sedfbme
-+ { "&SVGAlib", options_video_driver_linux_menu_svgalib, NIL, 0, NIL }, //sedsvgalibme
-+ { NIL, NIL, NIL, 0, NIL } //sedsvgalibme
- };
-
- #else
diff --git a/games-emulation/fakenes/files/digest-fakenes-0.3.1 b/games-emulation/fakenes/files/digest-fakenes-0.3.1
deleted file mode 100644
index d496ee677c62..000000000000
--- a/games-emulation/fakenes/files/digest-fakenes-0.3.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a0f8416fe0749ee1464b0e4814acfb93 fakenes-0.3.1.tar.bz2 160899
-RMD160 1a0ecaf20cd874ea1a80208cd9791b3052e251e2 fakenes-0.3.1.tar.bz2 160899
-SHA256 5a1233826a254eb1be3118dd50dcd5a81a14edcaef6cad2f42f553724c8466ae fakenes-0.3.1.tar.bz2 160899