summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-08-17 05:11:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-08-17 05:11:39 +0000
commit98c6f3cd617daef770f0ef056089e42986272bee (patch)
tree6c8f29fa33a0058733b06e51bdeddf41a609398b /games-emulation
parentVersion bump, cleanup (diff)
downloadgentoo-2-98c6f3cd617daef770f0ef056089e42986272bee.tar.gz
gentoo-2-98c6f3cd617daef770f0ef056089e42986272bee.tar.bz2
gentoo-2-98c6f3cd617daef770f0ef056089e42986272bee.zip
version bump
(Portage version: 2.1.2.11)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mamory/ChangeLog8
-rw-r--r--games-emulation/mamory/files/digest-mamory-0.2.253
-rw-r--r--games-emulation/mamory/mamory-0.2.25.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/games-emulation/mamory/ChangeLog b/games-emulation/mamory/ChangeLog
index 06e26bb5c3be..795ce985c321 100644
--- a/games-emulation/mamory/ChangeLog
+++ b/games-emulation/mamory/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/mamory
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/ChangeLog,v 1.21 2007/08/01 00:10:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/ChangeLog,v 1.22 2007/08/17 05:11:39 mr_bones_ Exp $
+
+*mamory-0.2.25 (17 Aug 2007)
+
+ 17 Aug 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +mamory-0.2.25.ebuild:
+ version bump
*mamory-0.2.24 (01 Aug 2007)
diff --git a/games-emulation/mamory/files/digest-mamory-0.2.25 b/games-emulation/mamory/files/digest-mamory-0.2.25
new file mode 100644
index 000000000000..35dbfe03848b
--- /dev/null
+++ b/games-emulation/mamory/files/digest-mamory-0.2.25
@@ -0,0 +1,3 @@
+MD5 778f5e5c5be93fb0dfb1f3246e2df203 mamory-0.2.25.tar.gz 437223
+RMD160 b4efdcaeb92c6d8e1caaf3bdc47750934cc35d34 mamory-0.2.25.tar.gz 437223
+SHA256 81593967a4f334d221ff23e066aa71d939c08d9a6e8b953e3912d76700c65e50 mamory-0.2.25.tar.gz 437223
diff --git a/games-emulation/mamory/mamory-0.2.25.ebuild b/games-emulation/mamory/mamory-0.2.25.ebuild
new file mode 100644
index 000000000000..05afcb246ebc
--- /dev/null
+++ b/games-emulation/mamory/mamory-0.2.25.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/mamory-0.2.25.ebuild,v 1.1 2007/08/17 05:11:39 mr_bones_ Exp $
+
+inherit autotools games
+
+DESCRIPTION="ROM management tools and library"
+HOMEPAGE="http://mamory.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/expat"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Make sure the system expat is used
+ sed -i \
+ -e 's/#ifdef.*SYSEXPAT/#if 1/' \
+ mamory/amlxml.c mamory/amlxml.h \
+ || die "sed amlxml failed"
+
+ # Remove hardcoded CFLAGS options
+ sed -i \
+ -e '/AC_ARG_ENABLE(debug,/ {N;N;N;d}' \
+ configure.ac \
+ || die "sed configure.ac failed"
+
+ # Make it possible for eautoreconf to fix fPIC etc.
+ sed -i \
+ -e '/libcommon_la_LDFLAGS= -static/d' \
+ common/Makefile.am \
+ || die "sed Makefile.am failed"
+
+ AT_M4DIR="config" eautoreconf || die
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --includedir=/usr/include || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ dohtml DOCS/mamory.html
+ prepgamesdirs
+}