summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-01-17 14:04:36 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-01-17 14:04:36 +0000
commit982ed94984d0822706179f6fd4c6aa04cacf500f (patch)
tree920111a1ae62e96fe92e194474c0810196a85876 /games-emulation
parentStable for ppc, wrt bug #535678 (diff)
downloadgentoo-2-982ed94984d0822706179f6fd4c6aa04cacf500f.tar.gz
gentoo-2-982ed94984d0822706179f6fd4c6aa04cacf500f.tar.bz2
gentoo-2-982ed94984d0822706179f6fd4c6aa04cacf500f.zip
EAPI 5
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/daphne/ChangeLog7
-rw-r--r--games-emulation/daphne/daphne-1.0.ebuild19
2 files changed, 14 insertions, 12 deletions
diff --git a/games-emulation/daphne/ChangeLog b/games-emulation/daphne/ChangeLog
index 996938f3c284..ddfd354d4b7c 100644
--- a/games-emulation/daphne/ChangeLog
+++ b/games-emulation/daphne/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/daphne
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.17 2011/09/21 10:44:04 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/ChangeLog,v 1.18 2015/01/17 14:04:36 tupone Exp $
+
+ 17 Jan 2015; Tupone Alfredo <tupone@gentoo.org> daphne-1.0.ebuild:
+ EAPI 5
21 Sep 2011; Tupone Alfredo <tupone@gentoo.org> daphne-1.0.ebuild,
+files/daphne-1.0-underlink.patch, +files/daphne-1.0-zlib.patch:
diff --git a/games-emulation/daphne/daphne-1.0.ebuild b/games-emulation/daphne/daphne-1.0.ebuild
index bd6e7d43254a..3a6de9df2b20 100644
--- a/games-emulation/daphne/daphne-1.0.ebuild
+++ b/games-emulation/daphne/daphne-1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-1.0.ebuild,v 1.7 2011/09/21 10:44:04 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-1.0.ebuild,v 1.8 2015/01/17 14:04:36 tupone Exp $
-EAPI=2
+EAPI=5
inherit eutils toolchain-funcs games
DESCRIPTION="Laserdisc Arcade Game Emulator"
@@ -19,6 +19,7 @@ DEPEND="media-libs/libogg
media-libs/libsdl[video]
media-libs/sdl-mixer
media-libs/glew"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/v_1_0/src
@@ -73,23 +74,21 @@ src_compile() {
emake \
CXX=$(tc-getCXX) \
- DFLAGS="${CXXFLAGS} ${archflags}" \
- || die "src build failed"
+ DFLAGS="${CXXFLAGS} ${archflags}"
cd vldp2
emake \
-f Makefile.linux \
CC=$(tc-getCC) \
- DFLAGS="${CFLAGS} ${archflags}" \
- || die "vldp2 build failed"
+ DFLAGS="${CFLAGS} ${archflags}"
}
src_install() {
cd ..
- newgamesbin daphne.bin daphne || die "newgamesbin failed"
+ newgamesbin daphne.bin daphne
exeinto "$(games_get_libdir)"/${PN}
- doexe libvldp2.so || die "doexe failed"
+ doexe libvldp2.so
insinto "${GAMES_DATADIR}"/${PN}
- doins -r pics roms sound || die "doins failed"
+ doins -r pics roms sound
dodoc doc/*.{ini,txt}
dohtml -r doc/*
prepgamesdirs