summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-07 05:31:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-07 05:31:40 +0000
commit8cbf42532e0c5a7e96d710a71ed0c6a9a0a2d4cd (patch)
tree630c79ee2b57f1c376a7b5352c5097e1098baca9 /games-emulation
parentIUSE; tidy; error check sed (Manifest recommit) (diff)
downloadgentoo-2-8cbf42532e0c5a7e96d710a71ed0c6a9a0a2d4cd.tar.gz
gentoo-2-8cbf42532e0c5a7e96d710a71ed0c6a9a0a2d4cd.tar.bz2
gentoo-2-8cbf42532e0c5a7e96d710a71ed0c6a9a0a2d4cd.zip
IUSE; tidy
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/game-launcher/ChangeLog8
-rw-r--r--games-emulation/game-launcher/game-launcher-0.9.8.ebuild13
-rw-r--r--games-emulation/gnomame/ChangeLog8
-rw-r--r--games-emulation/gnomame/gnomame-1.00_beta6.ebuild9
4 files changed, 25 insertions, 13 deletions
diff --git a/games-emulation/game-launcher/ChangeLog b/games-emulation/game-launcher/ChangeLog
index 9adccdcce62c..7a227707a276 100644
--- a/games-emulation/game-launcher/ChangeLog
+++ b/games-emulation/game-launcher/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/game-launcher
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/game-launcher/ChangeLog,v 1.3 2003/09/25 06:41:23 msterret Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/game-launcher/ChangeLog,v 1.4 2004/06/07 05:30:16 mr_bones_ Exp $
+
+ 06 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ game-launcher-0.9.8.ebuild:
+ IUSE; tidy
24 Sep 2003; Michael Sterrett <msterret@gentoo.org>
game-launcher-0.9.8.ebuild, files/0.9.8-gentoo.patch:
diff --git a/games-emulation/game-launcher/game-launcher-0.9.8.ebuild b/games-emulation/game-launcher/game-launcher-0.9.8.ebuild
index 126bf35d76ec..377b4d59e0d4 100644
--- a/games-emulation/game-launcher/game-launcher-0.9.8.ebuild
+++ b/games-emulation/game-launcher/game-launcher-0.9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/game-launcher/game-launcher-0.9.8.ebuild,v 1.3 2004/02/20 06:26:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/game-launcher/game-launcher-0.9.8.ebuild,v 1.4 2004/06/07 05:30:16 mr_bones_ Exp $
inherit games eutils
@@ -9,8 +9,9 @@ HOMEPAGE="http://www.dribin.org/dave/game_launcher/"
SRC_URI="mirror://sourceforge/glaunch/gl${PV//./}s.zip"
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
+IUSE=""
RDEPEND=">=media-libs/allegro-4.0.0
>=media-libs/loadpng-0.11
@@ -22,14 +23,14 @@ RDEPEND=">=media-libs/allegro-4.0.0
DEPEND="${RDEPEND}
app-arch/unzip"
-S=${WORKDIR}/glaunch
+S="${WORKDIR}/glaunch"
src_unpack() {
unpack ${A}
cd ${S}
edos2unix `find -regex '.*\.[ch]' -or -name '*.cc'`
- epatch ${FILESDIR}/${PV}-gentoo.patch
+ epatch "${FILESDIR}/${PV}-gentoo.patch"
find . -name ".cvsignore" -exec rm -f \{\} \;
}
@@ -38,7 +39,7 @@ src_compile() {
}
src_install() {
- dodir /opt/${P}
- cp -R ${S}/* ${D}/opt/${P} # doinst can't do recursive
+ dodir "/opt/${P}"
+ cp -R ${S}/* "${D}/opt/${P}" # doinst can't do recursive
prepgamesdirs
}
diff --git a/games-emulation/gnomame/ChangeLog b/games-emulation/gnomame/ChangeLog
index 3d4d59c743d1..0cd9aa650e63 100644
--- a/games-emulation/gnomame/ChangeLog
+++ b/games-emulation/gnomame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/gnomame
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnomame/ChangeLog,v 1.3 2003/10/03 01:46:26 mr_bones_ Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnomame/ChangeLog,v 1.4 2004/06/07 05:31:40 mr_bones_ Exp $
+
+ 06 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ gnomame-1.00_beta6.ebuild:
+ IUSE; tidy
02 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org>
gnomame-1.00_beta6.ebuild:
diff --git a/games-emulation/gnomame/gnomame-1.00_beta6.ebuild b/games-emulation/gnomame/gnomame-1.00_beta6.ebuild
index be966fe3af64..4de80dc1e9b6 100644
--- a/games-emulation/gnomame/gnomame-1.00_beta6.ebuild
+++ b/games-emulation/gnomame/gnomame-1.00_beta6.ebuild
@@ -1,25 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnomame/gnomame-1.00_beta6.ebuild,v 1.3 2004/02/20 06:26:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnomame/gnomame-1.00_beta6.ebuild,v 1.4 2004/06/07 05:31:40 mr_bones_ Exp $
MY_P="${P/_beta/b}"
-S=${WORKDIR}/${MY_P}
DESCRIPTION="GTK+ xmame catalog and frontend"
SRC_URI="http://gnomame.sourceforge.net/files/${MY_P}.tar.gz"
HOMEPAGE="http://gnomame.sourceforge.net/"
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
+IUSE=""
DEPEND="=x11-libs/gtk+-1.2*
media-libs/gdk-pixbuf
games-emulation/xmame"
+S="${WORKDIR}/${MY_P}"
+
src_compile() {
econf || die
emake || die "emake failed"
}
+
src_install() {
einstall || die
dodoc AUTHORS ChangeLog README || die "dodoc failed"