summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-08-13 16:52:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-08-13 16:52:11 +0000
commit853e8316c36216f9c9acffc5da697cf3765400c5 (patch)
treebbad3fdb48975b9a33759087eed956adbf4b98c2 /games-emulation
parentold (diff)
downloadgentoo-2-853e8316c36216f9c9acffc5da697cf3765400c5.tar.gz
gentoo-2-853e8316c36216f9c9acffc5da697cf3765400c5.tar.bz2
gentoo-2-853e8316c36216f9c9acffc5da697cf3765400c5.zip
disable SEXYAL sound system which is reported to be problematic (bug #155153) with patch from Brad House.
(Portage version: 2.1.2.11)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fceultra/ChangeLog9
-rw-r--r--games-emulation/fceultra/fceultra-0.98.12.ebuild14
-rw-r--r--games-emulation/fceultra/files/fceultra-0.98.12-nosex.patch51
3 files changed, 68 insertions, 6 deletions
diff --git a/games-emulation/fceultra/ChangeLog b/games-emulation/fceultra/ChangeLog
index f91d02cc2bf3..a470cbb4e5a2 100644
--- a/games-emulation/fceultra/ChangeLog
+++ b/games-emulation/fceultra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/fceultra
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceultra/ChangeLog,v 1.19 2006/09/26 20:56:48 nyhm Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceultra/ChangeLog,v 1.20 2007/08/13 16:52:11 mr_bones_ Exp $
+
+ 13 Aug 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/fceultra-0.98.12-nosex.patch, fceultra-0.98.12.ebuild:
+ disable SEXYAL sound system which is reported to be problematic (bug
+ #155153) with patch from Brad House.
26 Sep 2006; Tristan Heaven <nyhm@gentoo.org>
+files/fceultra-0.98.12-mkdir.patch, fceultra-0.98.12.ebuild:
diff --git a/games-emulation/fceultra/fceultra-0.98.12.ebuild b/games-emulation/fceultra/fceultra-0.98.12.ebuild
index 13c54a85e623..e8b3a8586053 100644
--- a/games-emulation/fceultra/fceultra-0.98.12.ebuild
+++ b/games-emulation/fceultra/fceultra-0.98.12.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceultra/fceultra-0.98.12.ebuild,v 1.6 2006/09/26 20:56:48 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceultra/fceultra-0.98.12.ebuild,v 1.7 2007/08/13 16:52:11 mr_bones_ Exp $
-inherit eutils games
+inherit autotools eutils games
DESCRIPTION="A portable NES/Famicom emulator"
HOMEPAGE="http://www.emulator-zone.com/doc.php/nes/fceultra.html"
@@ -26,7 +26,13 @@ S=${WORKDIR}/fceu
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-mkdir.patch
+ chmod a-x Documentation/tech/exp/*
+
+ # bug #155153 - disable SEXYAL system
+ epatch \
+ "${FILESDIR}"/${P}-mkdir.patch \
+ "${FILESDIR}"/${P}-nosex.patch
+ eautoreconf
}
src_compile() {
diff --git a/games-emulation/fceultra/files/fceultra-0.98.12-nosex.patch b/games-emulation/fceultra/files/fceultra-0.98.12-nosex.patch
new file mode 100644
index 000000000000..d7309bd5778b
--- /dev/null
+++ b/games-emulation/fceultra/files/fceultra-0.98.12-nosex.patch
@@ -0,0 +1,51 @@
+# By default SEXYAL is used. This doesn't seem to work
+# on some systems. We need to use SDL's native sound
+# support and there is no ./configure argument to do
+# that.
+
+diff -ru fceu.old/configure.ac fceu/configure.ac
+--- fceu.old/configure.ac 2004-08-17 18:29:13.000000000 -0400
++++ fceu/configure.ac 2006-11-14 14:46:59.000000000 -0500
+@@ -48,10 +48,10 @@
+ if test x$use_nativewin32 = xyes; then
+ LIBS="$LIBS -mwindows -lddraw -ldinput -ldsound -lgdi32 -ldxguid -lwinmm -lshell32 -lwsock32 -lcomdlg32 -lole32"
+ AM_CONDITIONAL(NATIVEWIN32,true)
+-else
+- AM_CONDITIONAL(USE_SEXYAL, true)
+- AC_DEFINE([USE_SEXYAL])
+- LIBS="$LIBS -ldsound -lwinmm"
++dnl else
++dnl AM_CONDITIONAL(USE_SEXYAL, true)
++dnl AC_DEFINE([USE_SEXYAL])
++dnl LIBS="$LIBS -ldsound -lwinmm"
+ fi
+
+
+@@ -61,9 +61,9 @@
+ AC_DEFINE([PSS_STYLE],[1])
+ AC_DEFINE([NETWORK],[1])
+
+-AC_CHECK_HEADER([sys/soundcard.h],
+- AM_CONDITIONAL(USE_SEXYAL, true)
+- AC_DEFINE([USE_SEXYAL]),[])
++dnl AC_CHECK_HEADER([sys/soundcard.h],
++dnl AM_CONDITIONAL(USE_SEXYAL, true)
++dnl AC_DEFINE([USE_SEXYAL]),[])
+ fi
+
+ dnl if expr x"$target" : 'x.*darwin' > /dev/null; then
+diff -ru fceu.old/src/drivers/pc/dface.h fceu/src/drivers/pc/dface.h
+--- fceu.old/src/drivers/pc/dface.h 2004-08-17 18:10:49.000000000 -0400
++++ fceu/src/drivers/pc/dface.h 2006-11-14 14:49:36.000000000 -0500
+@@ -17,7 +17,7 @@
+
+ int InitSound(FCEUGI *gi);
+ void WriteSound(int32 *Buffer, int Count);
+-int KillSound(void);
++void KillSound(void);
+ uint32 GetMaxSound(void);
+ uint32 GetWriteSound(void);
+
+
+
+