summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-26 17:44:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-26 17:44:49 +0000
commit5cddec2f1a6f16649821935b93a84d36ced94577 (patch)
tree8ba34e5c9f379386c66cb764fd87de3e30a52c5d /games-emulation
parentFix compilation for FreeMiNT by Alan Hourihane, bug #451502 (diff)
downloadgentoo-2-5cddec2f1a6f16649821935b93a84d36ced94577.tar.gz
gentoo-2-5cddec2f1a6f16649821935b93a84d36ced94577.tar.bz2
gentoo-2-5cddec2f1a6f16649821935b93a84d36ced94577.zip
version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mednafen/ChangeLog12
-rw-r--r--games-emulation/mednafen/files/mednafen-0.9.28-cflags.patch35
-rw-r--r--games-emulation/mednafen/files/mednafen-0.9.28-zlib.patch30
-rw-r--r--games-emulation/mednafen/mednafen-0.9.28.ebuild58
-rw-r--r--games-emulation/mednafen/metadata.xml5
5 files changed, 136 insertions, 4 deletions
diff --git a/games-emulation/mednafen/ChangeLog b/games-emulation/mednafen/ChangeLog
index a7b2dccc773b..2d6038c7c0a0 100644
--- a/games-emulation/mednafen/ChangeLog
+++ b/games-emulation/mednafen/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-emulation/mednafen
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/ChangeLog,v 1.39 2012/06/13 07:13:03 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/ChangeLog,v 1.40 2013/01/26 17:44:49 mr_bones_ Exp $
+
+*mednafen-0.9.28 (26 Jan 2013)
+
+ 26 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/mednafen-0.9.28-cflags.patch, +files/mednafen-0.9.28-zlib.patch,
+ +mednafen-0.9.28.ebuild, metadata.xml:
+ version bump
13 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org>
-files/mednafen-0.8.13.3-zlib-1.2.6.patch,
@@ -174,4 +181,3 @@
19 May 2006; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+mednafen-0.6.1.ebuild:
initial commit - ebuild submitted by Kai via bug #110044
-
diff --git a/games-emulation/mednafen/files/mednafen-0.9.28-cflags.patch b/games-emulation/mednafen/files/mednafen-0.9.28-cflags.patch
new file mode 100644
index 000000000000..0fca1c6136e2
--- /dev/null
+++ b/games-emulation/mednafen/files/mednafen-0.9.28-cflags.patch
@@ -0,0 +1,35 @@
+--- configure.ac.orig 2013-01-25 13:30:36.167253683 -0500
++++ configure.ac 2013-01-25 13:32:16.993678869 -0500
+@@ -90,21 +90,6 @@
+
+ dnl -fno-unit-at-a-time
+
+-OPTIMIZER_FLAGS=""
+-
+-dnl -ffast-math removed January 12, 2013. Don't re-add it, nor any of its sub-options(ESPECIALLY not -funsafe-math-optimizations),
+-dnl it messes up certain code(NES resampler, for example) under certain conditions and alignments of the great celestial squid.
+-dnl
+-dnl In fact, let's explicitly disable it here with -fno-fast-math.
+-dnl
+-AX_CFLAGS_GCC_OPTION([-fno-fast-math], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([-fno-unsafe-math-optimizations], OPTIMIZER_FLAGS)
+-
+-AX_CFLAGS_GCC_OPTION([-fomit-frame-pointer], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([-finline-limit=6000], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([--param large-function-growth=800], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([--param inline-unit-growth=175], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([--param max-inline-insns-single=10000], OPTIMIZER_FLAGS)
+ AX_NO_STRICT_OVERFLOW
+
+
+@@ -138,8 +123,8 @@
+ MDFN_COMPAT_FLAGS=""
+ AX_CFLAGS_GCC_OPTION([-fsigned-char], MDFN_COMPAT_FLAGS)
+
+-AC_SUBST([AM_CFLAGS], "$MDFN_COMPAT_FLAGS $WARNING_FLAGS $OPTIMIZER_FLAGS $NO_STRICT_OVERFLOW_FLAGS")
+-AC_SUBST([AM_CXXFLAGS], "$MDFN_COMPAT_FLAGS $WARNING_FLAGS $OPTIMIZER_FLAGS $NO_STRICT_OVERFLOW_FLAGS")
++AC_SUBST([AM_CFLAGS], "$MDFN_COMPAT_FLAGS $WARNING_FLAGS $NO_STRICT_OVERFLOW_FLAGS")
++AC_SUBST([AM_CXXFLAGS], "$MDFN_COMPAT_FLAGS $WARNING_FLAGS $NO_STRICT_OVERFLOW_FLAGS")
+
+ AM_CONDITIONAL(WANT_DEBUGGER, false)
+
diff --git a/games-emulation/mednafen/files/mednafen-0.9.28-zlib.patch b/games-emulation/mednafen/files/mednafen-0.9.28-zlib.patch
new file mode 100644
index 000000000000..8ada20096ecb
--- /dev/null
+++ b/games-emulation/mednafen/files/mednafen-0.9.28-zlib.patch
@@ -0,0 +1,30 @@
+diff -ru mednafen.orig/src/Makefile.am mednafen/src/Makefile.am
+--- mednafen.orig/src/Makefile.am 2013-01-12 08:41:03.000000000 -0500
++++ mednafen/src/Makefile.am 2013-01-25 13:17:44.351619447 -0500
+@@ -5,7 +5,7 @@
+
+ bin_PROGRAMS = mednafen
+ mednafen_SOURCES = debug.cpp error.cpp mempatcher.cpp settings.cpp endian.cpp mednafen.cpp file.cpp general.cpp md5.cpp memory.cpp netplay.cpp state.cpp movie.cpp player.cpp PSFLoader.cpp tests.cpp qtrecord.cpp cdplay.cpp okiadpcm.cpp FileWrapper.cpp Stream.cpp MemoryStream.cpp FileStream.cpp
+-mednafen_LDADD = trio/libtrio.a drivers/libmdfnsdl.a sexyal/libsexyal.a @SDL_LIBS@
++mednafen_LDADD = trio/libtrio.a drivers/libmdfnsdl.a sexyal/libsexyal.a @SDL_LIBS@ -lminizip
+ mednafen_DEPENDENCIES = trio/libtrio.a drivers/libmdfnsdl.a sexyal/libsexyal.a
+
+ SUBDIRS += sexyal drivers
+diff -ru mednafen.orig/src/compress/Makefile.am.inc mednafen/src/compress/Makefile.am.inc
+--- mednafen.orig/src/compress/Makefile.am.inc 2010-12-18 04:03:19.000000000 -0500
++++ mednafen/src/compress/Makefile.am.inc 2013-01-25 13:17:19.289508092 -0500
+@@ -1 +1 @@
+-mednafen_SOURCES += compress/minilzo.c compress/quicklz.c compress/blz.cpp compress/ioapi.c compress/unzip.c
++mednafen_SOURCES += compress/minilzo.c compress/quicklz.c compress/blz.cpp compress/ioapi.c
+diff -ru mednafen.orig/src/file.cpp mednafen/src/file.cpp
+--- mednafen.orig/src/file.cpp 2012-02-03 17:04:45.000000000 -0500
++++ mednafen/src/file.cpp 2013-01-25 13:17:09.527854217 -0500
+@@ -33,7 +33,7 @@
+
+
+ #include <zlib.h>
+-#include "compress/unzip.h"
++#include <minizip/unzip.h>
+
+ #include "file.h"
+ #include "general.h"
diff --git a/games-emulation/mednafen/mednafen-0.9.28.ebuild b/games-emulation/mednafen/mednafen-0.9.28.ebuild
new file mode 100644
index 000000000000..fbe9e71d4c68
--- /dev/null
+++ b/games-emulation/mednafen/mednafen-0.9.28.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/mednafen-0.9.28.ebuild,v 1.1 2013/01/26 17:44:49 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="An advanced NES, GB/GBC/GBA, TurboGrafx 16/CD, NGPC and Lynx emulator"
+HOMEPAGE="http://mednafen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mednafen/${P}-wip.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa altivec cjk debugger jack nls"
+
+RDEPEND="virtual/opengl
+ media-libs/libsndfile
+ dev-libs/libcdio
+ media-libs/libsdl[audio,joystick,video]
+ media-libs/sdl-net
+ sys-libs/zlib[minizip]
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e 's:$(datadir)/locale:/usr/share/locale:' \
+ $(find . -name Makefile.am) \
+ intl/Makefile.in || die
+ epatch \
+ "${FILESDIR}"/${P}-zlib.patch \
+ "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable altivec) \
+ $(use_enable cjk cjk-fonts) \
+ $(use_enable debugger) \
+ $(use_enable jack) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc Documentation/cheats.txt ChangeLog TODO
+ dohtml Documentation/*
+ prepgamesdirs
+}
diff --git a/games-emulation/mednafen/metadata.xml b/games-emulation/mednafen/metadata.xml
index d3c2cc926f0b..87490a093e62 100644
--- a/games-emulation/mednafen/metadata.xml
+++ b/games-emulation/mednafen/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>games</herd>
+ <herd>games</herd>
+ <use>
+ <flag name='debugger'>Build with internal debugger</flag>
+ </use>
</pkgmetadata>