summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-09-20 15:20:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-09-20 15:20:20 +0000
commit57146a81aaa056d1c2a311b86e2b91cb5f17299b (patch)
treeac9595aeb50da9d2121fc3f636b7d0094898fa78 /games-emulation
parent5.2.1 x86 stable (diff)
downloadgentoo-2-57146a81aaa056d1c2a311b86e2b91cb5f17299b.tar.gz
gentoo-2-57146a81aaa056d1c2a311b86e2b91cb5f17299b.tar.bz2
gentoo-2-57146a81aaa056d1c2a311b86e2b91cb5f17299b.zip
remove gtk2 use flag; tidy
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-glN64/ChangeLog6
-rw-r--r--games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild40
2 files changed, 24 insertions, 22 deletions
diff --git a/games-emulation/mupen64-glN64/ChangeLog b/games-emulation/mupen64-glN64/ChangeLog
index baf9d783aa2f..5037e4a3e11f 100644
--- a/games-emulation/mupen64-glN64/ChangeLog
+++ b/games-emulation/mupen64-glN64/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64-glN64
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/ChangeLog,v 1.9 2005/04/24 20:04:08 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/ChangeLog,v 1.10 2005/09/20 15:20:20 mr_bones_ Exp $
+
+ 20 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ mupen64-glN64-0.4.1_rc2-r1.ebuild:
+ remove gtk2 use flag; tidy
24 Apr 2005; Daniel Goller <morfic@gentoo.org>
+files/mupen64-glN64-noasmfix.patch, -mupen64-glN64-0.4.1_pre1.ebuild,
diff --git a/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild b/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild
index 8848afda9da3..144dd112cffc 100644
--- a/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild
+++ b/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild
@@ -1,48 +1,46 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild,v 1.5 2005/04/24 20:04:08 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild,v 1.6 2005/09/20 15:20:20 mr_bones_ Exp $
inherit eutils games
MY_P="glN64-${PV/_/-}"
-S=${WORKDIR}/${MY_P}
DESCRIPTION="An OpenGL graphics plugin for the mupen64 N64 emulator"
-SRC_URI="mirror://gentoo/glN64-0.4.1-rc2.tar.bz2"
HOMEPAGE="http://deltaanime.ath.cx/~blight/n64/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
-KEYWORDS="x86 ~amd64"
+KEYWORDS="~amd64 x86"
LICENSE="as-is"
SLOT="0"
-IUSE="asm gtk2"
+IUSE="asm"
RDEPEND="media-libs/libsdl
- !gtk2? ( =x11-libs/gtk+-1.2* )
- gtk2? ( =x11-libs/gtk+-2* )"
+ =x11-libs/gtk+-2*"
DEPEND="${RDEPEND}
- gtk2? ( dev-util/pkgconfig )"
-
-src_compile () {
- epatch ${FILESDIR}/${PN}-compile.patch || die "compile patch failed"
+ dev-util/pkgconfig"
- if use gtk2; then
- epatch ${FILESDIR}/${PN}-gtk2.patch || die "gtk2 patch failed"
- fi
+S=${WORKDIR}/${MY_P}
- epatch ${FILESDIR}/${PN}-ucode.patch || die "ucode patch failed"
- epatch ${FILESDIR}/${PN}-noasmfix.patch || die "noasmfix patch failed"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-compile.patch \
+ "${FILESDIR}"/${PN}-gtk2.patch \
+ "${FILESDIR}"/${PN}-ucode.patch \
+ "${FILESDIR}"/${PN}-noasmfix.patch
if ! use asm; then
epatch ${FILESDIR}/${PN}-noasm.patch
fi
- sed -i -e "s:CXXFLAGS.*=\(.*\):CXXFLAGS=\1 -fPIC ${CXXFLAGS}:" \
- Makefile || die "couldn't apply cflags"
-
- make || die
+ sed -i \
+ -e "s:CXXFLAGS.*=\(.*\):CXXFLAGS=\1 -fPIC ${CXXFLAGS}:" \
+ Makefile \
+ || die "sed failed"
}
src_install () {
- exeinto ${GAMES_LIBDIR}/mupen64/plugins
+ exeinto "${GAMES_LIBDIR}"/mupen64/plugins
doexe glN64-0.4.1.so || die "doexe failed"
prepgamesdirs
}