summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-27 01:50:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-27 01:50:08 +0000
commit54341cab043432acd2049a8d63e295d532e457d1 (patch)
tree3c2317e7a3625a809125b8f2e49438ff3eb66aab /games-emulation
parentIUSE (Manifest recommit) (diff)
downloadgentoo-2-54341cab043432acd2049a8d63e295d532e457d1.tar.gz
gentoo-2-54341cab043432acd2049a8d63e295d532e457d1.tar.bz2
gentoo-2-54341cab043432acd2049a8d63e295d532e457d1.zip
IUSE
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.75.ebuild11
-rw-r--r--games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild13
-rw-r--r--games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild13
-rw-r--r--games-emulation/psemu-spunull/psemu-spunull-1.0.ebuild13
4 files changed, 27 insertions, 23 deletions
diff --git a/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.75.ebuild b/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.75.ebuild
index 435852511126..0e449eda1b2c 100644
--- a/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.75.ebuild
+++ b/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.75.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.75.ebuild,v 1.2 2004/02/20 06:26:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetemesagl/psemu-gpupetemesagl-1.75.ebuild,v 1.3 2004/05/27 01:46:54 mr_bones_ Exp $
inherit games
@@ -11,17 +11,18 @@ SRC_URI="http://home.t-online.de/home/PeteBernert/gpupetemesagl${PV//.}.tar.gz"
LICENSE="freedist"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
DEPEND="virtual/opengl"
-S=${WORKDIR}
+S="${WORKDIR}"
src_install() {
- exeinto ${GAMES_LIBDIR}/psemu/plugins
+ exeinto "${GAMES_LIBDIR}/psemu/plugins"
doexe lib*
- exeinto ${GAMES_LIBDIR}/psemu/cfg
+ exeinto "${GAMES_LIBDIR}/psemu/cfg"
doexe cfgPeteMesaGL
- insinto ${GAMES_LIBDIR}/psemu/cfg
+ insinto "${GAMES_LIBDIR}/psemu/cfg"
doins gpuPeteMesaGL.cfg
dodoc readme.txt version.txt
prepgamesdirs
diff --git a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild b/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild
index cc9e1b86cc45..464878edf49e 100644
--- a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild
+++ b/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild,v 1.2 2004/02/20 06:26:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild,v 1.3 2004/05/27 01:47:45 mr_bones_ Exp $
inherit games
@@ -13,20 +13,21 @@ SRC_URI="http://home.t-online.de/home/PeteBernert/gpupetexgl${PVR//.}.tar.gz
LICENSE="freedist"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
DEPEND="virtual/opengl"
-S=${WORKDIR}
+S="${WORKDIR}"
src_install() {
- exeinto ${GAMES_LIBDIR}/psemu/plugins
+ exeinto "${GAMES_LIBDIR}/psemu/plugins"
doexe lib*
- exeinto ${GAMES_LIBDIR}/psemu/cfg
+ exeinto "${GAMES_LIBDIR}/psemu/cfg"
doexe cfgPeteXGL2
- insinto ${GAMES_LIBDIR}/psemu/cfg
+ insinto "${GAMES_LIBDIR}/psemu/cfg"
doins gpuPeteXGL2.cfg
# now do our shader files!
- insinto ${GAMES_LIBDIR}/psemu/shaders
+ insinto "${GAMES_LIBDIR}/psemu/shaders"
doins *.fp *.vp *.slf *.slv
dodoc *.txt
prepgamesdirs
diff --git a/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild b/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild
index e29fee48aaee..b17da7feda36 100644
--- a/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild
+++ b/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild,v 1.2 2004/02/13 15:42:32 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-padxwin/psemu-padxwin-1.6.ebuild,v 1.3 2004/05/27 01:48:43 mr_bones_ Exp $
inherit games eutils
@@ -11,27 +11,28 @@ SRC_URI="http://linuzappz.pcsx.net/downloads/padXwin-${PV}.tgz"
LICENSE="freedist"
SLOT="0"
KEYWORDS="x86 ~ppc"
+IUSE=""
DEPEND="=x11-libs/gtk+-1*"
-S=${WORKDIR}
+S="${WORKDIR}"
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${PV}-makefile-cflags.patch
+ epatch "${FILESDIR}/${PV}-makefile-cflags.patch"
}
src_compile() {
cd src
- emake OPTFLAGS="${CFLAGS}" || die
+ emake OPTFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
dodoc ReadMe.txt
cd src
- exeinto ${GAMES_LIBDIR}/psemu/plugins
+ exeinto "${GAMES_LIBDIR}/psemu/plugins"
doexe libpadXwin-*
- exeinto ${GAMES_LIBDIR}/psemu/cfg
+ exeinto "${GAMES_LIBDIR}/psemu/cfg"
doexe cfgPadXwin
prepgamesdirs
}
diff --git a/games-emulation/psemu-spunull/psemu-spunull-1.0.ebuild b/games-emulation/psemu-spunull/psemu-spunull-1.0.ebuild
index 7c803f406e78..79b8e51afe7e 100644
--- a/games-emulation/psemu-spunull/psemu-spunull-1.0.ebuild
+++ b/games-emulation/psemu-spunull/psemu-spunull-1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-spunull/psemu-spunull-1.0.ebuild,v 1.2 2004/02/20 06:26:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-spunull/psemu-spunull-1.0.ebuild,v 1.3 2004/05/27 01:50:08 mr_bones_ Exp $
-inherit games eutils
+inherit eutils games
DESCRIPTION="PSEmu plugin to use a null sound driver"
HOMEPAGE="http://www.pcsx.net/"
@@ -11,23 +11,24 @@ SRC_URI="http://linuzappz.pcsx.net/downloads/spunull-${PV}.tgz"
LICENSE="freedist"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
-S=${WORKDIR}
+S="${WORKDIR}"
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${PV}-makefile-cflags.patch
+ epatch "${FILESDIR}/${PV}-makefile-cflags.patch"
}
src_compile() {
cd src
- emake OPTFLAGS="${CFLAGS}" || die
+ emake OPTFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
dodoc ReadMe.txt
cd src
- exeinto ${GAMES_LIBDIR}/psemu/plugins
+ exeinto "${GAMES_LIBDIR}/psemu/plugins"
doexe libspunull-*
prepgamesdirs
}