summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-30 14:45:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-30 14:45:10 +0000
commit4fac1f2566c24f656510cbab15175037f0ecf2e1 (patch)
treea39f0206cce09b987f644a5ac6663dd6c83bbe43 /games-emulation
parentCleanup (diff)
downloadgentoo-2-4fac1f2566c24f656510cbab15175037f0ecf2e1.tar.gz
gentoo-2-4fac1f2566c24f656510cbab15175037f0ecf2e1.tar.bz2
gentoo-2-4fac1f2566c24f656510cbab15175037f0ecf2e1.zip
not parallel safe in the build
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmess/ChangeLog7
-rw-r--r--games-emulation/xmess/xmess-0.106.ebuild10
2 files changed, 10 insertions, 7 deletions
diff --git a/games-emulation/xmess/ChangeLog b/games-emulation/xmess/ChangeLog
index 1329c19a53b7..3228d739caa4 100644
--- a/games-emulation/xmess/ChangeLog
+++ b/games-emulation/xmess/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/xmess
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.61 2008/03/13 20:25:04 wolf31o2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.62 2009/01/30 14:45:10 mr_bones_ Exp $
+
+ 30 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> xmess-0.106.ebuild:
+ not parallel safe in the build
13 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org> xmess-0.83.1.ebuild:
QA cleanup: Fix quoting (again).
diff --git a/games-emulation/xmess/xmess-0.106.ebuild b/games-emulation/xmess/xmess-0.106.ebuild
index 336fff0dcd8b..35856a835e60 100644
--- a/games-emulation/xmess/xmess-0.106.ebuild
+++ b/games-emulation/xmess/xmess-0.106.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.8 2007/04/09 17:39:11 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.9 2009/01/30 14:45:10 mr_bones_ Exp $
inherit flag-o-matic toolchain-funcs eutils games
@@ -149,11 +149,11 @@ EOF
src_compile() {
local disp=0
if use sdl ; then
- emake DISPLAY_METHOD=SDL || die "emake failed (SDL)"
+ emake -j1 DISPLAY_METHOD=SDL || die "emake failed (SDL)"
disp=1
fi
if use svga ; then
- emake DISPLAY_METHOD=svgalib || die "emake failed (svgalib)"
+ emake -j1 DISPLAY_METHOD=svgalib || die "emake failed (svgalib)"
disp=1
fi
if use ggi ; then
@@ -162,7 +162,7 @@ src_compile() {
ewarn "GGI support is currently (${PV}) broken :("
fi
if [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
- emake DISPLAY_METHOD=x11 || die "emake failed (x11)"
+ emake -j1 DISPLAY_METHOD=x11 || die "emake failed (x11)"
fi
}