summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-07-11 15:17:18 +0000
committerSimon Stelling <blubb@gentoo.org>2005-07-11 15:17:18 +0000
commit46004146b357296f6fb575ec2a3314522f9bad5c (patch)
tree64fabb437c2432394d8e08c9c8c5a9b8d2052661 /games-emulation
parentMark 2.4.4 stable on x86. (diff)
downloadgentoo-2-46004146b357296f6fb575ec2a3314522f9bad5c.tar.gz
gentoo-2-46004146b357296f6fb575ec2a3314522f9bad5c.tar.bz2
gentoo-2-46004146b357296f6fb575ec2a3314522f9bad5c.zip
bug 89876
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dosbox/ChangeLog6
-rw-r--r--games-emulation/dosbox/dosbox-0.63.ebuild9
-rw-r--r--games-emulation/dosbox/files/0.63-64bit.patch11
3 files changed, 24 insertions, 2 deletions
diff --git a/games-emulation/dosbox/ChangeLog b/games-emulation/dosbox/ChangeLog
index 71228d7addd2..b4afefea2682 100644
--- a/games-emulation/dosbox/ChangeLog
+++ b/games-emulation/dosbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/dosbox
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.18 2005/06/15 18:32:57 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.19 2005/07/11 15:17:18 blubb Exp $
+
+ 11 Jul 2005; Simon Stelling <blubb@gentoo.org> +files/0.63-64bit.patch,
+ dosbox-0.63.ebuild:
+ fix bug 89876
15 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org> dosbox-0.58.ebuild,
dosbox-0.62.ebuild, dosbox-0.63.ebuild:
diff --git a/games-emulation/dosbox/dosbox-0.63.ebuild b/games-emulation/dosbox/dosbox-0.63.ebuild
index 426d54f5ce58..4ceae2a116bf 100644
--- a/games-emulation/dosbox/dosbox-0.63.ebuild
+++ b/games-emulation/dosbox/dosbox-0.63.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.63.ebuild,v 1.2 2005/06/15 18:32:57 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.63.ebuild,v 1.3 2005/07/11 15:17:18 blubb Exp $
inherit eutils games
@@ -22,6 +22,13 @@ DEPEND="virtual/libc
>=media-libs/sdl-net-1
media-libs/sdl-sound"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use amd64 && epatch ${FILESDIR}/${PV}-64bit.patch
+}
+
src_compile() {
local myconf=
diff --git a/games-emulation/dosbox/files/0.63-64bit.patch b/games-emulation/dosbox/files/0.63-64bit.patch
new file mode 100644
index 000000000000..765a8c57fae8
--- /dev/null
+++ b/games-emulation/dosbox/files/0.63-64bit.patch
@@ -0,0 +1,11 @@
+--- src/dos/drive_local.cpp 2005-07-11 17:06:44.000000000 +0200
++++ src/dos/drive_local.cpp 2005-07-11 17:07:16.000000000 +0200
+@@ -409,7 +409,7 @@
+ //TODO Give some doserrorcode;
+ return false;//ERROR
+ }
+- int ret=fseek(fhandle,*pos,seektype);
++ int ret=fseek(fhandle,*reinterpret_cast<Bit32s*>(pos),seektype);
+ if (ret!=0) {
+ // Out of file range, pretend everythings ok
+ // and move file pointer top end of file... ?! (Black Thorne)