summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-28 04:29:13 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-28 04:29:13 +0000
commit37f87f4c312a6eb1c45e71f9e3cbb614cc45987d (patch)
tree4a821fc49c31361cf5dc93af6d17728e7a8cb3e4 /games-emulation
parentMarked amd64. First fsv tag for amd64. (Manifest recommit) (diff)
downloadgentoo-2-37f87f4c312a6eb1c45e71f9e3cbb614cc45987d.tar.gz
gentoo-2-37f87f4c312a6eb1c45e71f9e3cbb614cc45987d.tar.bz2
gentoo-2-37f87f4c312a6eb1c45e71f9e3cbb614cc45987d.zip
QA - fix use invocation
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/generator/ChangeLog5
-rw-r--r--games-emulation/generator/generator-0.35.ebuild17
2 files changed, 10 insertions, 12 deletions
diff --git a/games-emulation/generator/ChangeLog b/games-emulation/generator/ChangeLog
index 8f370d9bf0c8..6cc36af2c265 100644
--- a/games-emulation/generator/ChangeLog
+++ b/games-emulation/generator/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/generator
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/ChangeLog,v 1.7 2004/06/24 22:27:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/ChangeLog,v 1.8 2004/06/28 04:29:13 agriffis Exp $
+
+ 27 Jun 2004; Aron Griffis <agriffis@gentoo.org> generator-0.35.ebuild:
+ QA - fix use invocation
30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> generator-0.35.ebuild:
don't rdepend on nasm; "use arch" instead of "ARCH == "
diff --git a/games-emulation/generator/generator-0.35.ebuild b/games-emulation/generator/generator-0.35.ebuild
index 069940ea4cf0..afa6bd8c4a35 100644
--- a/games-emulation/generator/generator-0.35.ebuild
+++ b/games-emulation/generator/generator-0.35.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35.ebuild,v 1.9 2004/06/24 22:27:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35.ebuild,v 1.10 2004/06/28 04:29:13 agriffis Exp $
inherit eutils gcc games
@@ -47,15 +47,17 @@ src_unpack() {
src_compile() {
local myconf="--with-gcc=$(gcc-major-version)"
- local mygui=
+ local mygui myguis
use x86 \
&& myconf="${myconf} --with-raze" \
|| myconf="${myconf} --with-cmz80"
- for mygui in `use gtk` `use svga` ; do
- [ "${mygui}" == "svga" ] && mygui=svgalib
+ use gtk && myguis="gtk"
+ use svga && myguis="svgalib"
+ [ -n "${myguis}" ] || myguis="gtk"
+ for mygui in ${myguis}; do
if [ -f Makefile ] ; then
make clean
fi
@@ -65,13 +67,6 @@ src_compile() {
emake -j1 || die "building ${mygui}"
mv main/generator-${mygui} my-bins/
done
- if [ -z "`use gtk``use svga`" ] ; then
- egamesconf \
- ${myconf} \
- --with-gtk || die
- emake -j1 || die "building ${mygui}"
- mv main/generator-gtk my-bins/
- fi
}
src_install() {