summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-07-06 07:54:40 +0000
committerSimon Stelling <blubb@gentoo.org>2006-07-06 07:54:40 +0000
commit2896b68af61e2b2a94b86e4d9f209cbf5c25d248 (patch)
tree87ca7f25e5a7c018c282e3513ef63ae1eca88146 /games-emulation
parent~amd64 (diff)
downloadgentoo-2-2896b68af61e2b2a94b86e4d9f209cbf5c25d248.tar.gz
gentoo-2-2896b68af61e2b2a94b86e4d9f209cbf5c25d248.tar.bz2
gentoo-2-2896b68af61e2b2a94b86e4d9f209cbf5c25d248.zip
forgot to apply the -fPIC patches from bug 112798; thanks joker
(Portage version: 3387-svn)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mamory/ChangeLog5
-rw-r--r--games-emulation/mamory/mamory-0.2.20.ebuild21
2 files changed, 22 insertions, 4 deletions
diff --git a/games-emulation/mamory/ChangeLog b/games-emulation/mamory/ChangeLog
index cf6b8d29301e..4b1fa372415f 100644
--- a/games-emulation/mamory/ChangeLog
+++ b/games-emulation/mamory/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/mamory
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/ChangeLog,v 1.14 2006/07/06 07:51:53 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/ChangeLog,v 1.15 2006/07/06 07:54:40 blubb Exp $
+
+ 06 Jul 2006; Simon Stelling <blubb@gentoo.org> mamory-0.2.20.ebuild:
+ forgot to apply the -fPIC patches from bug 112798; thanks joker
06 Jul 2006; Simon Stelling <blubb@gentoo.org> mamory-0.2.20.ebuild:
added ~amd64 keyword
diff --git a/games-emulation/mamory/mamory-0.2.20.ebuild b/games-emulation/mamory/mamory-0.2.20.ebuild
index 59ef207116af..67821b07df9f 100644
--- a/games-emulation/mamory/mamory-0.2.20.ebuild
+++ b/games-emulation/mamory/mamory-0.2.20.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/mamory-0.2.20.ebuild,v 1.2 2006/07/06 07:51:53 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mamory/mamory-0.2.20.ebuild,v 1.3 2006/07/06 07:54:40 blubb Exp $
-inherit games
+inherit games autotools
DESCRIPTION="rom management tools and library"
HOMEPAGE="http://mamory.sourceforge.net/"
@@ -16,9 +16,24 @@ IUSE=""
DEPEND=""
RDEPEND=""
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Remove hardcoded CFLAGS options
+ sed -i configure.in \
+ -e '/AC_ARG_ENABLE(debug,/ {N;N;N;d}'
+
+ # Make it possible for eautoreconf to fix fPIC etc.
+ sed -i common/Makefile.am \
+ -e '/libcommon_la_LDFLAGS= -static/d'
+
+ AT_M4DIR="config" eautoreconf || die
+}
+
src_compile() {
egamesconf \
- --disable-debug \
--disable-dependency-tracking \
--includedir=/usr/include || die
emake || die "emake failed"