summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-07-29 04:05:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-07-29 04:05:16 +0000
commit1986192a754fcb24cf0bcc0cd8c76a41382b9643 (patch)
treef32c1f4df37d20af05b3470564d40895b5262368 /games-emulation
parentThe PostgreSQL plugin needs just libpq, not a (local) server. (diff)
downloadgentoo-2-1986192a754fcb24cf0bcc0cd8c76a41382b9643.tar.gz
gentoo-2-1986192a754fcb24cf0bcc0cd8c76a41382b9643.tar.bz2
gentoo-2-1986192a754fcb24cf0bcc0cd8c76a41382b9643.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/raine/ChangeLog9
-rw-r--r--games-emulation/raine/raine-0.51.5.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/games-emulation/raine/ChangeLog b/games-emulation/raine/ChangeLog
index 78c18e154c52..2728b6fe91c6 100644
--- a/games-emulation/raine/ChangeLog
+++ b/games-emulation/raine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/raine
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.21 2008/05/08 21:58:55 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.22 2009/07/29 04:05:16 mr_bones_ Exp $
+
+*raine-0.51.5 (29 Jul 2009)
+
+ 29 Jul 2009; Michael Sterrett <mr_bones_@gentoo.org> +raine-0.51.5.ebuild:
+ version bump
08 May 2008; Michael Sterrett <mr_bones_@gentoo.org> raine-0.50.7.ebuild:
never try to run nasmw
diff --git a/games-emulation/raine/raine-0.51.5.ebuild b/games-emulation/raine/raine-0.51.5.ebuild
new file mode 100644
index 000000000000..d06922adfccd
--- /dev/null
+++ b/games-emulation/raine/raine-0.51.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/raine-0.51.5.ebuild,v 1.1 2009/07/29 04:05:16 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="R A I N E M680x0 Arcade Emulation"
+HOMEPAGE="http://rainemu.swishparty.co.uk/"
+SRC_URI="http://rainemu.swishparty.co.uk/html/archive/raines-${PV}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+
+RDEPEND="dev-cpp/muParser
+ media-libs/libsdl
+ sys-libs/zlib
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ app-arch/unzip"
+
+src_prepare() {
+ echo > detect-cpu
+ echo > cpuinfo
+ sed -i \
+ -e "/^NEO/s:^:#:" \
+ -e "s:nasmw:nasm:" \
+ -e "/bindir/s:=.*:=\$(DESTDIR)${GAMES_BINDIR}:" \
+ -e "/sharedir =/s:=.*:=\$(DESTDIR)${GAMES_DATADIR}:" \
+ -e "/mandir/s:=.*:=\$(DESTDIR)/usr/share/man/man6:" \
+ makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ local myopts
+
+ use static \
+ && myopts="${myopts} STATIC=1" \
+ || myopts="${myopts} STATIC="
+ emake \
+ _MARCH="${CFLAGS}" \
+ ${myopts} || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ keepdir "${GAMES_DATADIR}"/${PN}/{roms,artwork,emudx,scripts/raine}
+ dodoc docs/readme.txt
+ prepgamesdirs
+}