summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-01 16:09:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-01 16:09:08 +0000
commit114fa3cbd7839ac5f25319738e2b76ab3e46a793 (patch)
tree7a410d047c337128ae66c598379f11695d15a93c /games-emulation
parentpunt svga support (diff)
downloadgentoo-2-114fa3cbd7839ac5f25319738e2b76ab3e46a793.tar.gz
gentoo-2-114fa3cbd7839ac5f25319738e2b76ab3e46a793.tar.bz2
gentoo-2-114fa3cbd7839ac5f25319738e2b76ab3e46a793.zip
punt svga support
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/advancemame-1.2.ebuild11
2 files changed, 10 insertions, 9 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 8bb33c7b0f76..fc808762e9ae 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/advancemame
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.49 2013/02/17 03:51:09 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.50 2014/07/01 16:09:08 mr_bones_ Exp $
+
+ 01 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org> advancemame-1.2.ebuild:
+ punt svga support
*advancemame-1.2 (17 Feb 2013)
@@ -280,4 +283,3 @@
24 Aug 2002; Martin Schlemmer <azarah@gentoo.org> :
Initial version contributed by myself.
-
diff --git a/games-emulation/advancemame/advancemame-1.2.ebuild b/games-emulation/advancemame/advancemame-1.2.ebuild
index 5aada4e7117a..62b8b0d7f4cb 100644
--- a/games-emulation/advancemame/advancemame-1.2.ebuild
+++ b/games-emulation/advancemame/advancemame-1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-1.2.ebuild,v 1.1 2013/02/17 03:51:09 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-1.2.ebuild,v 1.2 2014/07/01 16:09:08 mr_bones_ Exp $
EAPI=5
inherit eutils flag-o-matic games
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
LICENSE="GPL-2 XMAME"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa fbcon oss static svga truetype"
+IUSE="alsa fbcon oss static truetype"
# sdl is required (bug #158417)
RDEPEND="app-arch/unzip
@@ -21,8 +21,7 @@ RDEPEND="app-arch/unzip
media-libs/libsdl
sys-libs/zlib
alsa? ( media-libs/alsa-lib )
- truetype? ( media-libs/freetype )
- svga? ( >=media-libs/svgalib-1.9 )"
+ truetype? ( media-libs/freetype )"
DEPEND="${RDEPEND}
virtual/os-headers
x86? ( >=dev-lang/nasm-0.98 )"
@@ -54,11 +53,11 @@ src_configure() {
--enable-sdl \
--enable-zlib \
--disable-slang \
+ --disable-svgalib \
$(use_enable alsa) \
$(use_enable fbcon fb) \
$(use_enable oss) \
$(use_enable static) \
- $(use_enable svga svgalib) \
$(use_enable truetype freetype) \
$(use_enable x86 asm) \
--with-emu=${PN/advance}