summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-06 23:56:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-06 23:56:36 +0000
commitf2d6209028115e4222b5c0d2219285bf0bd39d17 (patch)
tree65931b0999c5bee463e42f30d5b162acfdb6ec58 /games-emulation/xmame
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-f2d6209028115e4222b5c0d2219285bf0bd39d17.tar.gz
gentoo-2-f2d6209028115e4222b5c0d2219285bf0bd39d17.tar.bz2
gentoo-2-f2d6209028115e4222b5c0d2219285bf0bd39d17.zip
version bump
Diffstat (limited to 'games-emulation/xmame')
-rw-r--r--games-emulation/xmame/ChangeLog7
-rw-r--r--games-emulation/xmame/Manifest2
-rw-r--r--games-emulation/xmame/files/digest-xmame-0.891
-rw-r--r--games-emulation/xmame/xmame-0.89.ebuild207
4 files changed, 216 insertions, 1 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index 2c79a77204aa..a0fa7d7dcd74 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/xmame
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.30 2004/11/30 20:54:06 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.31 2004/12/06 23:56:36 mr_bones_ Exp $
+
+*xmame-0.89 (06 Dec 2004)
+
+ 06 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org> +xmame-0.89.ebuild:
+ version bump
30 Nov 2004; Sven Wegener <swegener@gentoo.org> xmame-0.88.ebuild:
Added missing ? after USE flag in dependency.
diff --git a/games-emulation/xmame/Manifest b/games-emulation/xmame/Manifest
index e3ec4a051149..bc12bee9c83b 100644
--- a/games-emulation/xmame/Manifest
+++ b/games-emulation/xmame/Manifest
@@ -2,6 +2,7 @@ MD5 1bfbc5236e4fbf2e323be0a45cd8652e ChangeLog 7382
MD5 e44da7fe9271f2f2e299cc34df120830 metadata.xml 1537
MD5 30e8d4b0106df48fc70f99beb5608280 xmame-0.82.1.ebuild 6437
MD5 3bfc553fbd6d37187aba00e77fb80875 xmame-0.83.1.ebuild 6774
+MD5 f23f07aad63a835cbf245a45a5abbc3f xmame-0.89.ebuild 5595
MD5 f23f07aad63a835cbf245a45a5abbc3f xmame-0.88.ebuild 5595
MD5 8678f14a1893c1e9c8fa453ebd051382 xmame-0.86.ebuild 5877
MD5 9bbbd2de60f0c41f643674a694cd2c90 files/0.77.1-alsa-1.0.0.patch 438
@@ -22,4 +23,5 @@ MD5 d60ae5dd2d8a993999a9a252d20507cf files/digest-xmame-0.82.1 67
MD5 bd94e56aecab93b1d9e02b6fb3d8a0e9 files/digest-xmame-0.83.1 67
MD5 1c5281cca09cd38869fa3715b3839b1b files/digest-xmame-0.86 65
MD5 60b1266244271466b84fb43fc9483ff2 files/digest-xmame-0.88 65
+MD5 61102d8121de66b952f348dd992ab7e9 files/digest-xmame-0.89 65
MD5 240bd404f0deb6cd68bf6a98a5fb76db files/0.88-glx-fix.patch 386
diff --git a/games-emulation/xmame/files/digest-xmame-0.89 b/games-emulation/xmame/files/digest-xmame-0.89
new file mode 100644
index 000000000000..d54e8daebaf6
--- /dev/null
+++ b/games-emulation/xmame/files/digest-xmame-0.89
@@ -0,0 +1 @@
+MD5 76554475dec85223e01a5bf8c9c9158c xmame-0.89.tar.bz2 14933673
diff --git a/games-emulation/xmame/xmame-0.89.ebuild b/games-emulation/xmame/xmame-0.89.ebuild
new file mode 100644
index 000000000000..6e2d665e3e1c
--- /dev/null
+++ b/games-emulation/xmame/xmame-0.89.ebuild
@@ -0,0 +1,207 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.89.ebuild,v 1.1 2004/12/06 23:56:36 mr_bones_ Exp $
+
+inherit flag-o-matic gcc eutils games
+
+TARGET="${PN}"
+
+DESCRIPTION="Multiple Arcade Machine Emulator for X11"
+HOMEPAGE="http://x.mame.net/"
+SRC_URI="http://x.mame.net/download/xmame-${PV}.tar.bz2"
+
+LICENSE="xmame"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="3dfx alsa arts dga esd ggi joystick net opengl sdl svga X xv"
+
+RDEPEND="sys-libs/zlib
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ alsa? ( media-libs/alsa-lib )
+ xv? ( virtual/x11 )
+ dga? ( virtual/x11 )
+ X? ( virtual/x11 )
+ opengl? (
+ virtual/x11
+ virtual/opengl
+ virtual/glu )
+ expat? ( dev-libs/expat )
+ esd? ( >=media-sound/esound-0.2.29 )
+ svga? ( media-libs/svgalib )
+ ggi? ( media-libs/libggi )
+ arts? ( kde-base/arts )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+# Icc sucks. bug #41342
+# icc? ( dev-lang/icc )
+
+S="${WORKDIR}/xmame-${PV}"
+
+toggle_feature() {
+ if use $1 ; then
+ sed -i \
+ -e "/$2.*=/s:#::" Makefile \
+ || die "sed Makefile ($1 / $2) failed"
+ fi
+}
+toggle_feature2() {
+ use $1 && toggle_feature $2 $3
+}
+
+src_unpack() {
+ local mycpu=
+
+ unpack ${A}
+ cd "${S}"
+
+ case ${ARCH} in
+ x86) mycpu="i386";;
+ ia64) mycpu="ia64";;
+ amd64) mycpu="amd64";;
+ ppc) mycpu="risc";;
+ sparc) mycpu="risc";;
+ hppa) mycpu="risc";;
+ alpha) mycpu="alpha";;
+ mips) mycpu="mips";;
+ esac
+
+ sed -i \
+ -e '/^BUILD_EXPAT/s/^/#/' \
+ -e "/^PREFIX/s:=.*:=/usr:" \
+ -e "/^MY_CPU/s:i386:${mycpu}:" \
+ -e "/^BINDIR/s:=.*:=${GAMES_BINDIR}:" \
+ -e "/^MANDIR/s:=.*:=/usr/share/man/man6:" \
+ -e "/^XMAMEROOT/s:=.*:=${GAMES_DATADIR}/${TARGET}:" \
+ -e "/^TARGET/s:mame:${TARGET:1}:" \
+ -e "s:^CFLAGS =:CFLAGS=${CFLAGS}:" \
+ Makefile \
+ || die "sed Makefile failed"
+
+ if use ppc ; then
+ sed -i \
+ -e '/LD.*--relax/s:^# ::' Makefile \
+ || die "sed Makefile (ppc/LD) failed"
+ fi
+
+
+ #toggle_feature x86 X86_ASM_68020 # Broken
+ toggle_feature x86 X86_ASM_68000
+ toggle_feature x86 X86_MIPS3_DRC
+ toggle_feature2 x86 mmx EFFECT_MMX_ASM
+ toggle_feature joystick JOY_STANDARD
+ use net && ewarn "Network support is currently (${PV}) broken :("
+ #toggle_feature net XMAME_NET # Broken
+ toggle_feature esd SOUND_ESOUND
+ toggle_feature alsa SOUND_ALSA
+ toggle_feature arts SOUND_ARTS
+ toggle_feature dga X11_DGA
+ toggle_feature xv X11_XV
+ toggle_feature expat BUILD_EXPAT
+ toggle_feature opengl X11_OPENGL
+
+ case ${ARCH} in
+ x86|ia64|amd64)
+ append-flags -Wno-unused -fomit-frame-pointer -fstrict-aliasing -fstrength-reduce
+ use amd64 || append-flags -ffast-math #54270
+ [ $(gcc-major-version) -eq 3 ] \
+ && append-flags -falign-functions=2 -falign-jumps=2 -falign-loops=2 \
+ || append-flags -malign-functions=2 -malign-jumps=2 -malign-loops=2
+ ;;
+ ppc)
+ append-flags -Wno-unused -funroll-loops -fstrength-reduce -fomit-frame-pointer -ffast-math -fsigned-char
+ ;;
+ hppa)
+ append-flags -ffunction-sections
+ ;;
+ esac
+
+ sed -i \
+ -e "s:[Xx]mame:${TARGET}:g" \
+ doc/*.6 \
+ || die "sed man pages failed"
+ sed -i \
+ -e '/^QUIET/s:^:#:' src/unix/unix.mak \
+ || die "sed src/unix/unix.mak failed"
+}
+
+src_compile() {
+ local disp=0
+ if use sdl ; then
+ emake DISPLAY_METHOD=SDL || die "emake failed (SDL)"
+ disp=1
+ fi
+ if use svga ; then
+ emake DISPLAY_METHOD=svgalib || die "emake failed (svgalib)"
+ disp=1
+ fi
+ if use ggi ; then
+ #emake DISPLAY_METHOD=ggi || die "emake failed (ggi)"
+ #disp=1
+ ewarn "GGI support is currently (${PV}) broken :("
+ fi
+ if [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+ emake DISPLAY_METHOD=x11 || die "emake failed (x11)"
+ fi
+}
+
+src_install() {
+ local disp=0
+
+ sed -i \
+ -e "s:^PREFIX.*:PREFIX=${D}/usr:" \
+ -e "s:^BINDIR.*:BINDIR=${D}/${GAMES_BINDIR}:" \
+ -e "s:^MANDIR.*:MANDIR=${D}/usr/share/man/man6:" \
+ -e "s:^XMAMEROOT.*:XMAMEROOT=${D}/${GAMES_DATADIR}/${TARGET}:" \
+ Makefile \
+ || die "sed Makefile failed"
+
+ if use sdl ; then
+ make DISPLAY_METHOD=SDL install || die "install failed (sdl)"
+ disp=1
+ fi
+ if use svga ; then
+ make DISPLAY_METHOD=svgalib install || die "install failed (svga)"
+ disp=1
+ fi
+ if use ggi ; then
+ #make DISPLAY_METHOD=ggi install || die "install failed (ggi)"
+ #disp=1
+ ewarn "GGI support is currently (${PV}) broken :("
+ fi
+ if [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+ make DISPLAY_METHOD=x11 install || die "install failed (x11)"
+ fi
+ exeinto "${GAMES_LIBDIR}/${PN}"
+ doexe chdman || die "doexe failed"
+ if [ ${PN} == "xmame" ; then
+ doexe xml2info || die "doexe failed"
+ fi
+
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r ctrlr "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
+ dodoc doc/{changes.*,*.txt,mame/*,${TARGET}rc.dist} README todo \
+ || die "dodoc failed"
+ dohtml -r doc/* || die "dohtml failed"
+
+ if [ ${disp} -eq 0 ] || use opengl || use X || use dga || use xv ; then
+ dosym "${TARGET}.x11" "${GAMES_BINDIR}/${TARGET}"
+ elif use sdl ; then
+ dosym "${TARGET}.SDL" "${GAMES_BINDIR}/${TARGET}"
+ elif use svga ; then
+ dosym ${TARGET}.svgalib "${GAMES_BINDIR}/${TARGET}"
+ #elif use ggi ; then
+ #dosym ${TARGET}.ggi "${GAMES_BINDIR}/${TARGET}"
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "Your available MAME binaries are: ${TARGET}"
+ if useq opengl || useq X || useq dga || useq xv ; then
+ einfo " ${TARGET}.x11"
+ fi
+ useq sdl && einfo " ${TARGET}.SDL"
+ #useq ggi && einfo " ${TARGET}.ggi"
+ useq svga && einfo " ${TARGET}.svgalib"
+}