summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-02 20:17:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-02 20:17:20 +0000
commit34ed351de74d343d070c787a1162f0049af95042 (patch)
tree2e85c5d0bef1bdde15284fd3bcb0cbab1fd36158 /games-emulation/xmame
parentreconfig hook now cleans up after itself (Manifest recommit) (diff)
downloadgentoo-2-34ed351de74d343d070c787a1162f0049af95042.tar.gz
gentoo-2-34ed351de74d343d070c787a1162f0049af95042.tar.bz2
gentoo-2-34ed351de74d343d070c787a1162f0049af95042.zip
Install chdman and xml2info in GAMES_LIBDIR
Diffstat (limited to 'games-emulation/xmame')
-rw-r--r--games-emulation/xmame/ChangeLog5
-rw-r--r--games-emulation/xmame/xmame-0.86.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index 3f1a945254a7..2fd8d6a4a006 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/xmame
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.26 2004/09/02 19:42:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.27 2004/09/02 20:17:20 mr_bones_ Exp $
+
+ 02 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.86.ebuild:
+ Install chdman and xml2info in GAMES_LIBDIR
02 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.86.ebuild:
turn on joystick support always for libsdl; should fix bug #62620
diff --git a/games-emulation/xmame/xmame-0.86.ebuild b/games-emulation/xmame/xmame-0.86.ebuild
index a80016b8eee7..87616cdb3b88 100644
--- a/games-emulation/xmame/xmame-0.86.ebuild
+++ b/games-emulation/xmame/xmame-0.86.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.86.ebuild,v 1.2 2004/09/02 19:42:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.86.ebuild,v 1.3 2004/09/02 20:17:20 mr_bones_ Exp $
inherit flag-o-matic gcc eutils games
@@ -179,7 +179,8 @@ src_install() {
if [ ${disp} -eq 0 ] || use X || use dga || use xv ; then
make DISPLAY_METHOD=x11 install || die "install failed (x11)"
fi
- dogamesbin chdman || die "dogamesbin chdman failed"
+ exeinto "${GAMES_LIBDIR}/${PN}"
+ doexe chdman xml2info || die "doexe failed"
dodir "${GAMES_DATADIR}/${PN}"
cp -r ctrlr "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"