summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-18 19:37:48 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-18 19:37:48 +0000
commit6679d243c6e0bd45136b8717f9622f1f7dea29b2 (patch)
treee05b013e624c471765fd23343c107ce1b4f7f7e0 /games-emulation/tuxnes
parentStable on ppc64; bug #151838 (diff)
downloadgentoo-2-6679d243c6e0bd45136b8717f9622f1f7dea29b2.tar.gz
gentoo-2-6679d243c6e0bd45136b8717f9622f1f7dea29b2.tar.bz2
gentoo-2-6679d243c6e0bd45136b8717f9622f1f7dea29b2.zip
Use autotools eclass
(Portage version: 2.1.2_pre3-r4)
Diffstat (limited to 'games-emulation/tuxnes')
-rw-r--r--games-emulation/tuxnes/ChangeLog6
-rw-r--r--games-emulation/tuxnes/files/digest-tuxnes-0.752
-rw-r--r--games-emulation/tuxnes/files/tuxnes-0.75-configure.in.patch19
-rw-r--r--games-emulation/tuxnes/tuxnes-0.75.ebuild34
4 files changed, 36 insertions, 25 deletions
diff --git a/games-emulation/tuxnes/ChangeLog b/games-emulation/tuxnes/ChangeLog
index fd8c544ad9d7..9100d35ff28b 100644
--- a/games-emulation/tuxnes/ChangeLog
+++ b/games-emulation/tuxnes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/tuxnes
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/ChangeLog,v 1.7 2006/03/23 20:42:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/ChangeLog,v 1.8 2006/10/18 19:37:48 nyhm Exp $
+
+ 18 Oct 2006; Tristan Heaven <nyhm@gentoo.org>
+ files/tuxnes-0.75-configure.in.patch, tuxnes-0.75.ebuild:
+ Use autotools eclass
23 Mar 2006; Michael Sterrett <mr_bones_@gentoo.org> tuxnes-0.75.ebuild:
more dep fixing (bug #122168); use games eclass
diff --git a/games-emulation/tuxnes/files/digest-tuxnes-0.75 b/games-emulation/tuxnes/files/digest-tuxnes-0.75
index 7bc52404f40d..aeda4a20064b 100644
--- a/games-emulation/tuxnes/files/digest-tuxnes-0.75
+++ b/games-emulation/tuxnes/files/digest-tuxnes-0.75
@@ -1 +1,3 @@
MD5 5db0cd42dfdff3e681805e93b4867c43 tuxnes-0.75.tar.gz 198735
+RMD160 d4a94e00f7c90cbf6fbf19537ede22aca05eeafd tuxnes-0.75.tar.gz 198735
+SHA256 217fc57fdd2a5ec360c197ea36110ec929d3f27c88cf875f0f4723b3496ed7c2 tuxnes-0.75.tar.gz 198735
diff --git a/games-emulation/tuxnes/files/tuxnes-0.75-configure.in.patch b/games-emulation/tuxnes/files/tuxnes-0.75-configure.in.patch
index 06c011fc6298..d0319ca6d0a7 100644
--- a/games-emulation/tuxnes/files/tuxnes-0.75-configure.in.patch
+++ b/games-emulation/tuxnes/files/tuxnes-0.75-configure.in.patch
@@ -1,14 +1,21 @@
---- tuxnes-0.75/configure.in
-+++ tuxnes-0.75/configure.in
-@@ -31,7 +31,7 @@
+--- configure.in
++++ configure.in
+@@ -31,7 +31,6 @@
dnl Don't assume we want high level optimisations, it is known to
dnl produce broken code on certain architectures using certain compilers
dnl --------------------------------------------------------------------
-CFLAGS="-O"
-+dnl CFLAGS="-O"
AC_SUBST(CFLAGS)
dnl --------------------------------------------------------------------
+@@ -39,6 +38,7 @@
+ dnl --------------------------------------------------------------------
+ AC_PROG_CC
+ AC_PROG_INSTALL
++AM_PROG_AS
+
+ dnl --------------------------------------------------------------------
+ dnl Check whether user wants simple warnings or advanced warnings
@@ -46,12 +46,10 @@
AC_ARG_ENABLE(warnings, [ --enable-warnings enable more compilation warning checks [default=no]], enable_warnings="yes", enable_warnings="no")
@@ -23,7 +30,8 @@
fi
AC_SUBST(CFLAGS)
-@@ -144,10 +144,7 @@
+@@ -144,12 +142,9 @@
+ [ --without-ggi disable check for GGI (General Graphics Interface)])
if test "x$with_ggi" != "xno"; then
- OCPPFLAGS="$CPPFLAGS"
@@ -35,3 +43,4 @@
- CPPFLAGS="$OCPPFLAGS"
fi
+ dnl --------------------------------------------------------------------
diff --git a/games-emulation/tuxnes/tuxnes-0.75.ebuild b/games-emulation/tuxnes/tuxnes-0.75.ebuild
index b75f6ffc8ce7..8cd6e6b2b484 100644
--- a/games-emulation/tuxnes/tuxnes-0.75.ebuild
+++ b/games-emulation/tuxnes/tuxnes-0.75.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/tuxnes-0.75.ebuild,v 1.8 2006/03/23 20:42:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/tuxnes-0.75.ebuild,v 1.9 2006/10/18 19:37:48 nyhm Exp $
-inherit flag-o-matic eutils games
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit autotools flag-o-matic eutils games
DESCRIPTION="emulator for the 8-bit Nintendo Entertainment System"
HOMEPAGE="http://tuxnes.sourceforge.net/"
@@ -13,22 +15,17 @@ SLOT="0"
KEYWORDS="x86"
IUSE="X ggi"
-RDEPEND="sys-libs/zlib
- X? ( || (
- (
- x11-libs/libXext
- x11-libs/libICE
- x11-libs/libX11
- x11-libs/libXpm
- x11-libs/libSM )
- virtual/x11 ) )
+RDEPEND="X? (
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libSM )
ggi? ( >=media-libs/libggi-2.0.1 )"
DEPEND="${RDEPEND}
- X? ( || (
- (
- x11-proto/xextproto
- x11-proto/xproto )
- virtual/x11 ) )"
+ X? (
+ x11-proto/xextproto
+ x11-proto/xproto )"
src_unpack() {
unpack ${A}
@@ -36,8 +33,7 @@ src_unpack() {
epatch \
"${FILESDIR}"/${P}-configure.in.patch \
"${FILESDIR}"/${P}-gcc34.patch
- export WANT_AUTOCONF=2.5
- aclocal && automake && autoconf || die "autoconf failed"
+ eautoreconf
}
src_compile() {
@@ -51,7 +47,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
doicon tuxnes.xpm tuxnes2.xpm
dodoc AUTHORS BUGS ChangeLog CHANGES NEWS README THANKS
prepgamesdirs