summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-02 16:11:11 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-02 16:11:11 +0000
commite00212b3d6c5b7a5d90819c88248551c047b34a2 (patch)
treeaa52a3b1d1edda54cfd7ba2b1a6c81150e332380 /games-emulation/tuxnes/files
parentalpha stable wrt #175465 (diff)
downloadgentoo-2-e00212b3d6c5b7a5d90819c88248551c047b34a2.tar.gz
gentoo-2-e00212b3d6c5b7a5d90819c88248551c047b34a2.tar.bz2
gentoo-2-e00212b3d6c5b7a5d90819c88248551c047b34a2.zip
remove need for an executable stack
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'games-emulation/tuxnes/files')
-rw-r--r--games-emulation/tuxnes/files/digest-tuxnes-0.75-r13
-rw-r--r--games-emulation/tuxnes/files/tuxnes-0.75-exec-stack.patch19
-rw-r--r--games-emulation/tuxnes/files/tuxnes-0.75-include.patch51
3 files changed, 73 insertions, 0 deletions
diff --git a/games-emulation/tuxnes/files/digest-tuxnes-0.75-r1 b/games-emulation/tuxnes/files/digest-tuxnes-0.75-r1
new file mode 100644
index 000000000000..aeda4a20064b
--- /dev/null
+++ b/games-emulation/tuxnes/files/digest-tuxnes-0.75-r1
@@ -0,0 +1,3 @@
+MD5 5db0cd42dfdff3e681805e93b4867c43 tuxnes-0.75.tar.gz 198735
+RMD160 d4a94e00f7c90cbf6fbf19537ede22aca05eeafd tuxnes-0.75.tar.gz 198735
+SHA256 217fc57fdd2a5ec360c197ea36110ec929d3f27c88cf875f0f4723b3496ed7c2 tuxnes-0.75.tar.gz 198735
diff --git a/games-emulation/tuxnes/files/tuxnes-0.75-exec-stack.patch b/games-emulation/tuxnes/files/tuxnes-0.75-exec-stack.patch
new file mode 100644
index 000000000000..2e50fd6888e1
--- /dev/null
+++ b/games-emulation/tuxnes/files/tuxnes-0.75-exec-stack.patch
@@ -0,0 +1,19 @@
+--- Makefile.am
++++ Makefile.am
+@@ -10,6 +10,7 @@
+ ziploader.c ziploader.h
+ EXTRA_tuxnes_SOURCES = pixels.h
+ tuxnes_LDADD = table.o
++tuxnes_LDFLAGS = -Wl,-z,noexecstack
+
+ comptbl_SOURCES = comptbl.c
+
+--- x86.S
++++ x86.S
+@@ -1670,3 +1670,6 @@
+ leal 0x1(%eax),%ebx
+ popl %eax
+ jmp i_next
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/games-emulation/tuxnes/files/tuxnes-0.75-include.patch b/games-emulation/tuxnes/files/tuxnes-0.75-include.patch
new file mode 100644
index 000000000000..dec75d9127d8
--- /dev/null
+++ b/games-emulation/tuxnes/files/tuxnes-0.75-include.patch
@@ -0,0 +1,51 @@
+--- comptbl.c
++++ comptbl.c
+@@ -28,6 +28,8 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <stdlib.h>
++#include <string.h>
+
+ #define ALLOC_SIZE 0x48d801 /* approximately 4.69MB */
+ #define TBL_BASE ((unsigned char *)0x10000000)
+--- gamegenie.c
++++ gamegenie.c
+@@ -12,6 +12,7 @@
+
+ #include <ctype.h>
+ #include <stdio.h>
++#include <string.h>
+
+ #include "gamegenie.h"
+
+--- io.c
++++ io.c
+@@ -21,6 +21,7 @@
+ #endif /* HAVE_FEATURES_H */
+
+ #include <stdio.h>
++#include <string.h>
+
+ #include "consts.h"
+ #include "globals.h"
+--- mapper.c
++++ mapper.c
+@@ -13,6 +13,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "consts.h"
+ #include "globals.h"
+--- sound.c
++++ sound.c
+@@ -116,6 +116,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"