summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-27 02:15:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-27 02:15:00 +0000
commit672d95794e944fb5e1dbebf0f78e9b4f4bc29fcc (patch)
tree1e689d58afe8a0368ecfc3ba97601df831a387bd /games-emulation/stella
parentold (Manifest recommit) (diff)
downloadgentoo-2-672d95794e944fb5e1dbebf0f78e9b4f4bc29fcc.tar.gz
gentoo-2-672d95794e944fb5e1dbebf0f78e9b4f4bc29fcc.tar.bz2
gentoo-2-672d95794e944fb5e1dbebf0f78e9b4f4bc29fcc.zip
USE fixups
Diffstat (limited to 'games-emulation/stella')
-rw-r--r--games-emulation/stella/ChangeLog5
-rw-r--r--games-emulation/stella/stella-1.3-r1.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index f811a79d2c82..5001cb5b64eb 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.7 2004/03/13 16:27:57 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.8 2004/05/27 02:15:00 mr_bones_ Exp $
+
+ 26 May 2004; Michael Sterrett <mr_bones_@gentoo.org> stella-1.3-r1.ebuild:
+ USE fixups
13 Mar 2004; Chris Gianelloni <wolf31o2@gentoo.org> stella-1.3.ebuild:
Fixing alsa DEPEND for bug #27746.
diff --git a/games-emulation/stella/stella-1.3-r1.ebuild b/games-emulation/stella/stella-1.3-r1.ebuild
index 38c79ed6056a..1ae1854f22b8 100644
--- a/games-emulation/stella/stella-1.3-r1.ebuild
+++ b/games-emulation/stella/stella-1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-1.3-r1.ebuild,v 1.4 2004/03/02 10:21:11 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-1.3-r1.ebuild,v 1.5 2004/05/27 02:15:00 mr_bones_ Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc"
-IUSE="sdl oss X alsa"
+IUSE="sdl X alsa"
DEPEND="|| (
X? ( virtual/x11 )
@@ -32,14 +32,14 @@ src_compile() {
# let's just default joystick & snapshot support to on
MYOPTS="JOYSTICK_SUPPORT=1 SNAPSHOT_SUPPORT=1"
- if [ `use alsa` ] ; then
+ if use alsa ; then
MYOPTS="${MYOPTS} SOUND_ALSA=1"
fi
- if [ `use X` ] || [ -z "`use X``use sdl`" ] ; then
+ if use X || [ -z "`use X``use sdl`" ] ; then
cd ${S}/src/build
emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS linux-x || die
fi
- if [ `use sdl` ] ; then
+ if use sdl ; then
cd ${S}/src/build
emake OPTIMIZATIONS="${CFLAGS}" $MYOPTS SOUND_SDL=1 linux-sdl || die
fi