summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-08 21:06:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-08 21:06:47 +0000
commit64baf99977a4b6fcdd89d5910d37d6e00123ff71 (patch)
tree065ab8ee59a087b16aa207a1c29f228dd23536c7 /games-emulation/stella
parentBuild with USE=dedicated Bug #397923 (diff)
downloadgentoo-2-64baf99977a4b6fcdd89d5910d37d6e00123ff71.tar.gz
gentoo-2-64baf99977a4b6fcdd89d5910d37d6e00123ff71.tar.bz2
gentoo-2-64baf99977a4b6fcdd89d5910d37d6e00123ff71.zip
version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation/stella')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/stella-3.7.4.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index 334a3561262d..ad32867a95f5 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.72 2012/11/08 19:38:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.73 2012/11/08 21:06:47 mr_bones_ Exp $
+
+*stella-3.7.4 (08 Nov 2012)
+
+ 08 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org> +stella-3.7.4.ebuild:
+ version bump
08 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org> -stella-3.3.ebuild,
-stella-3.4.ebuild, -stella-3.5.ebuild:
diff --git a/games-emulation/stella/stella-3.7.4.ebuild b/games-emulation/stella/stella-3.7.4.ebuild
new file mode 100644
index 000000000000..f732b6c090f3
--- /dev/null
+++ b/games-emulation/stella/stella-3.7.4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-3.7.4.ebuild,v 1.1 2012/11/08 21:06:47 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stella/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="joystick opengl"
+
+DEPEND="media-libs/libsdl[joystick?,opengl?,video]
+ x11-libs/libX11
+ media-libs/libpng:0
+ sys-libs/zlib
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
+ Makefile || die
+ sed -i \
+ -e '/Icon/s/.png//' \
+ -e '/Categories/s/Application;//' \
+ src/unix/stella.desktop || die
+ # build with newer zlib (bug #390093)
+ sed -i -e '60i#define OF(x) x' src/emucore/unzip.h || die
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ local i
+ for i in 16 22 24 32 48 64 128 ; do
+ newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
+ done
+
+ emake DESTDIR="${D}" install || die
+ domenu src/unix/stella.desktop
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}