summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-27 04:51:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-27 04:51:39 +0000
commit6267c5fb937031111b87ff97245953049ac298d3 (patch)
tree1f617d1b850131579e0c4b06d6fe5b22d2df2a6d /games-emulation/snes9x
parentnew patchset w/out redhats check patch (diff)
downloadgentoo-2-6267c5fb937031111b87ff97245953049ac298d3.tar.gz
gentoo-2-6267c5fb937031111b87ff97245953049ac298d3.tar.bz2
gentoo-2-6267c5fb937031111b87ff97245953049ac298d3.zip
Fix reverse save/load keys by Matteo Settenvini #81980.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/ChangeLog8
-rw-r--r--games-emulation/snes9x/files/digest-snes9x-1.43-r11
-rw-r--r--games-emulation/snes9x/files/snes9x-1.43-key-bindings-fix.patch49
-rw-r--r--games-emulation/snes9x/snes9x-1.43-r1.ebuild96
4 files changed, 153 insertions, 1 deletions
diff --git a/games-emulation/snes9x/ChangeLog b/games-emulation/snes9x/ChangeLog
index 328cb8757025..18a1e108f1a2 100644
--- a/games-emulation/snes9x/ChangeLog
+++ b/games-emulation/snes9x/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/snes9x
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.17 2005/07/22 00:05:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.18 2005/08/27 04:51:39 vapier Exp $
+
+*snes9x-1.43-r1 (27 Aug 2005)
+
+ 27 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/snes9x-1.43-key-bindings-fix.patch, +snes9x-1.43-r1.ebuild:
+ Fix reverse save/load keys by Matteo Settenvini #81980.
22 Jul 2005; Mike Frysinger <vapier@gentoo.org>
+files/snes9x-1.43-build.patch, snes9x-1.43.ebuild:
diff --git a/games-emulation/snes9x/files/digest-snes9x-1.43-r1 b/games-emulation/snes9x/files/digest-snes9x-1.43-r1
new file mode 100644
index 000000000000..b8b43bedd773
--- /dev/null
+++ b/games-emulation/snes9x/files/digest-snes9x-1.43-r1
@@ -0,0 +1 @@
+MD5 2b86716203b6ce1dbfe0395c66bb46b5 snes9x-1.43-src.tar.gz 1016251
diff --git a/games-emulation/snes9x/files/snes9x-1.43-key-bindings-fix.patch b/games-emulation/snes9x/files/snes9x-1.43-key-bindings-fix.patch
new file mode 100644
index 000000000000..99ea776ef064
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.43-key-bindings-fix.patch
@@ -0,0 +1,49 @@
+--- snes9x-1.43-src/snes9x/unix/x11.cpp.old 2005-02-14 13:18:59.000000000 +0100
++++ snes9x-1.43-src/snes9x/unix/x11.cpp 2005-02-14 13:20:10.000000000 +0100
+@@ -1213,26 +1213,26 @@
+ // re-enable all sound channels
+ Define(TOGGLE_SOUND, 8, Alt(XK_F12), Ctrl(XK_F12));
+ // numbered quicksaves
+- Define(WRITE_SAVE_NUM, 0, XK_F1);
+- Define(WRITE_SAVE_NUM, 1, XK_F2);
+- Define(WRITE_SAVE_NUM, 2, XK_F3);
+- Define(WRITE_SAVE_NUM, 3, XK_F4);
+- Define(WRITE_SAVE_NUM, 4, XK_F5);
+- Define(WRITE_SAVE_NUM, 5, XK_F6);
+- Define(WRITE_SAVE_NUM, 6, XK_F7);
+- Define(WRITE_SAVE_NUM, 7, XK_F8);
+- Define(WRITE_SAVE_NUM, 8, XK_F9);
+- Define(WRITE_SAVE_NUM, 9, XK_F10);
+- Define(LOAD_SAVE_NUM, 0, Shift(XK_F1));
+- Define(LOAD_SAVE_NUM, 1, Shift(XK_F2));
+- Define(LOAD_SAVE_NUM, 2, Shift(XK_F3));
+- Define(LOAD_SAVE_NUM, 3, Shift(XK_F4));
+- Define(LOAD_SAVE_NUM, 4, Shift(XK_F5));
+- Define(LOAD_SAVE_NUM, 5, Shift(XK_F6));
+- Define(LOAD_SAVE_NUM, 6, Shift(XK_F7));
+- Define(LOAD_SAVE_NUM, 7, Shift(XK_F8));
+- Define(LOAD_SAVE_NUM, 8, Shift(XK_F9));
+- Define(LOAD_SAVE_NUM, 9, Shift(XK_F10));
++ Define(LOAD_SAVE_NUM, 0, XK_F1);
++ Define(LOAD_SAVE_NUM, 1, XK_F2);
++ Define(LOAD_SAVE_NUM, 2, XK_F3);
++ Define(LOAD_SAVE_NUM, 3, XK_F4);
++ Define(LOAD_SAVE_NUM, 4, XK_F5);
++ Define(LOAD_SAVE_NUM, 5, XK_F6);
++ Define(LOAD_SAVE_NUM, 6, XK_F7);
++ Define(LOAD_SAVE_NUM, 7, XK_F8);
++ Define(LOAD_SAVE_NUM, 8, XK_F9);
++ Define(LOAD_SAVE_NUM, 9, XK_F10);
++ Define(WRITE_SAVE_NUM, 0, Shift(XK_F1));
++ Define(WRITE_SAVE_NUM, 1, Shift(XK_F2));
++ Define(WRITE_SAVE_NUM, 2, Shift(XK_F3));
++ Define(WRITE_SAVE_NUM, 3, Shift(XK_F4));
++ Define(WRITE_SAVE_NUM, 4, Shift(XK_F5));
++ Define(WRITE_SAVE_NUM, 5, Shift(XK_F6));
++ Define(WRITE_SAVE_NUM, 6, Shift(XK_F7));
++ Define(WRITE_SAVE_NUM, 7, Shift(XK_F8));
++ Define(WRITE_SAVE_NUM, 8, Shift(XK_F9));
++ Define(WRITE_SAVE_NUM, 9, Shift(XK_F10));
+ // layer toggles
+ Define(TOGGLE_LAYER, 0, XK_1);
+ Define(TOGGLE_LAYER, 1, XK_2);
diff --git a/games-emulation/snes9x/snes9x-1.43-r1.ebuild b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
new file mode 100644
index 000000000000..b2bf42c2c16e
--- /dev/null
+++ b/games-emulation/snes9x/snes9x-1.43-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.1 2005/08/27 04:51:39 vapier Exp $
+
+# 3dfx support (glide) is disabled because it requires
+# glide-v2 while we only provide glide-v3 in portage
+# http://bugs.gentoo.org/show_bug.cgi?id=93097
+
+inherit eutils games flag-o-matic
+
+DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
+HOMEPAGE="http://www.snes9x.com/"
+SRC_URI="http://www.lysator.liu.se/snes9x/${PV}/snes9x-${PV}-src.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="opengl X joystick zlib dga debug"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ virtual/x11
+ media-libs/libpng
+ amd64? ( emul-linux-x86-xlibs )
+ opengl? ( virtual/opengl virtual/glu )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/snes9x
+ epatch "${FILESDIR}"/nojoy.patch
+ epatch "${FILESDIR}"/${P}-key-bindings-fix.patch #81980
+ sed -i 's:png_jmpbuf:png_write_info:g' configure
+
+ rm offsets # stupid prebuilt file
+ sed -i -e 's:-lXext -lX11::' Makefile.in
+ sed -i -e '/X_LDFLAGS=/d' configure
+ cp Makefile.in{,.orig}
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ if use amd64 ; then
+ export ABI=x86
+ append-flags -m32
+ append-ldflags -m32
+ fi
+
+ local vidconf=
+ local target=
+ local vid=
+
+ mkdir mybins
+ for vid in opengl X fallback ; do
+ if [[ ${vid} != "fallback" ]] ; then
+ use ${vid} || continue
+ fi
+ cd "${S}"/snes9x
+ case ${vid} in
+# 3dfx)
+# vidconf="--with-glide --without-opengl --without-x"
+# target=gsnes9x;;
+ opengl)
+ vidconf="--with-opengl --without-glide --without-x"
+ target=osnes9x;;
+ fallback|X)
+ vidconf="--with-x --without-glide --without-opengl"
+ target=snes9x;;
+ esac
+ # this stuff is ugly but hey the build process sucks ;)
+ egamesconf \
+ ${vidconf} \
+ $(use_with x86 assembler) \
+ $(use_with joystick) \
+ $(use_with debug debugger) \
+ $(use_with zlib) \
+ --with-screenshot \
+ $(use_with dga extensions) \
+ || die
+ # Makefile doesnt quite support parallel builds
+ emake -j1 offsets || die "making offsets"
+ emake ${target} || die "making ${target}"
+ mv ${target} "${S}"/mybins/
+ cd "${WORKDIR}"
+ rm -r "${S}"/snes9x
+ src_unpack
+ done
+}
+
+src_install() {
+ dogamesbin mybins/* || die "dogamesbin failed"
+ dodoc faqs.txt readme.txt readme.unix snes9x/*.txt
+ prepgamesdirs
+}