summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-11-10 22:44:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-11-10 22:44:27 +0000
commit5dc97faf3d1fc4b381d809f6f4f073bd48ba4757 (patch)
treeb3b6ea0bd4e4d7806e342d7e0d9cc48747e2f58a /games-emulation/snes9x
parentAdding amd64 keyword for #344661 (diff)
downloadgentoo-2-5dc97faf3d1fc4b381d809f6f4f073bd48ba4757.tar.gz
gentoo-2-5dc97faf3d1fc4b381d809f6f4f073bd48ba4757.tar.bz2
gentoo-2-5dc97faf3d1fc4b381d809f6f4f073bd48ba4757.zip
fix the screenshot configure arg with USE=gtk
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/ChangeLog6
-rw-r--r--games-emulation/snes9x/files/snes9x-1.52-build.patch48
-rw-r--r--games-emulation/snes9x/snes9x-1.52-r1.ebuild5
3 files changed, 43 insertions, 16 deletions
diff --git a/games-emulation/snes9x/ChangeLog b/games-emulation/snes9x/ChangeLog
index 187fad807921..4eb78a0d4552 100644
--- a/games-emulation/snes9x/ChangeLog
+++ b/games-emulation/snes9x/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/snes9x
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.49 2010/09/13 19:18:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.50 2010/11/10 22:44:27 mr_bones_ Exp $
+
+ 10 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ snes9x-1.52-r1.ebuild, files/snes9x-1.52-build.patch:
+ fix the screenshot configure arg with USE=gtk
13 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org>
snes9x-1.52-r1.ebuild:
diff --git a/games-emulation/snes9x/files/snes9x-1.52-build.patch b/games-emulation/snes9x/files/snes9x-1.52-build.patch
index 8c3880f1af6b..ae6794b7318d 100644
--- a/games-emulation/snes9x/files/snes9x-1.52-build.patch
+++ b/games-emulation/snes9x/files/snes9x-1.52-build.patch
@@ -1,5 +1,38 @@
---- unix/configure.ac
-+++ unix/configure.ac
+diff -ru snes9x-1.52-src.orig/gtk/configure.ac snes9x-1.52-src/gtk/configure.ac
+--- snes9x-1.52-src.orig/gtk/configure.ac 2010-01-10 12:27:44.000000000 -0500
++++ snes9x-1.52-src/gtk/configure.ac 2010-11-10 17:33:21.003119007 -0500
+@@ -133,7 +133,7 @@
+ [],
+ [with_zlib=yes])
+
+-AC_ARG_WITH(png,
++AC_ARG_WITH(screenshot,
+ [AS_HELP_STRING([--with(out)-screenshot],
+ [Screenshot support through libpng if available (default: with)])],
+ [],
+@@ -280,7 +280,6 @@
+ echo "--> Disabling Xrandr support."
+ ])
+ fi
+-PKG_CHECK_MODULES([LIBPNG],libpng)
+
+ CFLAGS="$CFLAGS $GTK_CFLAGS $GLIB_CFLAGS $GLADE_CFLAGS $LIBXML_CFLAGS $PORTAUDIO_CFLAGS $LIBPNG_CFLAGS $SDL_CFLAGS $XV_CFLAGS $XRANDR_CFLAGS $ALSA_CFLAGS $PULSEAUDIO_CFLAGS"
+ LIBS="$LIBS $GTK_LIBS $GLIB_LIBS $GLADE_LIBS $LIBXML_LIBS $PORTAUDIO_LIBS $LIBPNG_LIBS $SDL_LIBS $XV_LIBS $XRANDR_LIBS $ALSA_LIBS $PULSEAUDIO_LIBS"
+diff -ru snes9x-1.52-src.orig/unix/Makefile.in snes9x-1.52-src/unix/Makefile.in
+--- snes9x-1.52-src.orig/unix/Makefile.in 2010-01-04 04:13:21.000000000 -0500
++++ snes9x-1.52-src/unix/Makefile.in 2010-11-10 17:32:08.828962612 -0500
+@@ -65,7 +65,7 @@
+ exit 1
+
+ snes9x: $(OBJECTS)
+- $(CCC) $(INCLUDES) -o $@ $(OBJECTS) -lm @S9XLIBS@
++ $(CCC) $(LDFLAGS) $(INCLUDES) -o $@ $(OBJECTS) -lm @S9XLIBS@
+
+ ../jma/s9x-jma.o: ../jma/s9x-jma.cpp
+ $(CCC) $(INCLUDES) -c $(CCFLAGS) -fexceptions $*.cpp -o $@
+diff -ru snes9x-1.52-src.orig/unix/configure.ac snes9x-1.52-src/unix/configure.ac
+--- snes9x-1.52-src.orig/unix/configure.ac 2009-02-26 12:01:16.000000000 -0500
++++ snes9x-1.52-src/unix/configure.ac 2010-11-10 17:32:08.828962612 -0500
@@ -56,20 +56,6 @@
# *** Execution begins here ***
# *****************************
@@ -31,14 +64,3 @@
AC_S9X_COMPILER_FLAG([-fomit-frame-pointer], [omit_frame_pointer])
fi
---- unix/Makefile.in
-+++ unix/Makefile.in
-@@ -65,7 +65,7 @@
- exit 1
-
- snes9x: $(OBJECTS)
-- $(CCC) $(INCLUDES) -o $@ $(OBJECTS) -lm @S9XLIBS@
-+ $(CCC) $(LDFLAGS) $(INCLUDES) -o $@ $(OBJECTS) -lm @S9XLIBS@
-
- ../jma/s9x-jma.o: ../jma/s9x-jma.cpp
- $(CCC) $(INCLUDES) -c $(CCFLAGS) -fexceptions $*.cpp -o $@
diff --git a/games-emulation/snes9x/snes9x-1.52-r1.ebuild b/games-emulation/snes9x/snes9x-1.52-r1.ebuild
index ff691c85f92d..1db76638564c 100644
--- a/games-emulation/snes9x/snes9x-1.52-r1.ebuild
+++ b/games-emulation/snes9x/snes9x-1.52-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.52-r1.ebuild,v 1.8 2010/09/13 19:18:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.52-r1.ebuild,v 1.9 2010/11/10 22:44:27 mr_bones_ Exp $
EAPI=2
inherit autotools eutils flag-o-matic multilib gnome2-utils games
@@ -48,11 +48,12 @@ pkg_setup() {
}
src_prepare() {
+ cd "${WORKDIR}"/${P}-src
epatch "${FILESDIR}"/${P}-build.patch
+ cd unix
eautoreconf
if use gtk; then
cd ../gtk
- sed -i -e '/PKG_CHECK_MODULES(\[LIBPNG/d' configure.ac || die
eautoreconf
fi
}