summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-22 00:05:03 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-22 00:05:03 +0000
commit53c8294a1dddece10d7075f8cc69989e5113d4ef (patch)
treeace8d2e45dc63591021d8879aa31cc6ae0bfb804 /games-emulation/snes9x/files
parentAdd support for Emerald club members #99618 by Paul Varner. (diff)
downloadgentoo-2-53c8294a1dddece10d7075f8cc69989e5113d4ef.tar.gz
gentoo-2-53c8294a1dddece10d7075f8cc69989e5113d4ef.tar.bz2
gentoo-2-53c8294a1dddece10d7075f8cc69989e5113d4ef.zip
Fix amd64 support so it works.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/snes9x/files')
-rw-r--r--games-emulation/snes9x/files/snes9x-1.43-build.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-emulation/snes9x/files/snes9x-1.43-build.patch b/games-emulation/snes9x/files/snes9x-1.43-build.patch
new file mode 100644
index 000000000000..efc9d31fc226
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.43-build.patch
@@ -0,0 +1,34 @@
+Make sure the build process respects our LDFLAGS (so we can slip in -m32)
+and that the stupid custom OPTIMIZE flags arent used in favor of our own
+CFLAGS (so we can slip in -m32).
+
+--- snes9x/Makefile.in
++++ snes9x/Makefile.in
+@@ -16,6 +16,7 @@
+ @DREAMCAST@
+ CHEATS=1
+ 2XSAI=1
++EXTRALIBS=@LDFLAGS@
+
+ #Fairly good and special-char-safe descriptor of the os being built on.
+ OS=`uname -s -r -m|sed \"s/ /-/g\"|tr \"[A-Z]\" \"[a-z]\"|tr \"/()\" \"___\"`
+@@ -186,7 +188,7 @@
+ OPTIMISE=-O4 -ffreestanding -ffast-math -fschedule-insns2 -fomit-frame-pointer -fno-inline-functions -fno-defer-pop -fforce-addr -fstrict-aliasing -funroll-loops -fdelete-null-pointer-checks -fno-exceptions
+ CPUFLAGS=-ml -m4-single-only
+ else
+-OPTIMISE = @OPTIMIZE@
++OPTIMISE = @CFLAGS@
+ endif
+
+ DEFS += \
+@@ -257,8 +259,8 @@
+ @test -d unzip || mkdir unzip
+ @test -d jma || mkdir jma
+
+-offsets: offsets.o
+- $(CCC) $(INCLUDES) -o $@ offsets.o
++offsets: offsets.cpp
++ $(CCC) $(EXTRALIBS) $(INCLUDES) -o $@ offsets.cpp
+ ./offsets >$(srcdir)/$(CPU)/offsets.h #FIXME: Move to builddir
+
+ snes9x: $(OBJECTS) unix/x11.o $(AIDOOBJS)