summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-23 19:33:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-23 19:33:31 +0000
commitf0cebd4fc46d574ab3e685ca8e73be3669dbd9e7 (patch)
treeb43c0f96955f9fcb6ea442ff955f9203ea8ece01 /games-emulation/raine
parentinitial commit (diff)
downloadgentoo-2-f0cebd4fc46d574ab3e685ca8e73be3669dbd9e7.tar.gz
gentoo-2-f0cebd4fc46d574ab3e685ca8e73be3669dbd9e7.tar.bz2
gentoo-2-f0cebd4fc46d574ab3e685ca8e73be3669dbd9e7.zip
Fix building with libpng15 wrt #388255 by Roman Dobosz. Fix building with zlib >= 1.2.5.1-r1 (OF).
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/raine')
-rw-r--r--games-emulation/raine/ChangeLog7
-rw-r--r--games-emulation/raine/files/raine-0.51.9-libpng15.patch13
-rw-r--r--games-emulation/raine/raine-0.51.9.ebuild7
3 files changed, 24 insertions, 3 deletions
diff --git a/games-emulation/raine/ChangeLog b/games-emulation/raine/ChangeLog
index d684cbd84160..4cbd07e270a7 100644
--- a/games-emulation/raine/ChangeLog
+++ b/games-emulation/raine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/raine
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.30 2011/06/16 10:11:03 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.31 2011/10/23 19:33:31 ssuominen Exp $
+
+ 23 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> raine-0.51.9.ebuild,
+ +files/raine-0.51.9-libpng15.patch:
+ Fix building with libpng15 wrt #388255 by Roman Dobosz. Fix building with
+ zlib >= 1.2.5.1-r1 (OF).
16 Jun 2011; Tupone Alfredo <tupone@gentoo.org> raine-0.51.9.ebuild,
+files/raine-0.51.9-underlink.patch:
diff --git a/games-emulation/raine/files/raine-0.51.9-libpng15.patch b/games-emulation/raine/files/raine-0.51.9-libpng15.patch
new file mode 100644
index 000000000000..675df24801dc
--- /dev/null
+++ b/games-emulation/raine/files/raine-0.51.9-libpng15.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/388255
+
+--- source/savepng.c
++++ source/savepng.c
+@@ -203,7 +203,7 @@
+ goto Error;
+
+ /* Set error handling. */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* If we get here, we had a problem reading the file. */
+ goto Error;
+ }
diff --git a/games-emulation/raine/raine-0.51.9.ebuild b/games-emulation/raine/raine-0.51.9.ebuild
index 39451b94bf99..bbf2b288e41e 100644
--- a/games-emulation/raine/raine-0.51.9.ebuild
+++ b/games-emulation/raine/raine-0.51.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/raine-0.51.9.ebuild,v 1.4 2011/06/16 10:11:03 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/raine-0.51.9.ebuild,v 1.5 2011/10/23 19:33:31 ssuominen Exp $
EAPI=2
inherit flag-o-matic eutils games
@@ -35,7 +35,10 @@ src_prepare() {
makefile \
|| die "sed failed"
epatch "${FILESDIR}"/${P}-ldflags.patch \
- "${FILESDIR}"/${P}-underlink.patch
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+ has_version '>=sys-libs/zlib-1.2.5.1-r1' && \
+ sed -i -e '1i#define OF(x) x' source/mini-unzip/ioapi.h
append-ldflags -Wl,-z,noexecstack
}