summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-02-05 00:16:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-02-05 00:16:06 +0000
commit09e621ee7d0b61ad3c38c49504239ec7a5f745c5 (patch)
tree8f5611d53c40fa94ed50b1f210bbd7b203e198de /games-emulation/raine
parentRemove x11-wm/kahakai from tree. (bug #186440) (diff)
downloadgentoo-2-09e621ee7d0b61ad3c38c49504239ec7a5f745c5.tar.gz
gentoo-2-09e621ee7d0b61ad3c38c49504239ec7a5f745c5.tar.bz2
gentoo-2-09e621ee7d0b61ad3c38c49504239ec7a5f745c5.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-emulation/raine')
-rw-r--r--games-emulation/raine/ChangeLog7
-rw-r--r--games-emulation/raine/raine-0.50.7.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/games-emulation/raine/ChangeLog b/games-emulation/raine/ChangeLog
index 1ce85724888d..6c1ee42e83ed 100644
--- a/games-emulation/raine/ChangeLog
+++ b/games-emulation/raine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/raine
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.18 2008/01/11 19:12:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.19 2008/02/05 00:16:06 mr_bones_ Exp $
+
+*raine-0.50.7 (05 Feb 2008)
+
+ 05 Feb 2008; Michael Sterrett <mr_bones_@gentoo.org> +raine-0.50.7.ebuild:
+ version bump
*raine-0.50.6 (11 Jan 2008)
diff --git a/games-emulation/raine/raine-0.50.7.ebuild b/games-emulation/raine/raine-0.50.7.ebuild
new file mode 100644
index 000000000000..f59366fc41e4
--- /dev/null
+++ b/games-emulation/raine/raine-0.50.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/raine-0.50.7.ebuild,v 1.1 2008/02/05 00:16:06 mr_bones_ Exp $
+
+inherit versionator games
+
+MY_PV=$(replace_version_separator 3 '-')
+
+DESCRIPTION="R A I N E M680x0 Arcade Emulation"
+HOMEPAGE="http://www.rainemu.com/"
+SRC_URI="http://www.rainemu.com/html/archive/raines-${MY_PV}.tar.bz2
+ http://www.rainemu.com/html/archive/rainedocs.zip
+ http://www.rainemu.com/html/archive/icons.zip"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+
+RDEPEND="media-libs/allegro
+ media-libs/libsdl
+ sys-libs/zlib
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range -3)
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo > detect-cpu
+ echo > cpuinfo
+ sed -i \
+ -e "/prefix =/s:/usr::" \
+ -e "s:nasm -r:echo nasm:" \
+ -e "/bindir/s:=.*:=\$(DESTDIR)${GAMES_BINDIR}:" \
+ -e "/sharedir =/s:=.*:=\$(DESTDIR)${GAMES_DATADIR}:" \
+ -e "/mandir/s:=.*:=\$(DESTDIR)/usr/share/man/man6:" \
+ makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ local myopts=
+ use static \
+ && myopts="${myopts} STATIC=1" \
+ || myopts="${myopts} STATIC="
+ emake \
+ _MARCH="${CFLAGS}" \
+ ${myopts} || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ keepdir "${GAMES_DATADIR}"/${PN}/{roms,artwork,emudx}
+ dodoc "${WORKDIR}/raine.txt"
+
+ insinto /usr/share/icons
+ doins "${WORKDIR}/"*.png
+ make_desktop_entry raine Raine Raine48x48
+ prepgamesdirs
+}