summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-28 00:50:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-28 00:50:17 +0000
commit874a7aa474cbd0e5fba5cd09491baa6e17d3143a (patch)
tree95cac940ea310c38e8337372f452f0cd39a6cf96 /games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild
parentversion bump (bug 34548) (diff)
downloadgentoo-2-874a7aa474cbd0e5fba5cd09491baa6e17d3143a.tar.gz
gentoo-2-874a7aa474cbd0e5fba5cd09491baa6e17d3143a.tar.bz2
gentoo-2-874a7aa474cbd0e5fba5cd09491baa6e17d3143a.zip
version bump (bug 34548)
Diffstat (limited to 'games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild')
-rw-r--r--games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild b/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild
new file mode 100644
index 000000000000..562c7db5408e
--- /dev/null
+++ b/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild,v 1.1 2003/11/28 00:50:15 mr_bones_ Exp $
+
+inherit games eutils
+
+S="${WORKDIR}/padJoy/src"
+DESCRIPTION="PSEmu plugin to use joysticks/gamepads in PSX-emulators"
+HOMEPAGE="http://www.ammoq.com/"
+SRC_URI="http://members.chello.at/erich.kitzmueller/ammoq/padJoy${PV//.}.tgz"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="=x11-libs/gtk+-1*
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:-O2 -fomit-frame-pointer:${CFLAGS}:" Makefile || \
+ die "sed Makefile failed"
+}
+
+src_install() {
+ exeinto "${GAMES_LIBDIR}/psemu/plugins"
+ doexe libpadJoy-* || die "doexe failed"
+ exeinto "${GAMES_LIBDIR}/psemu/cfg"
+ doexe cfgPadJoy || die "doexe failed (2)"
+ dodoc ../readme.txt || die "dodoc failed"
+ prepgamesdirs
+}