summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-29 22:47:45 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-29 22:47:45 +0000
commitb3e83a83088a7d2a1eeaf655350f937f453205ea (patch)
treefd83081e13edbde17df4132133277197f7dd7531 /games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild
parentmore pixel shaders #39767 (diff)
downloadgentoo-2-b3e83a83088a7d2a1eeaf655350f937f453205ea.tar.gz
gentoo-2-b3e83a83088a7d2a1eeaf655350f937f453205ea.tar.bz2
gentoo-2-b3e83a83088a7d2a1eeaf655350f937f453205ea.zip
more pixel shaders #39767
Diffstat (limited to 'games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild')
-rw-r--r--games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild b/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild
new file mode 100644
index 000000000000..87660a4d8f8d
--- /dev/null
+++ b/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild,v 1.1 2004/01/29 22:47:45 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu MesaGL GPU"
+HOMEPAGE="http://home.t-online.de/home/PeteBernert/"
+SRC_URI="http://home.t-online.de/home/PeteBernert/gpupetexgl${PVR//.}.tar.gz
+ http://home.t-online.de/home/PeteBernert/pete_ogl2_shader_simpleblur.zip
+ http://home.t-online.de/home/PeteBernert/pete_ogl2_shader_scale2x.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/opengl"
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto ${GAMES_LIBDIR}/psemu/plugins
+ doexe lib*
+ exeinto ${GAMES_LIBDIR}/psemu/cfg
+ doexe cfgPeteXGL2
+ insinto ${GAMES_LIBDIR}/psemu/cfg
+ doins gpuPeteXGL2.cfg
+ # now do our shader files!
+ insinto ${GAMES_LIBDIR}/psemu/shaders
+ doins *.fp *.vp *.slf *.slv
+ dodoc *.txt
+ prepgamesdirs
+}