summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-09-26 18:37:30 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-09-26 18:37:30 +0000
commit7876d0a20c82b0b6dba217445448a01d4af26d24 (patch)
tree446109c1191d90bb3435cca5a9890330a53c7601 /games-emulation/psemu-cdriso
parentStable on hppa wrt #149051 (diff)
downloadgentoo-2-7876d0a20c82b0b6dba217445448a01d4af26d24.tar.gz
gentoo-2-7876d0a20c82b0b6dba217445448a01d4af26d24.tar.bz2
gentoo-2-7876d0a20c82b0b6dba217445448a01d4af26d24.zip
Let portage strip binaries, bug #137829
(Portage version: 2.1.2_pre1-r3)
Diffstat (limited to 'games-emulation/psemu-cdriso')
-rw-r--r--games-emulation/psemu-cdriso/ChangeLog7
-rw-r--r--games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild20
2 files changed, 16 insertions, 11 deletions
diff --git a/games-emulation/psemu-cdriso/ChangeLog b/games-emulation/psemu-cdriso/ChangeLog
index 826b93b7d3bf..4f8b546dbedb 100644
--- a/games-emulation/psemu-cdriso/ChangeLog
+++ b/games-emulation/psemu-cdriso/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/psemu-cdriso
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdriso/ChangeLog,v 1.6 2005/09/26 17:47:57 wolf31o2 Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdriso/ChangeLog,v 1.7 2006/09/26 18:37:30 nyhm Exp $
+
+ 26 Sep 2006; Tristan Heaven <nyhm@gentoo.org> psemu-cdriso-1.4.ebuild:
+ Let portage strip binaries, bug #137829
26 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org>
psemu-cdriso-1.4.ebuild:
diff --git a/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild b/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild
index 224cb087bb8d..73baa01bfe4e 100644
--- a/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild
+++ b/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild,v 1.8 2005/09/26 17:47:57 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild,v 1.9 2006/09/26 18:37:30 nyhm Exp $
inherit eutils games
@@ -15,27 +15,29 @@ IUSE=""
DEPEND="sys-libs/zlib
app-arch/bzip2
- =x11-libs/gtk+-1*
+ =x11-libs/gtk+-1.2*
dev-util/pkgconfig"
-S="${WORKDIR}/cdriso"
+S=${WORKDIR}/cdriso
src_unpack() {
unpack ${A}
epatch "${FILESDIR}/${PV}-makefile-cflags.patch"
+ cd "${S}"
+ sed -i '/strip/d' src/Linux/Makefile || die "sed failed"
}
src_compile() {
cd src/Linux
- emake OPTFLAGS="${CFLAGS}" || die
+ emake OPTFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
dodoc ReadMe.txt
cd src/Linux
- exeinto ${GAMES_LIBDIR}/psemu/plugins
- doexe libcdriso-*
- exeinto ${GAMES_LIBDIR}/psemu/cfg
- doexe cfgCdrIso
+ exeinto "${GAMES_LIBDIR}"/psemu/plugins
+ doexe libcdriso-* || die "doexe failed"
+ exeinto "${GAMES_LIBDIR}"/psemu/cfg
+ doexe cfgCdrIso || die "doexe failed"
prepgamesdirs
}