summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-07 07:13:45 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-07 07:13:45 +0000
commit36a4418de66624653361f7327bb35effa1f9f77e (patch)
tree679f2f85d0f5607033bbf844bd2e98c4880be217 /games-emulation/ps2emu-gssoft
parentVersion 1.0.2 tested and works on MIPS. Added ~mips keyword. (diff)
downloadgentoo-2-36a4418de66624653361f7327bb35effa1f9f77e.tar.gz
gentoo-2-36a4418de66624653361f7327bb35effa1f9f77e.tar.bz2
gentoo-2-36a4418de66624653361f7327bb35effa1f9f77e.zip
Version bump and clean up amd64 support.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/ps2emu-gssoft')
-rw-r--r--games-emulation/ps2emu-gssoft/ChangeLog8
-rw-r--r--games-emulation/ps2emu-gssoft/files/digest-ps2emu-gssoft-0.91
-rw-r--r--games-emulation/ps2emu-gssoft/files/ps2emu-gssoft-0.9-gentoo.patch45
-rw-r--r--games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild42
4 files changed, 95 insertions, 1 deletions
diff --git a/games-emulation/ps2emu-gssoft/ChangeLog b/games-emulation/ps2emu-gssoft/ChangeLog
index e7a8a13436de..7b85d45be5ab 100644
--- a/games-emulation/ps2emu-gssoft/ChangeLog
+++ b/games-emulation/ps2emu-gssoft/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/ps2emu-gssoft
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ChangeLog,v 1.6 2005/08/07 04:53:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ChangeLog,v 1.7 2005/08/07 07:13:45 vapier Exp $
+
+*ps2emu-gssoft-0.9 (07 Aug 2005)
+
+ 07 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/ps2emu-gssoft-0.9-gentoo.patch, +ps2emu-gssoft-0.9.ebuild:
+ Version bump and clean up amd64 support.
*ps2emu-gssoft-0.6.1 (12 Dec 2003)
diff --git a/games-emulation/ps2emu-gssoft/files/digest-ps2emu-gssoft-0.9 b/games-emulation/ps2emu-gssoft/files/digest-ps2emu-gssoft-0.9
new file mode 100644
index 000000000000..c99f621f0e20
--- /dev/null
+++ b/games-emulation/ps2emu-gssoft/files/digest-ps2emu-gssoft-0.9
@@ -0,0 +1 @@
+MD5 ece45f6b9b0956d94e79984a5f024234 GSsoft0.9.rar 330468
diff --git a/games-emulation/ps2emu-gssoft/files/ps2emu-gssoft-0.9-gentoo.patch b/games-emulation/ps2emu-gssoft/files/ps2emu-gssoft-0.9-gentoo.patch
new file mode 100644
index 000000000000..cc705ab2a4b1
--- /dev/null
+++ b/games-emulation/ps2emu-gssoft/files/ps2emu-gssoft-0.9-gentoo.patch
@@ -0,0 +1,45 @@
+--- Src/Texts.c
++++ Src/Texts.c
+@@ -17,6 +17,7 @@
+ */
+
+ #include <math.h>
++#include <string.h>
+
+ #include "GS.h"
+ #include "Texts.h"
+--- Src/Linux/Conf.c
++++ Src/Linux/Conf.c
+@@ -21,6 +21,7 @@
+ #include <sys/types.h>
+ #include <fcntl.h>
+ #include <unistd.h>
++#include <string.h>
+
+ #include "GS.h"
+
+--- Src/x86/ix86_cpudetect.c
++++ Src/x86/ix86_cpudetect.c
+@@ -124,16 +124,19 @@
+
+ __asm__ __volatile__ (
+ #ifdef __x86_64__
++#define AX "%%rax"
+ "sub $0x18, %%rsp\n"
++#else
++#define AX "%%eax"
+ #endif
+ "pushf\n"
+- "pop %%eax\n"
++ "pop "AX"\n"
+ "mov %%eax, %%edx\n"
+ "xor $0x200000, %%eax\n"
+- "push %%eax\n"
++ "push "AX"\n"
+ "popf\n"
+ "pushf\n"
+- "pop %%eax\n"
++ "pop "AX"\n"
+ "xor %%edx, %%eax\n"
+ "mov %%eax, %0\n"
+ #ifdef __x86_64__
diff --git a/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild b/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild
new file mode 100644
index 000000000000..a16c2a83291a
--- /dev/null
+++ b/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.9.ebuild,v 1.1 2005/08/07 07:13:45 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu2 GPU plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.8release/GSsoft${PV}.rar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ media-libs/libsdl
+ virtual/x11
+ =x11-libs/gtk+-1*"
+DEPEND="${RDEPEND}
+ app-arch/unrar"
+
+S=${WORKDIR}/GSsoft${PV}
+
+src_unpack() {
+ unrar x -idq "${DISTDIR}"/${A}
+ cd "${S}"
+ sed -i 's:-O2 -fomit-frame-pointer -ffast-math:$(OPTFLAGS):' Src/Linux/Makefile || die
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ cd Src/Linux
+ emake OPTFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ exeinto "${GAMES_LIBDIR}"/ps2emu/plugins
+ newexe Src/Linux/libGSsoft.so libGSsoft-${PV}.so || die
+ prepgamesdirs
+}