summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-12 22:07:54 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-12 22:07:54 +0000
commitb8fbd0b44041bbfe9c7a00afc33cac6e6c34ccd5 (patch)
treefdba159cce5636abc16114249ec18bed69228fd0 /games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild
parentno -r1 for cdvdiso (diff)
downloadgentoo-2-b8fbd0b44041bbfe9c7a00afc33cac6e6c34ccd5.tar.gz
gentoo-2-b8fbd0b44041bbfe9c7a00afc33cac6e6c34ccd5.tar.bz2
gentoo-2-b8fbd0b44041bbfe9c7a00afc33cac6e6c34ccd5.zip
inital ebuild
Diffstat (limited to 'games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild')
-rw-r--r--games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild b/games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild
new file mode 100644
index 000000000000..49e3872b8216
--- /dev/null
+++ b/games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild,v 1.1 2003/12/12 22:07:54 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu2 NULL Sound plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.5release/dev9null${PV}.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/gtk+-1*"
+
+S=${WORKDIR}/dev9null
+
+src_unpack() {
+ unpack ${A}
+ sed -i 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' ${S}/src/Makefile
+}
+
+src_compile() {
+ cd src
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ exeinto ${GAMES_LIBDIR}/ps2emu/plugins
+ newexe src/libDEV9null.so libDEV9null-${PV}.so
+ prepgamesdirs
+}