summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-04 09:26:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-04 09:26:46 +0000
commitd4e0c0deb214f0ab2ce692455daa1e3ccdeca8ec (patch)
tree21d79ca4f3a1c16565311f3d23e249d885d021e5 /games-emulation/openmsx
parentinitial commit; ebuild based on the one by Tony Vroon via bug 32397 (diff)
downloadgentoo-2-d4e0c0deb214f0ab2ce692455daa1e3ccdeca8ec.tar.gz
gentoo-2-d4e0c0deb214f0ab2ce692455daa1e3ccdeca8ec.tar.bz2
gentoo-2-d4e0c0deb214f0ab2ce692455daa1e3ccdeca8ec.zip
initial commit; ebuild based on the one by Tony Vroon via bug 32397
Diffstat (limited to 'games-emulation/openmsx')
-rw-r--r--games-emulation/openmsx/ChangeLog9
-rw-r--r--games-emulation/openmsx/Manifest4
-rw-r--r--games-emulation/openmsx/files/digest-openmsx-0.3.31
-rw-r--r--games-emulation/openmsx/metadata.xml9
-rw-r--r--games-emulation/openmsx/openmsx-0.3.3.ebuild62
5 files changed, 84 insertions, 1 deletions
diff --git a/games-emulation/openmsx/ChangeLog b/games-emulation/openmsx/ChangeLog
new file mode 100644
index 000000000000..52af17460265
--- /dev/null
+++ b/games-emulation/openmsx/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-emulation/openmsx
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.1 2003/11/04 09:26:44 mr_bones_ Exp $
+
+*openmsx-0.3.3 (04 Nov 2003)
+
+ 04 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> openmsx-0.3.3.ebuild:
+ initial commit; ebuild based on the one by Tony Vroon via bug 32397
+
diff --git a/games-emulation/openmsx/Manifest b/games-emulation/openmsx/Manifest
index 3e780f94c15a..64932aa26d04 100644
--- a/games-emulation/openmsx/Manifest
+++ b/games-emulation/openmsx/Manifest
@@ -1,2 +1,4 @@
-MD5 a1c64db6f79c68bba39736ce579b040f openmsx-0.3.3.ebuild 1968
+MD5 462f4c0d458bd4224d27192bc9967b25 openmsx-0.3.3.ebuild 1782
+MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 cd39be73711f765439eb307f57f5eb27 ChangeLog 409
MD5 57a5a827ee242bcd74d41dd135924b95 files/digest-openmsx-0.3.3 66
diff --git a/games-emulation/openmsx/files/digest-openmsx-0.3.3 b/games-emulation/openmsx/files/digest-openmsx-0.3.3
new file mode 100644
index 000000000000..327b25cb7d69
--- /dev/null
+++ b/games-emulation/openmsx/files/digest-openmsx-0.3.3
@@ -0,0 +1 @@
+MD5 898affabb1cc2a67b2ff58960aad747e openmsx-0.3.3.tar.gz 1045348
diff --git a/games-emulation/openmsx/metadata.xml b/games-emulation/openmsx/metadata.xml
new file mode 100644
index 000000000000..1cef6e243af3
--- /dev/null
+++ b/games-emulation/openmsx/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>games@gentoo.org</email>
+<name>Games Team</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-emulation/openmsx/openmsx-0.3.3.ebuild b/games-emulation/openmsx/openmsx-0.3.3.ebuild
new file mode 100644
index 000000000000..d9e3ddbf7afd
--- /dev/null
+++ b/games-emulation/openmsx/openmsx-0.3.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.3.3.ebuild,v 1.1 2003/11/04 09:26:44 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="MSX emulator that aims for perfection"
+HOMEPAGE="http://openmsx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="x86 ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/libxml2
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/sdl-image
+ media-libs/libsdl
+ virtual/x11
+ virtual/opengl"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # Remove all symlinking from the Makefile.in
+ sed -i \
+ -e "/ln /d" Makefile.in || \
+ die "sed Makefile.in failed"
+
+ # Change the hardcoded default SystemDir.
+ sed -i \
+ -e "s:/opt/openMSX/:${GAMES_DATADIR}/${PN}/:" \
+ src/file/FileOperations.cc || \
+ die "sed FileOperations.cc failed"
+}
+
+src_install() {
+ egamesinstall prefix="${D}${GAMES_DATADIR}/${PN}" \
+ bindir=${D}${GAMES_BINDIR} || die
+
+ dosym ${GAMES_DATADIR}/${PN}/share/machines/National_CF-1200 \
+ ${GAMES_DATADIR}/${PN}/share/machines/msx1
+ dosym ${GAMES_DATADIR}/${PN}/share/machines/Philips_NMS_8250 \
+ ${GAMES_DATADIR}/${PN}/share/machines/msx2
+ dosym ${GAMES_DATADIR}/${PN}/share/machines/Panasonic_FS-A1FX \
+ ${GAMES_DATADIR}/${PN}/share/machines/msx2plus
+ dosym ${GAMES_DATADIR}/${PN}/share/machines/Panasonic_FS-A1GT \
+ ${GAMES_DATADIR}/${PN}/share/machines/turbor
+
+ dodoc README AUTHORS NEWS ${D}${GAMES_DATADIR}/openmsx/*.{txt,tex} || \
+ die "dodoc failed"
+ dohtml -r doc/* || die "dohtml failed"
+
+ # Tidy up install
+ rm -f ${D}${GAMES_DATADIR}/openmsx/*.{txt,tex,html,png,css}
+ find ${D}${GAMES_DATADIR} -type f -exec chmod a-x \{\} \;
+
+ prepgamesdirs
+}