summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-08-15 10:20:47 +0000
committerMichał Górny <mgorny@gentoo.org>2014-08-15 10:20:47 +0000
commit52cfd74135279a9843726b6d6c5b4d1ee5f47409 (patch)
tree34288f9f51b95f506eab7438ce29ac98fcd4b9e8 /games-emulation/mupen64plus-video-rice
parentRemove games team maintainership following the Council decision. Use standard... (diff)
downloadgentoo-2-52cfd74135279a9843726b6d6c5b4d1ee5f47409.tar.gz
gentoo-2-52cfd74135279a9843726b6d6c5b4d1ee5f47409.tar.bz2
gentoo-2-52cfd74135279a9843726b6d6c5b4d1ee5f47409.zip
Remove games team maintainership following the Council decision. Use standard install layout.
(Portage version: 2.2.11_p72/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-emulation/mupen64plus-video-rice')
-rw-r--r--games-emulation/mupen64plus-video-rice/ChangeLog11
-rw-r--r--games-emulation/mupen64plus-video-rice/metadata.xml1
-rw-r--r--games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.0-r1.ebuild81
3 files changed, 90 insertions, 3 deletions
diff --git a/games-emulation/mupen64plus-video-rice/ChangeLog b/games-emulation/mupen64plus-video-rice/ChangeLog
index 265a44674a43..b369887a3760 100644
--- a/games-emulation/mupen64plus-video-rice/ChangeLog
+++ b/games-emulation/mupen64plus-video-rice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-emulation/mupen64plus-video-rice
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-video-rice/ChangeLog,v 1.3 2013/12/19 16:55:02 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-video-rice/ChangeLog,v 1.4 2014/08/15 10:20:47 mgorny Exp $
+
+*mupen64plus-video-rice-2.0-r1 (15 Aug 2014)
+
+ 15 Aug 2014; Michał Górny <mgorny@gentoo.org>
+ +mupen64plus-video-rice-2.0-r1.ebuild, metadata.xml:
+ Remove games team maintainership following the Council decision. Use standard
+ install layout.
19 Dec 2013; Michał Górny <mgorny@gentoo.org>
mupen64plus-video-rice-2.0.ebuild:
diff --git a/games-emulation/mupen64plus-video-rice/metadata.xml b/games-emulation/mupen64plus-video-rice/metadata.xml
index 9047711e4ffd..955f381367d5 100644
--- a/games-emulation/mupen64plus-video-rice/metadata.xml
+++ b/games-emulation/mupen64plus-video-rice/metadata.xml
@@ -1,7 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>games</herd>
<maintainer>
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
diff --git a/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.0-r1.ebuild b/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.0-r1.ebuild
new file mode 100644
index 000000000000..3a8b3c0120fd
--- /dev/null
+++ b/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.0-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.0-r1.ebuild,v 1.1 2014/08/15 10:20:47 mgorny Exp $
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, rice video plugin"
+HOMEPAGE="http://code.google.com/p/mupen64plus/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sse"
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.0-r1:0=
+ media-libs/libpng:0=
+ media-libs/libsdl:0=[video]
+ virtual/opengl:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl)"
+
+ NO_ASM=$(usex sse 0 1)
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}