summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-19 05:58:18 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-19 05:58:18 +0000
commit5b3c37ba9d557520c308437c6615ef9156487d68 (patch)
tree1c037ad6028591dff4f6c545545799b2a366a4b3 /games-emulation/mupen64
parentplanet ccrma custom kernel sources (diff)
downloadgentoo-2-5b3c37ba9d557520c308437c6615ef9156487d68.tar.gz
gentoo-2-5b3c37ba9d557520c308437c6615ef9156487d68.tar.bz2
gentoo-2-5b3c37ba9d557520c308437c6615ef9156487d68.zip
version bump #29016
Diffstat (limited to 'games-emulation/mupen64')
-rw-r--r--games-emulation/mupen64/ChangeLog7
-rw-r--r--games-emulation/mupen64/files/0.3-gcc3.patch118
-rw-r--r--games-emulation/mupen64/files/digest-mupen64-0.36
-rw-r--r--games-emulation/mupen64/files/mupen647
-rw-r--r--games-emulation/mupen64/mupen64-0.3.ebuild69
5 files changed, 203 insertions, 4 deletions
diff --git a/games-emulation/mupen64/ChangeLog b/games-emulation/mupen64/ChangeLog
index 8ab349b2c159..e61de83d3926 100644
--- a/games-emulation/mupen64/ChangeLog
+++ b/games-emulation/mupen64/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/mupen64
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/ChangeLog,v 1.2 2003/09/10 16:02:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/ChangeLog,v 1.3 2003/09/19 05:58:18 vapier Exp $
+
+*mupen64-0.3 (19 Sep 2003)
+
+ 19 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #29016.
*mupen64-0.2 (03 Sep 2003)
diff --git a/games-emulation/mupen64/files/0.3-gcc3.patch b/games-emulation/mupen64/files/0.3-gcc3.patch
new file mode 100644
index 000000000000..28a018e22e48
--- /dev/null
+++ b/games-emulation/mupen64/files/0.3-gcc3.patch
@@ -0,0 +1,118 @@
+diff -ur riceplugin.orig/DaedalusGraphics.cpp riceplugin/DaedalusGraphics.cpp
+--- riceplugin.orig/DaedalusGraphics.cpp 2003-09-19 01:22:36.335328472 -0400
++++ riceplugin/DaedalusGraphics.cpp 2003-09-19 01:22:36.470307952 -0400
+@@ -18,6 +18,7 @@
+ */
+ #include "stdafx.h"
+ #include "_BldNum.h"
++#include <assert.h>
+
+ #ifndef _WIN32
+ #include <unistd.h>
+diff -ur riceplugin.orig/DecodedMux.cpp riceplugin/DecodedMux.cpp
+--- riceplugin.orig/DecodedMux.cpp 2003-09-19 01:22:36.366323760 -0400
++++ riceplugin/DecodedMux.cpp 2003-09-19 01:22:48.379497480 -0400
+@@ -760,7 +760,7 @@
+ ShadeConstMergeMapType MergeShadeWithConstantsMaps[] =
+ {
+ 0, SHADE_DO_NOTHING,
+- 0x0007000600070006, SHADE_MOD_ENV, // SHADE * ENV
++ SHADE_DO_NOTHING, SHADE_MOD_ENV, // SHADE * ENV
+ };
+
+ // 0x05070501, 0x00070006 //(1 - PRIM) * ENV + PRIM
+diff -ur riceplugin.orig/OGLCombinerTNT2.cpp riceplugin/OGLCombinerTNT2.cpp
+--- riceplugin.orig/OGLCombinerTNT2.cpp 2003-09-19 01:22:36.340327712 -0400
++++ riceplugin/OGLCombinerTNT2.cpp 2003-09-19 01:25:36.859884568 -0400
+@@ -120,22 +120,22 @@
+
+ GLenum COGLColorCombinerTNT2::RGBArgsMap[] =
+ {
+- {GL_ZERO, }, //MUX_0
+- {GL_ZERO, }, //MUX_1
+- {GL_PREVIOUS_EXT, }, //MUX_COMBINED,
+- {GL_TEXTURE0_ARB, }, //MUX_TEXEL0,
+- {GL_TEXTURE1_ARB, }, //MUX_TEXEL1,
+- {GL_CONSTANT_EXT, }, //MUX_PRIM,
+- {GL_PRIMARY_COLOR_EXT, }, //MUX_SHADE,
+- {GL_CONSTANT_EXT, }, //MUX_ENV,
+- {GL_PREVIOUS_EXT, }, //MUX_COMBALPHA,
+- {GL_TEXTURE0_ARB, }, //MUX_T0_ALPHA,
+- {GL_TEXTURE1_ARB, }, //MUX_T1_ALPHA,
+- {GL_CONSTANT_EXT, }, //MUX_PRIM_ALPHA,
+- {GL_PRIMARY_COLOR_EXT, }, //MUX_SHADE_ALPHA,
+- {GL_CONSTANT_EXT, }, //MUX_ENV_ALPHA,
+- {GL_CONSTANT_EXT, }, //MUX_LODFRAC,
+- {GL_CONSTANT_EXT, }, //MUX_PRIMLODFRAC,
++ GL_ZERO,
++ GL_ZERO,
++ GL_PREVIOUS_EXT,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_EXT,
++ GL_PRIMARY_COLOR_EXT,
++ GL_CONSTANT_EXT,
++ GL_PREVIOUS_EXT,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_EXT,
++ GL_PRIMARY_COLOR_EXT,
++ GL_CONSTANT_EXT,
++ GL_CONSTANT_EXT,
++ GL_CONSTANT_EXT,
+ };
+
+
+diff -ur riceplugin.orig/OGLExtCombiner.cpp riceplugin/OGLExtCombiner.cpp
+--- riceplugin.orig/OGLExtCombiner.cpp 2003-09-19 01:22:36.371323000 -0400
++++ riceplugin/OGLExtCombiner.cpp 2003-09-19 01:24:56.994944960 -0400
+@@ -474,22 +474,22 @@
+
+ GLenum COGLExtColorCombiner::RGBArgsMap[] =
+ {
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_0
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_1
+- {GL_PREVIOUS_ARB, }, //MUX_COMBINED,
+- {GL_TEXTURE0_ARB, }, //MUX_TEXEL0,
+- {GL_TEXTURE1_ARB, }, //MUX_TEXEL1,
+- {GL_CONSTANT_ARB, }, //MUX_PRIM,
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_SHADE,
+- {GL_CONSTANT_ARB, }, //MUX_ENV,
+- {GL_PREVIOUS_ARB, }, //MUX_COMBALPHA,
+- {GL_TEXTURE0_ARB, }, //MUX_T0_ALPHA,
+- {GL_TEXTURE1_ARB, }, //MUX_T1_ALPHA,
+- {GL_CONSTANT_ARB, }, //MUX_PRIM_ALPHA,
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_SHADE_ALPHA,
+- {GL_CONSTANT_ARB, }, //MUX_ENV_ALPHA,
+- {GL_CONSTANT_ARB, }, //MUX_LODFRAC,
+- {GL_CONSTANT_ARB, }, //MUX_PRIMLODFRAC,
++ GL_PRIMARY_COLOR_ARB,
++ GL_PRIMARY_COLOR_ARB,
++ GL_PREVIOUS_ARB,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_ARB,
++ GL_PRIMARY_COLOR_ARB,
++ GL_CONSTANT_ARB,
++ GL_PREVIOUS_ARB,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_ARB,
++ GL_PRIMARY_COLOR_ARB,
++ GL_CONSTANT_ARB,
++ GL_CONSTANT_ARB,
++ GL_CONSTANT_ARB,
+ };
+
+
+diff -ur riceplugin.orig/unique.h riceplugin/unique.h
+--- riceplugin.orig/unique.h 2003-09-19 01:22:36.336328320 -0400
++++ riceplugin/unique.h 2003-09-19 01:22:36.473307496 -0400
+@@ -39,6 +39,7 @@
+ //
+ //
+
++#include <assert.h>
+ #ifdef _MSC_VER
+ #include <crtdbg.h>
+ #endif
diff --git a/games-emulation/mupen64/files/digest-mupen64-0.3 b/games-emulation/mupen64/files/digest-mupen64-0.3
new file mode 100644
index 000000000000..849358b90e59
--- /dev/null
+++ b/games-emulation/mupen64/files/digest-mupen64-0.3
@@ -0,0 +1,6 @@
+MD5 b40d563140fcda84661b9fa7a8f83747 mupen64_src-0.3.tar.bz2 1058587
+MD5 14fc6075a19bb567afebedd5ab2ea6c1 mupen64_input.tar.bz2 4438
+MD5 3d24b2d5e8c20abbb00765dd58ba1f79 mupen64_sound.tar.bz2 4646
+MD5 28e9b7f55f5bd5b832a9200769c90f17 tr64_oglv078_src.tar.bz2 285068
+MD5 862e83746234bc296a748bd2e17051bd mupen64_hle_rsp.tar.bz2 24951
+MD5 9e41f47820f89942855e26a4c4d73a1c riceplugin.tar.bz2 266387
diff --git a/games-emulation/mupen64/files/mupen64 b/games-emulation/mupen64/files/mupen64
index ef2ad4c06d8e..14e7969ab83a 100644
--- a/games-emulation/mupen64/files/mupen64
+++ b/games-emulation/mupen64/files/mupen64
@@ -1,11 +1,12 @@
#!/bin/sh
if [ ! -d ~/.mupen64/save ] ; then
- mkdir -p ~/.mupen64/{save,plugins}
+ mkdir -p ~/.mupen64/save
cd ~/.mupen64
- ln -s GENTOO_DIR/plugins/* plugins/
+ ln -s GENTOO_DIR/plugins plugins
ln -s GENTOO_DIR/mupen64 mupen64
+ ln -s GENTOO_DIR/mupen64_nogui mupen64_nogui
fi
cd ~/.mupen64
-GENTOO_DIR/mupen64 $@
+exec GENTOO_DIR/$(basename $0) "$@"
diff --git a/games-emulation/mupen64/mupen64-0.3.ebuild b/games-emulation/mupen64/mupen64-0.3.ebuild
new file mode 100644
index 000000000000..579e38f9df98
--- /dev/null
+++ b/games-emulation/mupen64/mupen64-0.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/mupen64-0.3.ebuild,v 1.1 2003/09/19 05:58:18 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="A Nintendo 64 (N64) emulator"
+SRC_URI="http://mupen64.emulation64.com/files/src/mupen64_src-${PV}.tar.bz2
+ http://mupen64.emulation64.com/files/src/mupen64_input.tar.bz2
+ http://mupen64.emulation64.com/files/src/mupen64_sound.tar.bz2
+ http://mupen64.emulation64.com/files/src/tr64_oglv078_src.tar.bz2
+ http://mupen64.emulation64.com/files/src/mupen64_hle_rsp.tar.bz2
+ http://mupen64.emulation64.com/files/src/riceplugin.tar.bz2"
+#SRC_URI="http://mupen64.emulation64.com/files/${P}.tar.bz2"
+HOMEPAGE="http://mupen64.emulation64.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=sys-apps/sed-4
+ media-libs/libsdl
+ virtual/glu
+ virtual/opengl"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+ sed -i "/^CC/s:-O3.*-Wall:${CFLAGS}:" \
+ emu64/Makefile \
+ mupen64_input/Makefile
+ sed -i "/^CFLAGS/s:-O3.*-march=athlon:${CFLAGS}:" mupen64_sound/Makefile
+ sed -i "/^CFLAGS/s:-O3.*$:${CFLAGS}:" \
+ riceplugin/Makefile \
+ rsp_hle/Makefile \
+ tr64_oglv078_src/Makefile
+}
+
+src_compile() {
+ for d in * ; do
+ cd ${S}/${d}
+ emake || die "failed on $d"
+ done
+}
+
+src_install() {
+ local dir=${GAMES_LIBDIR}/${PN}
+ dodir ${dir}
+
+ exeinto ${dir}/plugins
+ doexe */*.so
+ insinto ${dir}/plugins
+ doins */*.ini
+ rm ${D}/${dir}/plugins/mupen64*.ini
+
+ cd emu64
+ cp -r mupen64* lang plugins save roms path.cfg ${D}/${dir}/
+ rm ${D}/${dir}/mupen64_test.ini
+ dogamesbin ${FILESDIR}/mupen64
+ dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/mupen64
+ newgamesbin ${FILESDIR}/mupen64 mupen64_nogui
+ dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/mupen64_nogui
+ dodoc *.txt doc/readme.pdf
+
+ prepgamesdirs
+}