summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-13 21:31:11 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-13 21:31:11 +0000
commit21c511c159c02cdbbdf1eaf9b950ac66eb894022 (patch)
tree38385a6ddf153f3856b0c7c29469b6106243ee16 /games-emulation/mupen64
parentPatch for gcc-4.2 (diff)
downloadgentoo-2-21c511c159c02cdbbdf1eaf9b950ac66eb894022.tar.gz
gentoo-2-21c511c159c02cdbbdf1eaf9b950ac66eb894022.tar.bz2
gentoo-2-21c511c159c02cdbbdf1eaf9b950ac66eb894022.zip
Patch for gcc-4.2
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-emulation/mupen64')
-rw-r--r--games-emulation/mupen64/ChangeLog6
-rw-r--r--games-emulation/mupen64/files/mupen64-0.5-gcc42.patch22
-rw-r--r--games-emulation/mupen64/files/mupen64-0.5-gentoo3.patch4
-rw-r--r--games-emulation/mupen64/mupen64-0.5-r4.ebuild5
4 files changed, 32 insertions, 5 deletions
diff --git a/games-emulation/mupen64/ChangeLog b/games-emulation/mupen64/ChangeLog
index afcdf90fe58f..73914f40dd4b 100644
--- a/games-emulation/mupen64/ChangeLog
+++ b/games-emulation/mupen64/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/ChangeLog,v 1.25 2007/03/28 00:58:24 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/ChangeLog,v 1.26 2007/06/13 21:31:11 nyhm Exp $
+
+ 13 Jun 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/mupen64-0.5-gcc42.patch, mupen64-0.5-r4.ebuild:
+ Patch for gcc-4.2
*mupen64-0.5-r4 (28 Mar 2007)
diff --git a/games-emulation/mupen64/files/mupen64-0.5-gcc42.patch b/games-emulation/mupen64/files/mupen64-0.5-gcc42.patch
new file mode 100644
index 000000000000..b2d2fdb2fcc1
--- /dev/null
+++ b/games-emulation/mupen64/files/mupen64-0.5-gcc42.patch
@@ -0,0 +1,22 @@
+--- glN64/glATI.h
++++ glN64/glATI.h
+@@ -864,8 +864,8 @@
+ typedef GLuint (APIENTRY *PFNGLGENFRAGMENTSHADERSATIPROC)(GLuint range);
+ typedef GLvoid (APIENTRY *PFNGLBINDFRAGMENTSHADERATIPROC)(GLuint id);
+ typedef GLvoid (APIENTRY *PFNGLDELETEFRAGMENTSHADERATIPROC)(GLuint id);
+-typedef GLvoid (APIENTRY *PFNGLBEGINFRAGMENTSHADERATIPROC)(GLvoid);
+-typedef GLvoid (APIENTRY *PFNGLENDFRAGMENTSHADERATIPROC)(GLvoid);
++typedef GLvoid (APIENTRY *PFNGLBEGINFRAGMENTSHADERATIPROC)(void);
++typedef GLvoid (APIENTRY *PFNGLENDFRAGMENTSHADERATIPROC)(void);
+ typedef GLvoid (APIENTRY *PFNGLPASSTEXCOORDATIPROC)(GLuint dst, GLuint coord, GLenum swizzle);
+ typedef GLvoid (APIENTRY *PFNGLSAMPLEMAPATIPROC)(GLuint dst, GLuint interp, GLenum swizzle);
+ typedef GLvoid (APIENTRY *PFNGLCOLORFRAGMENTOP1ATIPROC)(GLenum op, GLuint dst, GLuint dstMask,
+@@ -2194,7 +2194,7 @@
+ typedef GLvoid (APIENTRY * PFNGLDELETEOCCLUSIONQUERIESNVPROC) (GLsizei n, const GLuint *ids);
+ typedef GLboolean (APIENTRY * PFNGLISOCCLUSIONQUERYNVPROC) (GLuint id);
+ typedef GLvoid (APIENTRY * PFNGLBEGINOCCLUSIONQUERYNVPROC) (GLuint id);
+-typedef GLvoid (APIENTRY * PFNGLENDOCCLUSIONQUERYNVPROC) (GLvoid);
++typedef GLvoid (APIENTRY * PFNGLENDOCCLUSIONQUERYNVPROC) (void);
+ typedef GLvoid (APIENTRY * PFNGLGETOCCLUSIONQUERYIVNVPROC) (GLuint id, GLenum pname, GLint *params);
+ typedef GLvoid (APIENTRY * PFNGLGETOCCLUSIONQUERYUIVNVPROC) (GLuint id, GLenum pname, GLuint *params);
+
diff --git a/games-emulation/mupen64/files/mupen64-0.5-gentoo3.patch b/games-emulation/mupen64/files/mupen64-0.5-gentoo3.patch
index 047fe8c13119..75a17a04b209 100644
--- a/games-emulation/mupen64/files/mupen64-0.5-gentoo3.patch
+++ b/games-emulation/mupen64/files/mupen64-0.5-gentoo3.patch
@@ -18,8 +18,8 @@ diff -ruN mupen64_src-0.5.orig/Makefile mupen64_src-0.5/Makefile
#CFLAGS =-DX86 -Wall -pipe -g
-CXXFLAGS =$(CFLAGS)
-+CFLAGS += -fPIC
-+CXXFLAGS += -fPIC
++CFLAGS += -fPIC -fno-strict-aliasing
++CXXFLAGS += -fPIC -fno-strict-aliasing
+
+CXXFLAGS ?=$(CFLAGS)
diff --git a/games-emulation/mupen64/mupen64-0.5-r4.ebuild b/games-emulation/mupen64/mupen64-0.5-r4.ebuild
index accf6445c897..3ecfcc480dfe 100644
--- a/games-emulation/mupen64/mupen64-0.5-r4.ebuild
+++ b/games-emulation/mupen64/mupen64-0.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/mupen64-0.5-r4.ebuild,v 1.3 2007/04/23 11:52:52 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/mupen64-0.5-r4.ebuild,v 1.4 2007/06/13 21:31:11 nyhm Exp $
inherit eutils multilib games
@@ -41,7 +41,8 @@ src_unpack() {
"${FILESDIR}"/${P}-anisotropic.patch \
"${FILESDIR}"/${P}-gentoo3.patch \
"${FILESDIR}"/${PN}-glN64-ucode.patch \
- "${FILESDIR}"/${PN}-glN64-noasmfix.patch
+ "${FILESDIR}"/${PN}-glN64-noasmfix.patch \
+ "${FILESDIR}"/${P}-gcc42.patch
sed -i \
-e "s:#undef WITH_HOME:#define WITH_HOME \"$(games_get_libdir)/\":" \