summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-10-12 01:18:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-10-12 01:18:36 +0000
commit9ea977a4b2e3a5d8fa267d77392ea826fc55af3c (patch)
tree25cd774b7cdf661d3318c6c98d63c833c66c4b1e /games-emulation/hatari
parentVersion bump. (diff)
downloadgentoo-2-9ea977a4b2e3a5d8fa267d77392ea826fc55af3c.tar.gz
gentoo-2-9ea977a4b2e3a5d8fa267d77392ea826fc55af3c.tar.bz2
gentoo-2-9ea977a4b2e3a5d8fa267d77392ea826fc55af3c.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation/hatari')
-rw-r--r--games-emulation/hatari/ChangeLog7
-rw-r--r--games-emulation/hatari/hatari-1.3.1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
index 1be842bc52d8..814ab5f0b4dd 100644
--- a/games-emulation/hatari/ChangeLog
+++ b/games-emulation/hatari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/hatari
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.24 2009/08/24 21:02:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.25 2009/10/12 01:18:36 mr_bones_ Exp $
+
+*hatari-1.3.1 (12 Oct 2009)
+
+ 12 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org> +hatari-1.3.1.ebuild:
+ version bump
*hatari-1.3.0 (24 Aug 2009)
diff --git a/games-emulation/hatari/hatari-1.3.1.ebuild b/games-emulation/hatari/hatari-1.3.1.ebuild
new file mode 100644
index 000000000000..23bd702429ff
--- /dev/null
+++ b/games-emulation/hatari/hatari-1.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-1.3.1.ebuild,v 1.1 2009/10/12 01:18:36 mr_bones_ Exp $
+
+EAPI=2
+inherit games
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.berlios.de/"
+SRC_URI="mirror://berlios/hatari/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[X,audio,video]
+ sys-libs/readline
+ media-libs/libpng
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ games-emulation/emutos"
+
+src_compile() {
+ # broken deps in the makefiles - bug #164068
+ emake -C src/uae-cpu gencpu || die "emake failed"
+ emake -C src/uae-cpu all || die "emake failed"
+ emake -C src || die "emake failed"
+}
+
+src_install() {
+ dogamesbin "${S}/src/hatari" || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins src/gui-sdl/font5x8.bmp src/gui-sdl/font10x16.bmp \
+ || die "doins failed"
+ dodoc readme.txt doc/*.txt
+ dohtml -r doc/
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
+ elog "has been installed in $(games_get_libdir) with a .img extension (there"
+ elog "are several from which to choose)."
+ elog
+ elog "Another option is to go to http://www.atari.st/ and get a real TOS:"
+ elog " http://www.atari.st/"
+ elog
+ elog "The first time you run hatari, you should configure it to find the"
+ elog "TOS you prefer to use. Be sure to save your settings."
+ echo
+}