summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-06-13 10:45:58 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-06-13 10:45:58 +0000
commit8a9f528849fab5b0378bec97f9d18b80f57ac56f (patch)
treef30d7d5c201e2e13b6257e65ab752d770bcc62c8 /games-emulation/hatari
parentuse python-single-r1, add dev-python/pygtk dep, fix hatariui and docdir path (diff)
downloadgentoo-2-8a9f528849fab5b0378bec97f9d18b80f57ac56f.tar.gz
gentoo-2-8a9f528849fab5b0378bec97f9d18b80f57ac56f.tar.bz2
gentoo-2-8a9f528849fab5b0378bec97f9d18b80f57ac56f.zip
version bump wrt #424321
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-emulation/hatari')
-rw-r--r--games-emulation/hatari/ChangeLog8
-rw-r--r--games-emulation/hatari/files/hatari-1.6.2-gentoo-docdir.patch13
-rw-r--r--games-emulation/hatari/files/hatari-1.6.2-gentoo.patch112
-rw-r--r--games-emulation/hatari/hatari-1.6.2.ebuild86
4 files changed, 218 insertions, 1 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
index f9c3e1034170..f614116b31ae 100644
--- a/games-emulation/hatari/ChangeLog
+++ b/games-emulation/hatari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/hatari
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.40 2013/06/13 10:37:26 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.41 2013/06/13 10:45:58 hasufell Exp $
+
+*hatari-1.6.2 (13 Jun 2013)
+
+ 13 Jun 2013; Julian Ospald <hasufell@gentoo.org> +hatari-1.6.2.ebuild,
+ +files/hatari-1.6.2-gentoo.patch, +files/hatari-1.6.2-gentoo-docdir.patch:
+ version bump wrt #424321
*hatari-1.6.1-r1 (13 Jun 2013)
diff --git a/games-emulation/hatari/files/hatari-1.6.2-gentoo-docdir.patch b/games-emulation/hatari/files/hatari-1.6.2-gentoo-docdir.patch
new file mode 100644
index 000000000000..715fb189143f
--- /dev/null
+++ b/games-emulation/hatari/files/hatari-1.6.2-gentoo-docdir.patch
@@ -0,0 +1,13 @@
+--- hatari-1.6.1/python-ui/uihelpers.py
++++ hatari-1.6.1/python-ui/uihelpers.py
+@@ -97,9 +97,7 @@
+ # first try whether there are local Hatari docs in standard place
+ # for this Hatari/UI version
+ sep = os.sep
+- path = self.get_binary_path("hatari")
+- path = sep.join(path.split(sep)[:-2]) # remove "bin/hatari"
+- path = path + sep + "share" + sep + "doc" + sep + "hatari" + sep
++ path = "@DOCDIR@"
+ if os.path.exists(path + "manual.html"):
+ return path
+ # if not, point to latest Hatari HG version docs
diff --git a/games-emulation/hatari/files/hatari-1.6.2-gentoo.patch b/games-emulation/hatari/files/hatari-1.6.2-gentoo.patch
new file mode 100644
index 000000000000..4f10d6d9e3ce
--- /dev/null
+++ b/games-emulation/hatari/files/hatari-1.6.2-gentoo.patch
@@ -0,0 +1,112 @@
+--- hatari-1.4.0.orig/src/paths.c
++++ hatari-1.4.0/src/paths.c
+@@ -109,71 +109,6 @@
+ free(pTmpName);
+ }
+
+-
+-/**
+- * Locate the directory where the hatari executable resides
+- */
+-static char *Paths_InitExecDir(const char *argv0)
+-{
+- char *psExecDir; /* Path string where the hatari executable can be found */
+-
+- /* Allocate memory for storing the path string of the executable */
+- psExecDir = malloc(FILENAME_MAX);
+- if (!psExecDir)
+- {
+- fprintf(stderr, "Out of memory (Paths_Init)\n");
+- exit(-1);
+- }
+-
+- /* Determine the bindir...
+- * Start with empty string, then try to use OS specific functions,
+- * and finally analyze the PATH variable if it has not been found yet. */
+- psExecDir[0] = '\0';
+-
+-#if defined(__linux__)
+- {
+- int i;
+- /* On Linux, we can analyze the symlink /proc/self/exe */
+- i = readlink("/proc/self/exe", psExecDir, FILENAME_MAX);
+- if (i > 0)
+- {
+- char *p;
+- psExecDir[i] = '\0';
+- p = strrchr(psExecDir, '/'); /* Search last slash */
+- if (p)
+- *p = 0; /* Strip file name from path */
+- }
+- }
+-//#elif defined(WIN32) || defined(__CEGCC__)
+-// /* On Windows we can use GetModuleFileName for getting the exe path */
+-// GetModuleFileName(NULL, psExecDir, FILENAME_MAX);
+-#endif
+-
+- /* If we do not have the execdir yet, analyze argv[0] and the PATH: */
+- if (psExecDir[0] == 0)
+- {
+- if (strchr(argv0, PATHSEP) == 0)
+- {
+- /* No separator in argv[0], we have to explore PATH... */
+- Paths_GetExecDirFromPATH(argv0, psExecDir, FILENAME_MAX);
+- }
+- else
+- {
+- /* There was a path separator in argv[0], so let's assume a
+- * relative or absolute path to the current directory in argv[0] */
+- char *p;
+- strncpy(psExecDir, argv0, FILENAME_MAX);
+- psExecDir[FILENAME_MAX-1] = 0;
+- p = strrchr(psExecDir, PATHSEP); /* Search last slash */
+- if (p)
+- *p = 0; /* Strip file name from path */
+- }
+- }
+-
+- return psExecDir;
+-}
+-
+-
+ /**
+ * Initialize the users home directory string
+ * and Hatari's home directory (~/.hatari)
+@@ -226,8 +161,6 @@
+ */
+ void Paths_Init(const char *argv0)
+ {
+- char *psExecDir; /* Path string where the hatari executable can be found */
+-
+ /* Init working directory string */
+ if (getcwd(sWorkingDir, FILENAME_MAX) == NULL)
+ {
+@@ -238,27 +171,11 @@
+ /* Init the user's home directory string */
+ Paths_InitHomeDirs();
+
+- /* Get the directory where the executable resides */
+- psExecDir = Paths_InitExecDir(argv0);
+-
+- /* Now create the datadir path name from the bindir path name: */
+- if (psExecDir && strlen(psExecDir) > 0)
+- {
+- snprintf(sDataDir, sizeof(sDataDir), "%s%c%s",
+- psExecDir, PATHSEP, BIN2DATADIR);
+- }
+- else
+- {
+- /* bindir could not be determined, let's assume datadir is relative
+- * to current working directory... */
+- strcpy(sDataDir, BIN2DATADIR);
+- }
++ strcpy(sDataDir, BIN2DATADIR);
+
+ /* And finally make a proper absolute path out of datadir: */
+ File_MakeAbsoluteName(sDataDir);
+
+- free(psExecDir);
+-
+ /* fprintf(stderr, " WorkingDir = %s\n DataDir = %s\n UserHomeDir = %s\n HatariHomeDir = %s\n",
+ sWorkingDir, sDataDir, sUserHomeDir, sHatariHomeDir); */
+ }
diff --git a/games-emulation/hatari/hatari-1.6.2.ebuild b/games-emulation/hatari/hatari-1.6.2.ebuild
new file mode 100644
index 000000000000..650792d252a0
--- /dev/null
+++ b/games-emulation/hatari/hatari-1.6.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-1.6.2.ebuild,v 1.1 2013/06/13 10:45:58 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+inherit eutils toolchain-funcs cmake-utils python-single-r1 games
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.berlios.de/"
+SRC_URI="http://download.tuxfamily.org/hatari/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/libsdl[X,audio,video]
+ sys-libs/readline
+ media-libs/libpng
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ games-emulation/emutos"
+
+pkg_setup() {
+ games_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-gentoo-docdir.patch
+ # build with newer zlib (bug #387829)
+ sed -i -e '1i#define OF(x) x' src/includes/unzip.h || die
+ sed -i -e '/Encoding/d' ./python-ui/hatariui.desktop || die
+ sed -i -e "s/python/${EPYTHON}/" tools/atari-hd-image.sh || die
+ sed -i \
+ -e "s%conf=.*$%conf=\"${GAMES_SYSCONFDIR}\"%" \
+ -e "s%path=.*$%path=\"${GAMES_DATADIR}/${PN}/hatariui\"%" \
+ python-ui/hatariui || die
+ sed -i -e "s#@DOCDIR@#/usr/share/doc/${PF}/html/#" python-ui/uihelpers.py || die
+ rm -f doc/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ "-DCMAKE_BUILD_TYPE:STRING=Release"
+ "-DDATADIR=${GAMES_DATADIR}/${PN}"
+ "-DBIN2DATADIR=${GAMES_DATADIR}/${PN}"
+ "-DBINDIR=${GAMES_BINDIR}"
+ "-DICONDIR=/usr/share/pixmaps"
+ "-DDESKTOPDIR=/usr/share/applications"
+ "-DMANDIR=/usr/share/man/man1"
+ "-DDOCDIR=/usr/share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ DOCS="readme.txt doc/*.txt" cmake-utils_src_install
+ dohtml -r doc/
+ python_fix_shebang "${ED%/}"/usr/share/games/hatari/{hatariui,hconsole}/*.py
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
+ elog "has been installed in $(games_get_libdir) with a .img extension (there"
+ elog "are several from which to choose)."
+ elog
+ elog "Another option is to go to http://www.atari.st/ and get a real TOS:"
+ elog " http://www.atari.st/"
+ elog
+ elog "The first time you run hatari, you should configure it to find the"
+ elog "TOS you prefer to use. Be sure to save your settings."
+ echo
+}