summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-08 01:09:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-08 01:09:16 +0000
commit7ae1529c5bd9e86b2fbb5be8f837fa7fad9e4cf1 (patch)
treecd37ca53d25253e235cd685313d2481c18b21a7a /games-emulation/hatari
parentversion bump (diff)
downloadgentoo-2-7ae1529c5bd9e86b2fbb5be8f837fa7fad9e4cf1.tar.gz
gentoo-2-7ae1529c5bd9e86b2fbb5be8f837fa7fad9e4cf1.tar.bz2
gentoo-2-7ae1529c5bd9e86b2fbb5be8f837fa7fad9e4cf1.zip
version bump
Diffstat (limited to 'games-emulation/hatari')
-rw-r--r--games-emulation/hatari/ChangeLog7
-rw-r--r--games-emulation/hatari/Manifest4
-rw-r--r--games-emulation/hatari/files/digest-hatari-0.451
-rw-r--r--games-emulation/hatari/hatari-0.45.ebuild58
4 files changed, 67 insertions, 3 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
index 39d42f006520..746f0fc40189 100644
--- a/games-emulation/hatari/ChangeLog
+++ b/games-emulation/hatari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/hatari
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.4 2003/09/19 07:38:30 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.5 2003/11/08 01:09:14 mr_bones_ Exp $
+
+*hatari-0.45 (07 Nov 2003)
+
+ 07 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> hatari-0.45.ebuild:
+ version bump
19 Sep 2003; Michael Sterrett <msterret@gentoo.org> hatari-0.40.ebuild,
metadata.xml:
diff --git a/games-emulation/hatari/Manifest b/games-emulation/hatari/Manifest
index 803b2bf253a1..d76dbbfe4b97 100644
--- a/games-emulation/hatari/Manifest
+++ b/games-emulation/hatari/Manifest
@@ -1,6 +1,6 @@
-MD5 5ca3a34057a4ed73e01654f2a46e92f8 ChangeLog 1101
+MD5 6e7864e1c2e20a0157d9688416e17461 ChangeLog 1221
MD5 66b6059cdb78b87685bd9d9706625d2d hatari-0.40.ebuild 1386
MD5 95e2b5bfd7767aeae061c77f7e1a055e metadata.xml 221
-MD5 3747bd2abd6aaabe6c4c3b13ee0e2e36 hatari-0.45.ebuild 1433
+MD5 baa16f82fc4f47b0bac0b5635a0c393a hatari-0.45.ebuild 1556
MD5 3e8a51349887e732bbc7c357a71afd70 files/digest-hatari-0.40 63
MD5 805ba6098c50b3ada3ee70778d225fc3 files/digest-hatari-0.45 63
diff --git a/games-emulation/hatari/files/digest-hatari-0.45 b/games-emulation/hatari/files/digest-hatari-0.45
new file mode 100644
index 000000000000..1a9c4315ac78
--- /dev/null
+++ b/games-emulation/hatari/files/digest-hatari-0.45
@@ -0,0 +1 @@
+MD5 945a1b8789deaf2978c81de062ad97d0 hatari-0.45.tar.gz 474055
diff --git a/games-emulation/hatari/hatari-0.45.ebuild b/games-emulation/hatari/hatari-0.45.ebuild
new file mode 100644
index 000000000000..494354713a17
--- /dev/null
+++ b/games-emulation/hatari/hatari-0.45.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-0.45.ebuild,v 1.1 2003/11/08 01:09:14 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Atari ST emulator"
+SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
+HOMEPAGE="http://hatari.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc"
+SLOT="0"
+
+RDEPEND="games-emulation/emutos
+ media-libs/libsdl
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "/^CFLAGS/ s:-O3.*:${CFLAGS}:" \
+ -e "/^DATADIR/ s:=.*:= ${GAMES_DATADIR}/${PN}:" Makefile.cnf || \
+ die "sed Makefile.cnf failed"
+}
+
+src_compile() {
+ cd src
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${S}/src/hatari || die "dogamesbin failed"
+ insinto ${GAMES_DATADIR}/${PN}
+ doins src/font8.bmp || die "doins failed"
+ dodoc readme.txt doc/*.txt || die "dodoc failed"
+ dohtml doc/ || die "dohtml failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
+ einfo "has been installed in /usr/games/lib/ with a .img extension (there"
+ einfo "are several from which to choose)."
+ echo
+ einfo "Another option is to go to http://www.atari.st/ and get a real TOS:"
+ einfo " http://www.atari.st/"
+ echo
+ einfo "The first time you run hatari, you should configure it to find the"
+ einfo "TOS you prefer to use. Be sure to save your settings."
+ echo
+}