summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-22 00:11:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-22 00:11:21 +0000
commit1a0eac671057ffc788e5d127804316bd25de797a (patch)
tree8162ca3484c5be41284422873cc69c0d723fe949 /games-emulation/goosnes
parenttweak comments, touchup syntax, and in general tweak (diff)
downloadgentoo-2-1a0eac671057ffc788e5d127804316bd25de797a.tar.gz
gentoo-2-1a0eac671057ffc788e5d127804316bd25de797a.tar.bz2
gentoo-2-1a0eac671057ffc788e5d127804316bd25de797a.zip
fixup autotools, add support for games eclass, and add amd64 KEYWORDS
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/goosnes')
-rw-r--r--games-emulation/goosnes/goosnes-0.5.2.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/games-emulation/goosnes/goosnes-0.5.2.ebuild b/games-emulation/goosnes/goosnes-0.5.2.ebuild
index e42e66368482..00f366d6779c 100644
--- a/games-emulation/goosnes/goosnes-0.5.2.ebuild
+++ b/games-emulation/goosnes/goosnes-0.5.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/goosnes/goosnes-0.5.2.ebuild,v 1.7 2004/11/11 01:37:04 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/goosnes/goosnes-0.5.2.ebuild,v 1.8 2005/07/22 00:11:21 vapier Exp $
+
+inherit games
DESCRIPTION="A GTK+ frontend for Snes9X"
HOMEPAGE="http://bard.sytes.net/goosnes/"
@@ -8,27 +10,32 @@ SRC_URI="http://bard.sytes.net/debian/dists/unstable/main/source/${PN}_${PV}-1.t
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="amd64 ppc x86"
IUSE="gtk2"
-DEPEND="|| (
+DEPEND="dev-libs/libxml2
gtk2? ( =x11-libs/gtk+-2* )
- =x11-libs/gtk+-1*
- )
- dev-libs/libxml2"
+ !gtk2? ( =x11-libs/gtk+-1* )"
RDEPEND="${DEPEND}
games-emulation/snes9x"
-
DEPEND="${DEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # packaging is broken
+ aclocal && autoheader && autoconf && automake || die
+}
+
src_compile() {
use gtk2 && myconf="--with-gtk-version=2.0"
- econf ${myconf} || die
+ egamesconf ${myconf} || die
emake || die "emake failed"
}
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog README
+ prepgamesdirs
}