summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-28 01:45:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-28 01:45:43 +0000
commitd4c90c2befa04241179ddb3519db20cf74798f41 (patch)
tree7f03b464011c153b56e85d6348cc83026a919989 /games-emulation/generator
parentFix src_test(). (diff)
downloadgentoo-2-d4c90c2befa04241179ddb3519db20cf74798f41.tar.gz
gentoo-2-d4c90c2befa04241179ddb3519db20cf74798f41.tar.bz2
gentoo-2-d4c90c2befa04241179ddb3519db20cf74798f41.zip
newer nasm fails with the old asm (bug #294916)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation/generator')
-rw-r--r--games-emulation/generator/ChangeLog8
-rw-r--r--games-emulation/generator/generator-0.35_p3.ebuild42
2 files changed, 20 insertions, 30 deletions
diff --git a/games-emulation/generator/ChangeLog b/games-emulation/generator/ChangeLog
index f3b23256bb56..abeabde5ddc8 100644
--- a/games-emulation/generator/ChangeLog
+++ b/games-emulation/generator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/generator
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/ChangeLog,v 1.23 2008/06/02 06:33:10 corsair Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/ChangeLog,v 1.24 2009/11/28 01:45:43 mr_bones_ Exp $
+
+ 28 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ generator-0.35_p3.ebuild:
+ newer nasm fails with the old asm (bug #294916)
02 Jun 2008; Markus Rothe <corsair@gentoo.org> generator-0.35_p3.ebuild:
Stable on ppc; bug #220427
diff --git a/games-emulation/generator/generator-0.35_p3.ebuild b/games-emulation/generator/generator-0.35_p3.ebuild
index fea2d1ddc4ce..4072cb96c847 100644
--- a/games-emulation/generator/generator-0.35_p3.ebuild
+++ b/games-emulation/generator/generator-0.35_p3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35_p3.ebuild,v 1.6 2008/06/02 06:33:10 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35_p3.ebuild,v 1.7 2009/11/28 01:45:43 mr_bones_ Exp $
+EAPI=2
inherit autotools eutils toolchain-funcs games
MY_P=${PN}-${PV/_p/-cbiere-r}
@@ -12,35 +13,21 @@ SRC_URI="http://www.ghostwhitecrab.com/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="sdlaudio svga"
+IUSE="+sdlaudio svga"
-RDEPEND="media-libs/jpeg
- media-libs/libsdl
+DEPEND="media-libs/jpeg
+ media-libs/libsdl[joystick,video]
+ sdlaudio? ( media-libs/libsdl[audio] )
svga? ( media-libs/svgalib )"
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
mkdir my-bins
epatch \
- "${FILESDIR}"/${P}-execstacks.patch \
"${FILESDIR}"/${P}-configure.patch
- # make it yasm-syntax-friendly
- sed -i \
- -e 's/-praze/-Praze/' \
- raze/Makefile.am \
- || die 'sed failed'
- # USE32 is redundent with elf
- sed -i \
- -e 's/USE32//' \
- raze/raze.asm.in \
- || die 'sed failed'
sed -i \
-e 's/@GTK_CFLAGS@//g' \
main/Makefile.am \
@@ -48,13 +35,13 @@ src_unpack() {
eautoreconf
}
+src_configure() {
+ :
+}
+
# builds SDL by default since otherwise -svga builds nothing
src_compile() {
- local myconf mygui myguis
-
- use x86 \
- && myconf="--with-raze" \
- || myconf="--with-cmz80"
+ local mygui myguis
myguis="sdl"
use svga && myguis="${myguis} svgalib"
@@ -62,9 +49,8 @@ src_compile() {
for mygui in ${myguis}; do
[[ -f Makefile ]] && emake clean
egamesconf \
- ${myconf} \
+ --with-cmz80 \
--with-${mygui} \
- --without-gtk \
--without-tcltk \
--with-gcc=$(gcc-major-version) \
$(use_with sdlaudio sdl-audio) \