summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-13 05:35:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-13 05:35:35 +0000
commit5e578bec9be4fd6ae725209bf03f5099e0cf963a (patch)
tree8924247fd6665b6ca7b3b4c31ecb652f78c556d0 /games-emulation/fceux
parentMarked ppc stable for bug #335825. (diff)
downloadgentoo-2-5e578bec9be4fd6ae725209bf03f5099e0cf963a.tar.gz
gentoo-2-5e578bec9be4fd6ae725209bf03f5099e0cf963a.tar.bz2
gentoo-2-5e578bec9be4fd6ae725209bf03f5099e0cf963a.zip
fix building with USE=-lua
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation/fceux')
-rw-r--r--games-emulation/fceux/ChangeLog5
-rw-r--r--games-emulation/fceux/fceux-2.1.4a.ebuild9
2 files changed, 12 insertions, 2 deletions
diff --git a/games-emulation/fceux/ChangeLog b/games-emulation/fceux/ChangeLog
index 37e5f9356d7c..df8798fcfa9d 100644
--- a/games-emulation/fceux/ChangeLog
+++ b/games-emulation/fceux/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/fceux
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.5 2010/07/26 21:28:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.6 2010/09/13 05:35:35 mr_bones_ Exp $
+
+ 13 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org> fceux-2.1.4a.ebuild:
+ fix building with USE=-lua
*fceux-2.1.4a (26 Jul 2010)
diff --git a/games-emulation/fceux/fceux-2.1.4a.ebuild b/games-emulation/fceux/fceux-2.1.4a.ebuild
index 8e8b87e496fb..14fa4656817b 100644
--- a/games-emulation/fceux/fceux-2.1.4a.ebuild
+++ b/games-emulation/fceux/fceux-2.1.4a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.4a.ebuild,v 1.1 2010/07/26 21:28:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.4a.ebuild,v 1.2 2010/09/13 05:35:35 mr_bones_ Exp $
EAPI=2
inherit games
@@ -28,6 +28,13 @@ RDEPEND="${RDEPEND}
S=${WORKDIR}/fceu${PV}
+src_prepare() {
+ # mentioned in bug #335836
+ if ! use lua ; then
+ sed -i -e '/_S9XLUA_H/d' SConstruct || die
+ fi
+}
+
src_compile() {
local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
scons \